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Introduction

Overview
Welcome to the MultiSurf tutorials. If you are coming to MultiSurf as a mechanical 
CAD user, you’ll be entering a new world, because surface modeling and solid 
modeling have somewhat different approaches or styles (for details, see “Basic 
Concepts” in the User’s Guide). Therefore, the focus of these tutorials is two-fold:

• To introduce you to specific MultiSurf functions and entities

• To help you become comfortable working in the surface modeling style

The first lesson introduces you to the new user interface and some of its features.  In 
the second lesson, we will build a simple model to demonstrate some basic MultiSurf 
methods. Then we’ll move on to acquainting you with the wealth of MultiSurf 
entities. In later lessons, we will concentrate on creating and modifying somewhat 
more complex models.

To make the most of your tutorial experience, we recommend you give yourself 
plenty of time, so you don’t feel the need to rush. You can, of course, stop part way 
through any of them. 

And don’t worry about trying to understand every last detail at each step. As you 
work through the guided tour and get more of a feel for MultiSurf , you’ll find that 
concepts and techniques will become familiar and clear.

We recommend that you read “Basic Concepts” (in the User’s Guide or online help) 
before you launch into the tutorials.

Using the Online Tutorials
For those of you who would like to run the tutorials from online (rather than printed) 
instructions, you can open the online file in either of two ways:

• On the Windows task bar, choose Start>Programs>AeroHydro>MultiSurf 
Tutorials.

• In Windows Explorer, go to the \MultiSurf folder and double-click on the file 
Marine Tutorials.chm.

Size and arrange the tutorial windows to suit your needs.

To follow the tutorial sequence:
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1 On the Contents tab, double-click a tutorial book to open it (it is intended that 
you should follow the tutorials in numerical sequence).

2 Double-click the first topic in the tutorial.

3 Follow this topic to its end. There will be a vertical scroll bar at the right of the 
window if the topic is longer than the window — use it to get to the end of the 
topic.

4 Click the button to move on to the next topic in the tutorial sequence.

5 Repeat steps 3 and 4 to the end of each tutorial.

6 To move on to another tutorial, just click again, or go back 
to the contents and choose the next tutorial from there.

Taking a Break
Some of the tutorials are quite long and you may not want to tackle them at a single 
sitting. 

If you need to take a break: 

1 Save your work:

When you first save the file use File>Save As and be sure to specify a 
new name.   Saving the file directly will overwrite the tutorial.  If you 
have already given your work file a name different from the distributed 
filename, just File>Save.

2 To resume, open your saved file, then check in the tutorial to see how the filters, 
nametags, and orthogonal dragging mode should be set for continuing.

File and folder locations
The default folder for loading your software is C:\Program Files\AeroHydro\
MultiSurf .  In this folder are loaded all of the files needed to run MultiSurf .  Under 
this folder are sub-folders for Tutorials, Examples and Tutorial Files.  Because you 
are free to load MultiSurf in another folder which you name, we will refer to the 
location of certain files as, for example, \Tutorials.  This means they are found in the 
Tutorials sub-folder located wherever you have loaded MultiSurf .

If Your Screen Doesn’t Match Our Instructions
If at any time during the process what you see on your screen looks very odd or 
doesn’t seem to match what we write about it, don’t dismay. You may have done 

something as simple as clicking the View>Port button instead of the 
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View>Starboard one. First, check back in the tutorial and be sure you are 
looking from the same viewpoint (including perspective/orthographic). If that’s as 
should be, you’ll need to check your model (against the tutorial sequences and/or 
against one of our distribution files).

For the longer tutorials, we have included some intermediate model files with your 
MultiSurf distribution for along-the-way assistance. Periodically during the tutorial, 
we note where they fit in, e.g. “This should match our distribution model 
TANGENT2.ms2".  These files are located in the \Marine Tutorials folder.

There are 3 options for proceeding from an apparent tangle. You can:

• Start over again at the beginning.

• Undo until things look right, then proceed forward again from that point.

• Use one of our distribution model files to continue the tutorial:

1 Look back in the tutorial and find the most recent mention of a distribution 
file.

2 Use File>Open to open the distribution model, from \ Tutorials.

3 Immediately File>Save As and specify a different filename so you won’t 
overwrite the distribution file by mistake.

4 You may need to look back in the tutorial and reset some settings to what 
they would have been if you were proceeding with your own model: 

• Viewpoint (standard views; perspective; etc.)

• The Selection Set

• Filters (toolbar buttons or Select>Class Filters; Select>Current Layer 
Filter)

• Orthogonal dragging mode (toolbar button or 
Tools>Options>Dragging)

• Nametags (toolbar buttons or View>Nametags)

5 Continue with the tutorial.

6 Before you do any File>Saves, be sure your model’s filename is one you have 
specified (Step 3 takes care of this; Step 6 is a just-in-case message to make 
sure you do not overwrite a distribution file with changes).

Some Basic Terminology

Mousing
MultiSurf is operated by both mouse and keyboard. Here is a summary of some 
basic mouse terminology as we use it:

Term Meaning
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point move the mouse arrow cursor on the screen until it points at a 
particular entity, option, or button

click (or click on) point the cursor arrow at a particular entity or item, then 
press down and release the left mouse button

double-click with the cursor arrow pointed at a particular entity or item, 
click the left mouse button twice in rapid succession

click and hold click the left mouse button and hold it down

drag point the cursor arrow at a point or screen location, press the 
left mouse button and hold it down while you move the 
mouse, then release the mouse button

choose make a selection from the main menu bar

wheel zoom, rotate, 
pan or zoom to area

use your mouse center wheel, to zoom, rotate, pan or zoom 
to area

Selecting, Choosing, Picking, Going to ...
We basically follow the Windows convention of using select to mean marking an 
entity or item on the screen (usually with a highlight or a wider line); and choose to 
mean telling the program to actually take an action (as in opening a window, or 
carrying out a menu or dialog box task). We also use pick and go to with the same 
meaning as choose.

Generally, a single click or pressing Tab (in a dialog box) will select an entity or item; 
a double-click or pressing Enter or clicking OK when an item is already selected, will 
choose the action (carry it out).

Typeface and Symbol Conventions
1 In the tutorials, we print what you are to do (menu options to choose, keys to

press, entities to select, values or names to type in, etc.) in bold typeface. 
Instructional steps are numbered.  There is occasional use of bold type for 
emphasis, but this will be clear from its context.

2 <Q> or 'press <Q>' means press the letter 'Q' on the keyboard.  <Shift+Q> means 
hold down the Shift key and press the letter 'Q'.  <Apply> means click on the 
'Apply' button.

3 When we want you to choose a series of menu and dialog box options, we print 
the choices separated by a '>'. For example,

>Projected Snake or Insert>Snake>Projected Snake

means click on the button and pick Projected Snake from the menu or click 
on Insert and choose Snake from the menu and then Projected Snake from the 
next menu.

4 We enclose entity names in single quotes, e.g. ‘magnet2’ or ‘pt4’. When you type in 
the entity name, don’t include the quotes.
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The Figures
In order to be visually more clear, most figures illustrating MultiSurf steps in the 
tutorials do not show the graphic-display shading of surfaces.

Troubleshooting

Keyboard Doesn’t Respond
If your keyboard seems hung up, you may have run into that unfortunate Windows 
problem of having pressed Alt unknowingly, thus jumping the cursor up to the 
menu bar where it doesn’t show up very well.

Solution: press Alt again (to get back out of the menu bar). 

Can’t Select an Entity on the Screen
If you click on an entity to select it in the drawing and it won’t select, check your 
filter settings: 

• on the tool bar — filter buttons for the classes of entities and for Current Layer 
Only

• in the Select Menu — Class Filters, Visible/Hidden/Both, Current Layer Filter

Reset filter(s) if need be. Note that while Select>Reset All Filters immediately 
makes all entities selectable, it does reset all filters to their default settings. Whatever 
you do to your filter settings to get at the entity you want to select, you might want 
to check back through the tutorial and make sure that your settings match the 
instructions — to avoid further confusion as you continue following the tutorial. 

Drawing Disappears
If you are changing the viewpoint (rotating; panning, zooming) and your model 

disappears, do a Zoom to Fit ( or View>Modify>Zoom to Fit or <F>).

Error Messages
If the MultiSurf Errors window opens and reports an error, you have these options 
(the entity in question will be displayed in the Entity Manager,  with a .  If the 
entity appears in the Selection Set or Available Entities panes it will also display a 

):

• To fix an entity that’s in error, select it and then edit it — double-clicking the 
entity in the Error window will select that Entity and show the attributes in the 
Property Manager.

• To get rid of an entity that’s in error that does not already have children, select it 
in the Entity Manager or the Available Entities Manager, then Edit>Delete it or 
press the Delete key.

• You also can Undo an error if you have just created it. If the error occurred 
during entity creation, Undo will undo the entity creation (there will be no new 
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entity in the model). If the error occurred during entity editing, Undo will undo 
the edit (the entity will remain in the model).
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Views and Viewing

Introduction
In this tutorial we introduce you to the basics of navigating in MultiSurf , including 
how to:

• make choices and enter information
• control the view
• view the model data in several formats
• export 2D and 3D files

In the beginning, we use very explicit instructions, down to the last MultiSurf mouse 
click. Later on, when we assume you are familiar with a particular menu choice or 
dialog, we give you more general instructions.

Entity introductions:

Wireframe

Concept and Function introductions:

• , , , , , cursor shapes <Arrow>, <Ctrl+Arrow>, 
<Ctrl+O>, <F>, <F1>, <F5>, <F8>, <F10>, <Home>, <P>, <Pg Down>, 
<Pg Up>, <Shift+X>, <Shift+Y>, <Shift+Z>, <X>, <Y>, <Z> Shortcut 
Keys

• Drag a point
• Edit>Undo
• Expand to Selected Entity in Entity Manager
• File>Close, >Exit, >Open, >Export 2D>DXF, >Export 3D
• Help>About MultiSurf, >Help Topics
• Latitude, Longitude, Radius, Tilt
• Orthographic View
• Parent/Child box
• Right click menus for graphics area whitespace, Entity Manager

whitespace and entity
• Select>Children>First Generation, >All Generations and 

Select>Parents>First Generation, >All Generations
• Entity Manager, Selection Set pane, Available Entities pane
• Tools>Options, General, Rotation Constraint, Free tumble/Z axis vertical
• Tools>Options, Model, Home View
• Tools>Options, Performance, Degrees per Keystroke
• Tooltip shows name and type when held over entity
• View>Display>Wireframe, >Shaded, >Shiplines, >Perspective



Views and Viewing Program startup

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  8

View>Marine View Orientation>Bow, >Stern, >Port, >Starboard, >Deck, >Keel, 
>Home View>Mechanical View Orientation>Left, >Right, >Top, >Home
View>Modify>Pan, >Previous, >Rotate, >Zoom In/Out, >Zoom to Area, >Zoom 
to Fit, >Zoom to Selection

• View>Nametags, Point
• View>Symmetry Images
• Wheel Rotate, Zoom
• Window>New Model Window, >Tile Vertical

Program startup
If you have not yet installed MultiSurf and its supporting set of model files on your 
computer, please follow the instructions in the main manual under “Installing 
MultiSurf .”

Start MultiSurf from the Windows Start Menu: click Programs, then AeroHydro, 
then MultiSurf; or in Explorer double-click the program WINDSURF.EXE in the 
\MultiSurf folder. Please refer to your Windows manual if you need further 
assistance.

The program starts up — what do you see?

You should see the MultiSurf title bar, a menu bar, and a toolbars at the top of your 
screen and a status bar at the bottom. You will also see the Entity Manager, the 
Selection Set Manager, and the Property Manager. These should remain open and 
can be docked around the perimeter of the workspace or moved to a second monitor. 
The workspace holds all the windows (graphics views, and other displays) you use 
for viewing the model. 

Until you open a file, there are only a few choices on the menu bar, and the 
text/graphics on most of the toolbars (shortcuts for various menu choices) are grayed 
out, meaning they are inactive.

The status bar also becomes more helpful once you have opened a file. It reports 
viewing data and gives you feedback on what editing operation is pending, or on 
what menu choices and buttons do.

For a drop down box of menu option information, click the mouse button while the 
cursor is on a menu item.  You can then drag the cursor to the other menu items to 
see their drop down boxes of options.  Once a final menu option is highlighted, press 
<F1> for extended information from the online help file.  If you click and hold on a 
menu item, you can follow the boxes until you are at the choice you want.  Read the 
status bar for information.  Release the mouse button to make that choice or if you 
don’t want to activate a menu item, drag the cursor off the item before you release 
the mouse button. For toolbar button information, hold the cursor over the button 
and read the status bar or the pop-up tool tip.  

Open a model file
Okay, now we’re going to open a model file:

Click or press <Ctrl+O> or choose File>Open.
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A standard Windows dialog box appears, but since some of you may not be familiar 
with how it works, we’ll do an introduction here. If you’re already familiar with 
Windows dialog boxes, jump below to “Continuing.”

Dialog box introduction
The Open File dialog box lets you specify the file you want to open and the path 
(drive and folder/directory) to get to it.

The file we want to load should be in the Marine Tutorials sub-folder of the 
MultiSurf folder.  At the moment, the folder shown in the “Look in” field should be 
Local Disk (C:). To move to the Marine Tutorials folder, double-click in turn the 
folders that lead to the tutorials folder.  If you installed using the default location, 
these folders would be: Program Files, AeroHydro, MultiSurf, Marine Tutorials.  
Now the “Look in” field should report Marine Tutorials.

Continuing
The list of .MS2 files in the Marine Tutorials folder should include DEMO.MS2 (in 
your list it probably shows as Demo.ms2; we capitalize filenames in the tutorial text 
because they stand out more that way — it means the same thing).

Is the list box listless (empty)? If it is, you probably don’t have the supporting files 
loaded in the correct folder. DEMO.MS2 should be among the files supplied with 
MultiSurf , and a copy of it should be in the \ Marine Tutorials folder. If there is 
nothing there, please exit (click <Cancel>, choose File>Exit), review installation 
instructions, and correct the installation.

Assuming DEMO.MS2 is there, double-click it.

Entity Manager…
The program opens a window in the main area of the screen and displays a picture of 
a boat.  On the left side of the screen are three panes, one with a list of entity types 
that we call the Entity Manager, one labeled "Selection Set" that is blank and the 
bottom one labeled "Property Manager".  These three panes provide access to, and 
information about, the model and its entities.
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The Entity Manager provides a complete list of the entities in the model, listed by 
entity class.  When expanded each entity also shows its parents (if the 'Children' tab 
is selected, each entity displays its children).

The Selection Set pane displays all entities that are in the Selection Set.  Once listed, 
the set can be reordered as a group, or individual entities can be removed or 
reordered.

The Property Manager is where you would edit the attributes of individual entities 
or groups of entities.

For more detailed information on these three panes, see "The Entity Manager and 
"The Selection Set and Property Manager" in the "Fundamentals" chapter of the 
User's Guide.

Shaded vs. Wireframe view
The opening view of DEMO.ms2 is in shaded view (Fig. 1 top).  Old models open in 
the view in which they were saved, the default view for new models is shaded.

Fig. 1  demo.ms2.

Click or choose View>Display>Wireframe to change to wireframe view (Fig. 1 
bottom). This is the other way to view the model.  Wireframe models are transparent.  
Although you can set the amount of transparency in shaded view to appear nearly 
transparent, wireframe view does away with shading altogether.

In a graphics display, points are represented by small squares, curves are represented 
by polylines (with the number of segments determined by the product of the curve's 
Divisions and Sub-divisions) and surfaces are represented by a mesh of curves.

The DEMO model consists of 12 points (yellow in this case), 3 curves built from those 
points (cyan in this case), 1 surface built from those curves (in this case we are 
displaying only the longitudinal family of curves, 11 of them, in light green), and 2 
sets of contours cutting the surface (11 transverse sections through the surface in red 
and 1 horizontal section in the plane Z = 0 in magenta) a total of 18 objects.
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To return to shaded view, just click or choose View>Display>Shaded.  For the 

rest of this tutorial we will want the model in wireframe view, so click once 
again.

Controlling the view
You can control many aspects of this 3D graphics view using the keyboard and the 
mouse. The first thing to do, however, is to decide which method of viewing you 
want to use.  In Tools>Options, General tab under Rotation Constraint you can 
choose either Free tumble or Z axis vertical.

Free tumble mode
In Free tumble mode the model rotates around imaginary axes that are vertical and
horizontal in relation to the screen so the model can appear to tumble when you 
rotate it.

Z axis vertical mode
In Z axis vertical mode, the model still appears to rotate, but because the Z axis is 
constrained to be vertical, i.e. tilt = 0, the model never appears to tumble.  Note that 
this does not mean that positive Z always points up, but that the axis is always 
vertical in the plane of the screen.

Note:  There are 2 caveats about the Z axis being vertical:

1 When you are in perspective view, the Z axis will sometimes be a little angled.  
This an artifact of how the perspective view is generated.

2 Three views in Mechanical View Orientation, Left View, Right View and Top 
View, all have non-zero tilt, and Home View, which is found in both Mechanical 
and Marine View Orientation, can have tilt set to non-zero.  If you go to a view 
that has non-zero tilt and then rotate, the model will immediately jump so that 
the Z axis becomes vertical in the plane of the screen.  You have two options for 
dealing with this:  use Free Tumble mode, for which this is not a problem, or use 
the Marine View Orientation buttons all of which have tilt=0.

Viewing in steps
You can think of the view of the model as being recorded by a camera, which is 
“where your eye is”.  Picture this camera residing on the surface of a sphere, pointing 
inward toward the center of the sphere which is the look point (Fig. 2).  After you 
zoom, pan or rotate, the camera ends up in a different position around the model.

The camera position is specified by four variables:

• latitude — camera angle above or below the horizontal (X,Y) plane

• longitude — camera angle to the left or right from looking along the positive 
X-axis

• radius — distance from the center of the sphere (the camera’s look point) to the 
camera; this defines the size of the sphere
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• tilt — camera tilt from vertical

orbit
sphere

longitude

model

camera

+
tilt

Fig. 2.  Model and its axes, camera (your viewpoint), orbit sphere, latitude, longitude. The camera is at 
Lat -30, Lon 75, Tilt 0.

These four values are displayed on the status line. They are updated each time you 
rotate or zoom.

Rotate

Pressing the up and down arrow keys rotates the model around an imaginary 
screen horizontal axis that passes through the model's look point.  In Z axis vertical 
mode, this changes only the latitude, in Free tumble mode both the latitude and 
longitude are free to change.

Pressing the left and right arrow keys:

in Z axis vertical mode rotates the model around an imaginary axis that is 
parallel to the Z axis and passes through the look point.  This changes only the 
longitude.

in Free tumble mode rotates the model around an imaginary axis that is parallel 
to screen vertical and passes through the look point.  Both longitude and latitude 
are free to change.

Pan

Holding down the <Ctrl> key while pressing any of the arrow keys pans the camera.  
This has the effect of moving the look point without changing latitude, longitude, 
radius or tilt.

Zoom

Pressing <PgUp> moves the camera inward; pressing <PgDn> moves the camera
outward; these are changes in radius; the orbit sphere gets bigger and smaller

Tilt
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Tilt cannot be controlled directly by any key.  It is always 0 in Z axis vertical mode 
(except as noted above).  Tilt can be set for the Home view in Tools>Options, 
Model, Home View.

Smaller Motions

To move by smaller increments, hold down <Shift> while pressing the regular 
motion key(s).

Home

If you get lost, or want to get back to the beginning, Press <Home> or choose 
View>Mechanical (or Marine) Orientation>Home to restore the original view.  If 
you want to change the Home view, go to Tools>Options, Model, Home View and 
set Latitude, Longitude and Tilt.

Degrees per Keystroke

In Z-axis vertical mode, pressing an arrow key changes the latitude or longitude the 
number of degrees specified in Tools>Options, Performance, Degrees per 
keystroke.  If latitude is changed, longitude remains unchanged and vice versa.

In Free tumble mode, the model rotates around imaginary axes that are vertical and 
horizontal in relation to the plane of the screen.  Because of this, the latitude and 
longitude changes are unpredictable.  If the rotation happens to be perpendicular to 
one of the model axes, then the latitude and longitude will change the way it does in 
Z axis vertical mode, but only while the rotation remains perpendicular to that axis.

Dynamic viewing
You can also control the graphics view using the mouse. The mouse controls are 
equivalent to rotating, panning and zooming the camera using the arrow keys and 
<PgUp>/<PgDn>.  We have provided many methods for you to view dynamically:

• You can select a method for controlling the view from the View>Modify menu 
and then use the left mouse button to move the model

• You can use the left mouse button to select the kind of motion desired from 
the View Modify toolbar and then use the left mouse button to move the model

• You can use the right mouse button to click in white space and then pick a 
mode from the menu and then use the left mouse button to move the model

• If you have a center mouse button you can use it to rotate or pan directly

• If you have a center mouse wheel, you can use it to rotate, pan or zoom 
directly.

Rotate

The easiest way to rotate is to place the pointer anywhere in the graphics view, 
press and hold down the center wheel (or button) of your mouse (if you have 
one) and move the mouse.
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Alternatively, you can select View>Modify>Rotate or right click in white space

and choose Rotate or just click and then press and hold down the left mouse 
button in the graphics space while moving the mouse.

The cursor changes to to indicate Rotation mode.

Pan

Press <Ctrl> then place the pointer anywhere in the graphics view and hold 
down the center wheel (or button) of your mouse (if you have one) and move the 
mouse.

Select View>Modify>Pan or Right click in white space and choose Pan or just 

click and then press and hold down the left mouse button in the graphics 
space while moving the mouse.

The cursor changes to to indicate Pan mode.

Zoom

If you have a center mouse wheel the easiest way to rotate is simply to move the top 
of the wheel away from you to zoom out or to move the top of the wheel towards 
you to zoom in.  If you use the wheel, the cursor shape does not change.

Alternatively, you can select View>Modify>Zoom In/Out or right click in white 

space and choose Zoom In/Out or just click and then press and hold down 
the left mouse button in the graphics space while moving the mouse.

The cursor changes to to indicate Zoom In\Out mode.

Move up to increase magnification, down to reduce.

Zoom to Area

If you have a center mouse wheel or button, press <Shift> then place the pointer 
anywhere in the graphics view and hold down the center wheel (or button) of 
your mouse.  Drag a box around what you want to zoom in on or click and 
release to center the model on the click point.

Alternatively, you can select View>Modify>Zoom to Area or right click in white 

space and choose Zoom to Area or just click and then press and hold down 
the left mouse button in the graphics space.  Drag a box around what you want 
to zoom in on or click and release to center the model on the click point.

The cursor changes to to indicate Zoom to Area mode.

Which Rotation constraint to use?
So which Rotation constraint should you use?  Its all a matter of preference really.  Z 
axis vertical is the viewing method that we originally used in MultiSurf .  Some of us 
like it for boats and any large object because it gives us the feeling of walking around 
the model.  For smaller objects, some of us like Free tumble mode because it gives us 
the idea of holding the object in our hands and turning it over any which way.

In Z axis vertical mode, you can pretty easily rotate with the mouse and get back to 
where you started.  This is much harder with Free tumble mode.  On the other hand, 
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you can put the model in positions in Free tumble mode that cannot be reached in Z 
axis vertical mode.

Experiment on your own to get a feel for both modes and to get used to dynamic and 
step wise motions.  Motions are easier and faster with the mouse, but not as precise 
as the keys.  Notice how the view changes and the numbers on the Status Bar change 
as you practice.

Since we want to make sure that everybody is always working with the same view, 
we are going to pick a Rotation constraint and use the arrow keys to move around 
while doing these tutorials.

When you are finished experimenting:

Go to Tools>Options, General, Rotation Constraint, and click the Z axis 

vertical radio button.  Then press Zoom to Fit, so that the model fills the 
screen and is centered.

Orthographic vs. perspective views
The views we have been seeing are orthographic, in which the points are projected 
along parallel lines.   This is the view that engineers are accustomed to looking at 
(usually parallel to one of the 3 coordinate axes).  Perspective view provides realistic 
3D views very similar to those you would see with your eye or with a real camera. In 
perspective, points in 3D are projected along lines which converge at the camera (or 
eye) point, and objects which are farther away appear smaller than those that are 
closer.

To switch to Perspective view:

Click or press <P> or choose View>Display>Perspective to toggle 
perspective on.

To switch back to Orthographic view, click or press <P> or choose
View>Display>Perspective

Use the arrow keys and <PgUp> to move to Latitude -10, Longitude 20, Radius 
~32. You can press the arrow keys, <PgUp>, etc. in rapid succession to get to a 
specific viewpoint — you do not have to let the program redraw the image in 
between key presses.

Toggle this viewpoint back and forth between Orthographic and Perspective 
(use the toolbar button) and notice the relative size of the near and far ends of the 
boat in the two views. The Perspective view is much more pictorial (Fig. 3, left). The 
Orthographic view is like a picture taken from very far away, with a long telephoto 
lens (Fig. 3, right).
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Fig. 3  Perspective view (left) and orthographic view (right) of DEMO model at Lat -10, Lon 20.

Orthographic views along the axes are most commonly useful, and these are 
instantly available by use of toolbar buttons or keyboard letter presses.  The choices 

are: , , , , , or View>Marine View Orientation>Bow, Stern, 
Port, Starboard, Deck, Keel.  These are also choosable buy using the keyboard 
<Shift+X>, <X>, <Shift+Y>, <Y>, <Z>, and <Shift+Z>. Shift+ X, Y or Z looks in the 
positive direction along the axis (toward the end of the axis that is labeled X, Y, or Z); 
X, Y or Z looks in the negative direction (toward the unlabeled axis end). For example:

Press <Y>. This gives you a profile view of this hull (use <PgDn> or <F>  if you 
can’t see the whole boat), looking toward negative Y and with X increasing 
toward the left — you are looking at the outside of the starboard side of the hull 
(Fig. 4).

 Fig. 4

Press <Shift+Y>. This also gives you a profile view, but looking toward 
positive Y and with X increasing toward the right — you are looking at the inside
of the starboard side of the hull (Fig. 5).

 Fig. 5

Press <Z>. This shows the plan view from above, with positive Y downward 
and positive X to the left (Fig. 6).

 Fig. 6

Following any of the letter keys you can rotate again with the arrow keys.  You will 

remain in orthographic view unless you click or press <P> or choose
View>Display>Perspective.

Help side-trip
The key functions controlling the view are fairly numerous. Though most of them are 
mnemonic, it may be hard to remember them all. But panic not! We’ve provided a 
key actions summary card with this manual and a detailed on-line help system 
within the program. To access the on-line help system, all you need to do is press the 
<F1> function key or choose Help>Help Topics. Let’s take a little side trip to check 
it out:

1 Choose Help>About MultiSurf .  This is where you find the version and build 
number of your MultiSurf program. 

2 Click <OK> to close this help window.
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3 Now choose Help>Help Topics.  This is the on line help file. 

4 At the top of the Contents listing on the right side, click on "All Keyboard 
Shortcuts Listed Alphabetically by Option".  This shows you the table of 
shortcuts listed alphabetically by option. Use the scroll bar or the mouse wheel to 
scroll down through the table. (You can change the size of the help window by 
dragging its bottom corner).  Notice that the Contents listing on the left side 
expands to show where you are in the documentation system.

5 Prowl around the help system a bit if you'd like: 

Click on one of the other topics.
Click the Index and type in a keyword.
Click Search and type in a keyword or keywords.

6 Click to close the Help window.

Four ways to zoom
Suppose we want to zoom in on the bow of the boat.  Here are three ways to do that:

Keys

1 Choose (View>Marine View Orientation>Starboard) to get a profile view, 
bow to the right.

2 Then press <Ctrl>+right or left arrow several times to get the bow centered in 
the window (remember, you don’t have to wait for the program to redraw 
between key presses; Fig. 7, left).

3 Now you can press <PgUp> to zoom in (Fig. 7, right); <PgDn> to zoom out 
again (or use the wheel).

Fig. 7

If you did not get the nose precisely centered, you noticed the tip drifting off of 
center.  Here's another method:

Zoom to Area

1 or <F> to Zoom to Fit.

We should still be in Starboard view, so the whole boat should be visible, and facing 
right.

2 First, imagine a rectangle surrounding the area you want to enlarge.
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3 Choose or right click and choose Zoom to Area or choose 

View>Modify>Zoom to Area.  The cursor changes to .

4 Place the cursor at one corner of the rectangular area you just imagined.

5 Press and hold down the left mouse button down while you drag the 
pointer to the diagonally opposite corner of the rectangle.  A “rubber band” 
line will stretch to enclose the rectangular area you are defining.

6 Release the mouse button. The area you picked is now enlarged to fill the 
screen (Fig. 8).

7 Press <F8> or View>Modify>Previous
shortcut key; it returns you to the last 
view that completely drew on the screen.

8 Choose <F8> again to return to the bow 
close-up view.

Fig. 8

9 Try zooming in on the nose again.

There's still some drift.  Let's try one more method:

10 Return to Select Mode and Zoom to Fit.

Zoom to Selection
At the very tip of the bow is a point that is yellow.

1 Move the cursor over this point.  When you are over the point, the cursor 

changes to and the tooltip reads 'Point p11'.  Click the left mouse button.

This places the point in the Selection Set.

2 Now press or <F10> or View>Modify>Zoom to Selection.

This centers the point on the screen and makes it the new look point.  That means 
that zooming now keeps the tip of the bow on the screen and also keeps the tip at the 
center of rotation.

3 Try zooming and rotating to see how the view changes.

Zoom to Cursor
1 Place the cursor near the area of the model you desire to zoom and roll the center 

mouse wheel towards you. The view will zoom to the cursor location.
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Pan-to-center
Before we get into this section, let's get the view set so we are starting off at roughly 
the same point.

1 Choose (Starboard view) and Zoom to Fit.

2 Choose (Zoom to Area) and drag a box around the bow.

Now, let’s say you want to examine the full length of the hull at this enlarged view. 

You could do this by choosing or by pressing <Ctrl>+left arrow numerous times. 
Here’s another way to pan; it lets you choose the location in the drawing that will 
become the new center of the image.

To pan the length of the hull:

3 Choose and move the mouse cursor to the left edge of the drawing 
area, about halfway down from the top. 

4 Click and release the left mouse button (without moving the cursor).  The 
location you clicked becomes the new center of the image.

5 Repeat. By clicking successively, you can move the camera along your enlarged 
view of the boat and in a number of pans examine the whole length of the boat in 
detail (Fig. 9).

6 Press <Home> to return to the original view.

... ...

 Fig. 9

Save 2D drawing files
Looking at pictures on the screen is great, but how can you make a hard copy? And 
how can you get these pictures into a CAD program as a basis for more complex 2D 
drawings? The answer is a .DXF file, intended for input into 2D CAD programs.  Any 
graphic picture on the screen can be saved as a .DXF file.

To see how it’s done:

1 Choose a view that you like.  Then pick File>Export 2D>DXF

The Export 2D Options dialog box appears, offering Fast or Accurate calculation 
during the save, a check box that allows you to keep the Save Mode if you changed 
the mode and want to export in that mode the next time, All Visible Objects or 
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Selection Set Only, the Point size of the exported lines and an Identifying Message if 
you want to add one.

2 We’ll use the defaults Fast, All Visible Objects, and Point Size = 1, so just click 
<OK>.

The File Save As dialog box which appears next looks and works like the File Open dialog. 

3 Type in the filename demo1.  Make sure the folder specified is \Marine 
Tutorials.  Then press <Enter> (or click <OK>).

View lines plan
Naval architects have a conventional way of displaying hull forms as a lines plan.

To view this boat as a lines plan:

Pick View>Display>Ship Lines.

MultiSurf opens the ShipLines Parameters dialog.  For details see Ship Lines in 
the Marine section of the paper or online User's Manual.  For now accept the defaults 
by pressing <OK>.

MultiSurf opens a second window (which becomes the active window) and displays 
the ship lines view in it (Fig. 10). The lines plan shows 3 orthographic views, with the 
same set of plane sections in each. These are (from top to bottom):

• body plan — separate views of the bow and stern, looking along +X and -X

• profile view (or elevation) — looking along -Y axis

• plan view — looking along +Z axis

 Fig. 10

(If we wanted more stations, waterlines, buttocks, etc., we could get them by adding 
more Contours entities to the model.)

You can’t work on the model in this view, but you can export a 2D file of it:

Right click in this view and select Export DXF.

Give it the filename demo2.
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Close the ship lines view by clicking at the top right of the ship lines window. 
The graphics window becomes the active window again.

Symmetry images
The graphics image on your screen represents one side of a hull which has mirror 
symmetry with respect to the centerplane, Y = 0. The model file includes the 
information that this model has mirror symmetry, but the display of the other side 
has been suppressed (by default). We can change that:

View>Symmetry Images (or <F5>) is a toggle, which switches the program back 
and forth between displaying and suppressing the symmetry images specified for the 
model.  With symmetry images on, you can see how the transparency of the 
wireframe can make a confusing image. Usually wireframes look better with 
symmetry images off.

Press <F5> to toggle the symmetry images off.

3D drawing files
Next, go to File>Export 3D.

This option saves the complete 3D shape, which is independent of the particular 
view (whereas Export 2D saves just the current view of the model as a specific 2D 
picture). The 3D shape can be saved in several formats:

• a DXF file composed either of a wireframe or of meshes (for input to 
AutoCAD or other 3D CAD programs)

• an IGES file of NURBS approximations of the MultiSurf surfaces
• a VRML file (Virtual Reality Modeling Language) for transmission of 3D 

visual models over the Internet
• a file of POV triangles (for input into the POV-Ray rendering program)
• a RUL surfaces file (ruled and developable surfaces for flattening in MSDEV)
• an AeroHydro .3DA wireframe file

Files that are exported as a .3DA wireframe can be reloaded, using 
Insert>Wireframe, back into MultiSurf as WireFrame entities for display, in 
combination with other entities, if desired.

Click anywhere in the background of the graphics view to close the menus 
without saving a file and to make the graphics view active again.

View dependency
There is another, non-graphical way of looking at a model that we should 
demonstrate while we’re looking at ways to view a model.

1 If you are not already there, return to the Home viewpoint.
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2 Now place the point of the cursor over the cyan curve that forms the bow 
(forward edge) of the hull and click the mouse. (You can tell when you are 

over the line when the cursor changes to ).  This selects the curve (B-spline 
Curve) 'MC1'.  Selected entities are drawn in bold.

3 Right Click in white space in the Entity Manager, (the top pane).  From the 
drop down menu, choose “Expand to Selected Entities”. You should see the 
curve, 'MC1', highlighted ( ) among the other curves in the model.  This is a 
convenient method of finding an entity in the Entity Manager.

4 Right click on the curve in the Entity Manager and choose “Parent/Child” 
from the drop down menu.  (You can also get to the Parent/Child box directly 
from step two by right clicking the entity in the graphic space and choosing 
Parent/Child).

MultiSurf opens a new window showing the parents and children of the selected 
entity.  The selected entity, 'MC1',  still has the light blue icon in this window.

MultiSurf ' unique modeling power derives from maintaining and utilizing a web of 
parent/child relationships among the entities making up a model. When entity B is 
created by a construction that directly utilizes geometric information about entity A, 
we say that entity B is a child of entity A; or, conversely, that entity A is a parent of 
entity B. Parent/Child is a facility for exploring and understanding the complete set 
of relationships connecting the entities of a model. 

The Parent/Child window has two parts: a parent list box at the top, and a children 
list box on the bottom. Entities appearing in the parent list are first-generation parents 
for the selected entity, things it depends on directly. This shows that ‘MC1’ depends 
on ‘P11’, ‘P12’, ‘P13’, ‘P14’. The children list shows things that are first-generation
children of the selected entity, in this case only ‘C-spline Lofted Surface hull’.

Another way to see the parents or children of an entity is to place its parents or 
children into the Selection Set (the second pane in the set of three panes running 
down the left side of the workspace).

5 Click OK to close the Parent/Child Relationships box.

6 With 'MC1' still in the Selection Set, click or Select>Parents>First 
Generation. Its first generation parents appear in the Selection Set window.

7 Click again and you see the next Generation of parents of 'MC1' if there are 
any.  No more entities appear, showing that there are no more parents for this 
entity.

8 Click in white space to clear the selection set, and then select 'MC1' again.

9 Click  or Select>Children>First Generation to see the first generation of 
'MC1's children.

10 Click again to see the next generation.
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If you want to see all of an entity's parents or children at once you can just choose 
Select>Parents>All Generations or Select>Children>All Generations, but we 

often find that it is easier, especially in small models, to just quickly click on or 

until all generations are selected.

Multiple graphics views of a model
In MultiSurf you can have several graphics views of a model open at the same time. 
These views are all linked — changes you make to the model in one window are 
reflected in all the others. Let’s see:

1 Window>New Model Window. This opens a second model of the demo hull, 
displaying it in the <Home> view. This new window is now the active window.  
Switch this view to the <Y> view.

2 Window>New Model Window  Switch this view to the <Z> view.

3 Window>New Model Window.  Set this view to the <X> view.

4 Click (Window>Tile Vertical).

5 If you find that the 3 non-graphic panes take up a lot of space, you can resize 
them by grabbing the right side of the panes with the mouse and sliding it left.

6 Click (Zoom to Fit) to make the image fill the <X> view window.

7 Click in graphics white space of the original window (window: 1) to activate 
that window.

8 Click to fill the window.  Repeat steps 6 and 7 for the other two windows.

Let’s do a simple edit to show you what we mean when we say the views in the 
windows are linked. (At this point, we won’t explain any whys about the editing 
process — we’ll spend plenty of time on creating and editing objects in the 
succeeding tutorials.)

9 Click in graphics white space of the <Y> view (DEMO.MS2:2).  
(View>Nametags, Point) to turn nametags for points on.

10 Click and hold on P11 (the point at the tip of the bow) and drag it around a bit.  
Notice that all four windows update simultaneously as the you drag the point.

11 Edit>Undo and all four views update again.

12 File>Close, No to the save changes inquiry.

Before we end this tutorial, let’s do a couple of demonstrations of move-a-point-
presto-change-o model modifications you might do in real life.
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Moving a cabin
1 File>Open 2CABINS.MS2 — it should be in the \Marine Tutorials folder. We’ll 

use this model for a wee introductory demonstration.

2 Maximize the window by clicking .

3 Click to zoom the model to fit.  This is the deck and cabin of a boat.

4 Now press the function key <F5> to see the symmetry images that make the 
other half of the model (Fig. 11).

 Fig. 11.  2CABINS.MS2

Start by imagining that you as the designer had gotten this far with your design and 
changed your mind about where you wanted the cabin — you now want to have the 
cabin pretty far aft. Would you believe you can do that right now, by moving a single 
point?

Along the centerline (magenta), where the front of the cabin crosses it, there is a 
white point. It is called ‘r0’.  Let's select this point and drag it aft.

5 Place the cursor over 'r0' (at the intersection of the centerline and the front of 
the cabin).  When you are over the point, click and hold down the mouse 
button.

6 Drag the cursor aft along the centerline, to just in front of the red master curve 
that crosses the deck.

Not only has the point ‘r0’ moved, but the entire cabin has moved as well. In addition, 
in its new position, the cabin still meets the deck exactly, and the cabin surfaces still 
fit together exactly! (Pretty cool, yes?)

Want to have another go at it? How about moving the cabin way forward:

7 Point the cursor towards ‘r0’ again.  Press and hold down the mouse button.  
Drag the cursor directly forward to about halfway between the tip of the bow 
and the cyan master curve that crosses the deck.  Release the mouse button.

Presto! The entire cabin moves, and all the surface joins remain exact. This model is 
also constructed so you can move the aft end of the cabin independently of the front. 
The point that controls this is located where the bottom edge of the cabin back 
crosses the centerline. You may not be able to see it right now, but it is there; it is 
called ‘r1’ and it’s also white:

8 Click and hold when the cursor is over 'Ring r1' (where the bottom edge of 
the cabin back crosses the centerline).

9 Drag this point aft along the centerline to where the red master curve 
crosses the deck. So how do you like that?!
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10 Now click and hold on ‘r0’ again (at the front of the cabin). We’re going to 
move the big cabin.

11 Drag ‘r0’ aft along the centerline to where the cyan master curve crosses the 
deck.

How can MultiSurf do all this? Well, here are the basics:

1 When you create a model in MultiSurf, you build it up from point objects to 
curve objects to surface objects.

2 In the process of creating objects, you specify particular relationships between 
objects — for instance, that curve X passes through points A, B, and C.  MultiSurf 
retains all these specified relationships as part of the data it stores to represent 
the model.

3 When you make a change in a model, MultiSurf automatically updates the entire
model, checking and maintaining all the relationships specified between objects 
— for instance if you moved point C, MultiSurf would update the position of C 
and recreate curve X so that it still passed through point C, as well as points A 
and B.

That’s just what you have seen with the cabin-deck model. In this case, some of the 
defined relationships are:

• the point ‘r0’ is constrained to lie on the centerline of the deck

• all parts of the cabin lie in specified relationship to the point ‘r0’ — therefore, 
when you move the point, the whole cabin moves

• the bottom curves of the cabin sides and front are special curves that must lie 
on the deck surface — therefore, when you move the cabin, the cabin-deck joins 
always remain exact

There is a more detailed discussion of this model in Tutorial 6 - Superstructures.

File>Close the model (do not save changes).

Moving a bulkhead
Let’s do another one.

1 Open BULKHD1.MS2, from the \Marine Tutorials folder. 

2 <F5> to see the other half of the boat (Fig. 12).

 Fig. 12.  BULKHD1.MS2
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This model includes a hull, a deck, and a bulkhead that meets the hull and deck 
surfaces in watertight joins. We’ve made a bulkhead — now we want to move it. 
There is a green point where the X-axis intersects the bulkhead. It controls the 
longitudinal position of the bulkhead. You can find out its name without our telling 
you:

3 Click or View>Nametags, Point.

4 Click and hold on the green point ‘e0’.

5 Drag ‘e0’ forward a little.

What you get is one repositioned watertight bulkhead that is still watertight.

6 Drag ‘e0’ about 3/4 of the way back toward the stern.

Now we have moved the bulkhead to the stern of the boat, and you can see that the 
bulkhead still joins the hull and the deck accurately — no gaps.

7 Click (Edit>Undo) twice and the bulkhead returns to its original position.

In this model:

• the bulkhead surface is connected, through a series of relationships, to the 
point ‘e0’ — therefore, when you move the point, the bulkhead moves

• ‘e0’ is a special kind of point constrained to lie on a curve — in this case the 
curve is a line that runs along the X-axis, therefore the bulkhead can only move 
forward and aft (not vertically or sideways)

• the edge curves of the bulkhead are special curves that must lie on the deck 
and hull surfaces — therefore, when you move the bulkhead, the bulkhead 
remains watertight

We don’t expect you to fully understand the way these “parametric” models work at 
this point. This is the “show” part of our “show and tell.” As you progress through 
the tutorials, you will gain understanding of the many kinds of relationships 
MultiSurf maintains. We will revisit these three models in Tutorial 6 and explain 
them more fully after you’ve learned some of the basics. This winds up our first 
tutorial. 

8 File>Exit to quit MultiSurf. Click <No> when the program asks if you want to 
save changes.

Tutorial 1 wrap-up
In this lesson you have learned many different ways to view a model, and a number 
of other important ideas for using MultiSurf effectively.  You have also seen some of 
the power of relational geometry.
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Making a Simple Model

Overview
Now that you know from Tutorial 1 how to navigate in MultiSurf, and how to choose 
and control views, let’s jump right in and mess around. We’ll make a model from 
scratch.

This tutorial is longer than the first one. It is easier to follow if you have enough 
flexibility to run the entire sequence without having to close the model. “MultiSurf
Marine Tutorials: Introduction” contains information about taking a break, what to 
do if your screen doesn’t match our instructions, basic terminology, typeface and 
symbol conventions, and trouble shooting. 

The filenames of the intermediate .MS2 files for Tutorial 2 all begin with T2ROW and 
they live in the \Marine Tutorials folder.

In the beginning of this tutorial, we use quite explicit instructions, often down to the 
last MultiSurf mouse click. When we assume you are familiar with a particular menu 
choice or dialog, we give you more general instructions, e.g. the simple instruction:

Select ‘p11’.

would replace the sequence:

In the wireframe drawing, point the cursor towards point ‘p11’.

Click the mouse button.
In the Which Entity dialog, click on “Point  p11” to highlight it.
Click <OK>.

Entity introductions:

• Bead
• Edge Snake
• Line Snake
• Projected Curve
• Ruled Surface
• UV Snake
• XYZ Ring
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Concept and Function introductions:

• , cursor shapes
• <Alt+Enter>, <Ctrl+F>, <Ctrl+H>, <Ctrl+L>, <Ctrl+N>, <Ctrl+W>, <Esc>, <F4>, 

<G>, <O>, <Q>, <S>, <Shift+A> shortcut keys
• *Y=0 default plane and Y=0 plane of symmetry
• Ambiguous Selection
• Bead can drag off end of curve but not sideways
• Ctrl+click adds entity to Selection Set
• Edit Entity in the Property Manager
• Edit>Transform>Scale
• File>New, >Save, >Save As
• Filter Curve, Point, Invert Filters
• Insert>Copy Last
• Insert>Quick Point Mode
• Insert>Quick Spline Mode
• Left mouse click>drag selection
• Lowest dimensionality entity selected
• Mirror Symmetry
• Points drag in plane of screen
• Points explained (2 parents)
• Pre-selected entity
• Preserve Absolute Location / Preserve Offset Values
• Quick Bead/Ring snaps perpendiculaly to curve
• Quick Magnet
• Quick Ring
• Quick Ring placed off end of curve snaps to end of curve
• Replace 'space' with '_' automatically when naming entity
• Right click in white space>Select Mode
• Right click on entity in Selection Set pane>Show
• Right click on entity>Hide
• Select>Class Filters, <Set All>
• Select>Select Mode, >Hidden, >Both, >Reset All Filters, >Clear Selection Set
• Show-Hide>Hide Selection Set, >Show All, >Show Selection Set
• Snakes
• Surface u and v parameters explained
• t parameter explained
• Tickmarks
• Tools>Adopt Children
• Tools>Options, Entity, Quick Spline Defaults
• Tools>Options, General, Auto Orientation
• Tools>Options, Model, Latitude, Model Comment
• Tools>Options, Model Units
• Two Ruled Surfaces joining at their common edge have no gaps
• View>Entity Orientation, Grid
• Which Entity dialog box
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Beginning a new model
All the introductions over, what kind of model shall we create? We may not be ready 
to go to sea yet, but it would be fun to row around in the harbor. We’ll want a 
rowboat. Let’s make one. Where to start? Well, if our overall or long-term goal is a 
rowboat, you might think of a flat bottom, a slanted side and a slanted transom as 
short-term goals (Fig. 1). An underlying objective is that all the seams be watertight.

Fig. 1.  Wireframe of the rowboat we will create.

1 Start MultiSurf by choosing Start>Programs>AeroHydro>MultiSurf (or using 
Windows Explorer; the program filename is WindSurf.EXE).

2 Click or press <Ctrl+N> or choose File>New.

The program opens a window displaying the coordinate axes.

3 Press <O> or choose Tools>Options

4 Under Rotation Constraint, click on the Z axis vertical radio button.

Since our entire rowboat model will be symmetrical with respect to the Y = 0 plane, 
we can take advantage of MultiSurf' mirror symmetry images. Making our model 
with Mirror symmetry means we only need to create one half of the total model.  
When Symmetry Images is turned on during model construction, the rest of the boat 
appears for viewing (Fig. 2).

Fig. 2  The one half of the rowboat we’ll create (left); the entire model with symmetry images (right).

5 Choose the Model tab and under Mirror Symmetry, click the checkbox for 
Y=0 plane.

6 Under Home View, set Latitude to 10 (leave Longitude at 60 and Tilt at 0).

7 In the Model Comment box, type in an identifying message for this model:

rowboat example for tutorial 2

8 In the Model Units tab set Units to Feet / Pounds in the drop down box.  Click
<OK>.

Before we proceed from here, let’s name our file:
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9 Choose File>Save As.

10 Give it the filename ROW1, and put it into the \Marine Tutorials folder. (These 
settings should match the settings in our distribution model T2ROW1.MS2).

11 If you get a warning that ROW1.MS2 already exists and the query to replace 
existing file, just click <Yes> (all this means is that someone has already run 
the tutorial and created a ROW1.MS2 file, which you are now going to overwrite 
with your own ROW1.MS2).

Check program settings
Before we go on, let’s check some other program settings. If we don’t all start with 
the same set now, what we say and what you see as we proceed will be different 
(aargh!). The set we use are the program’s initial defaults, but since the program is 
customizable, you may find differences if you or someone else has already worked 
with your program. This is what you should have:

On the View menu:

Axes and Status Bar should be ON (preceded by a checkmark; to turn an option 
on, simply click on the menu item or if it has a box next to it click on the box).

All Toolbars except Mechanical View Orientation should be ON.  To check 
this, click on Toolbars.  A toolbar is on when checked.

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

Making the side surface
Now we’re ready to create some objects. Remember that you can use our 
intermediate files as checkpoints and/or restart models if you think you’ve gotten off 
the track.

We’ll be creating several kinds of points, a few simple curves, and 6 Ruled Surfaces. 
We’ll use a Ruled Surface for the side surface of our rowboat. This kind of surface is 
made by connecting corresponding points on two curves with a family of straight 
lines. So, we’ll need to make a sheerline curve (the upper edge of the side surface —
the sheer or gunwale), a chine curve (the curve where the side panel joins the 
bottom), and then we’ll make the side panel between these two curves. We'll make 
the sheerline first, creating the three points that define the curve.  Since we will use 
Quick Spline mode to make the points, we will create the sheerline simultaneously.
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Creating the Sheer Curve – Quick Spline.
1 Choose Tools>Options, Entity tab. At the top of this dialog you see settings for 

different Quick Spline options. Check the radio button to create C-Splines, set 
Degree to 3 and make sure the Alternate spline creation box has a check mark. 
<OK>

2 Back in the workspace, click or press <Y> to arrange the view to look down 
the Y axis.

3 Click or <S> or Insert>Quick Spline Mode to turn on Quick Spline mode. 

Notice that the cursor changes from a to a when the pointer is in the 
graphics window.

4 Make the first mouse click above the origin somewhere (it doesn't matter where 
we place these points as we will edit their locations in the next step). Click and 
release and move the mouse to the left. Click again for the second point, 
move to the left and double click to make the last point and end the curve.

5 Go back to Select Mode by using the Right Click menu or pressing <Esc> or 
choosing Select>Select Mode or clicking the toolbar button again or <S>.

6 Click in white space to clear the Selection Set.

Now you clearly see 3 points and a curve passing through them. Rotate the model 

( , or use the wheel) and you will see that the curve was created on the plane 
passing through the origin where all Y coordinates will be equal to zero. Or as we say 
in MultiSurf, the Y=0 Plane.

Editing the curve.
To edit the curve we edit the points which are the parents of the curve. 

1 Go to Home view ( ) and click on the point furthest to the right. This 
allows you to edit the point in the Property Manager.  

2 Change the name of this point to  ‘s1’ (short for sheer 1).

Here’s a printing convention: We print the names of objects inside single quotes. 
When you type in the name, don’t type the quotes, just the name that’s inside them.

3 Change the location of ‘s1’ to the following coordinates.

dx = 0
dy = 0
dz = 1.5

4 Press <Enter> or click <OK> to accept the location.  Don't worry if the point 
disappears from view.  We'll show you how to see it and the other two after we 
have finished editing them.
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From here we will edit the location of the other 2 points to complete the Sheer curve.

5 Click on the middle point to edit.

6 Change the name to ‘s2’ and change the location of ‘s2’ to the following 
coordinates.

dx = 6
dy = 2
dz = 1

7 Again press <Enter> or click <OK> to accept the location.

8 <PgDn> or use Zoom In\Out or Zoom to Fit (which are available from either the 
View>Modify menu or the Right Click menu) or spin the wheel of your mouse 
if you have a wheel until the whole curve becomes visible.

9 Edit the last point and change the name to ‘s3’

Again, accept the other defaults for ‘s3’, and change the location to:

dx = 12
dy = 1.5
dz = 1.2

10 <OK> to the Edit dialog and or <F> or View>Modify>Zoom to Fit.

Here’s the rationale behind the locations of dx, dy and dz: the overall length of our 
rowboat is 12 ft, which shows up as the dx-value of ‘s3’ (stern); the dx-value at ‘s2’ 
(midships) is 6, and zero at ‘s3’ (bow). The maximum beam is a little over 4 ft (2 times 
dy of ‘s2’) just aft of 's2'; the 3-ft transom breadth is 2 times dy of ‘s3’. dz shows the 
values set for freeboard: 1.5 ft at the bow, 1.0 ft midships, and 1.2 ft at the stern.

X

Y

Z

's1''s2'

's3'

Fig. 3. Rowboat model; first 3 points; Lat 10, Lon 60.

11 Click (or choose View>Nametags and click the Point checkbox; then 
click <OK>). The point nametags appear diagonally down-right from their 
respective points.
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12 Click on the curve and change the name to ‘sheer’. Click <OK> to accept the 
Edit dialog. 

13 Click or File>Save. [This should match our distribution model 
T2ROW1.MS2.]

14 Press <F5> to turn Symmetry Images on  and take a look at the or <X> and 

or <Z> views as well.

15 Click or press <G> or choose View>Grid. A ten-unit-by-ten-unit grid, 
subdivided into units, is displayed along with the model. The status bar reports 
the size of the smallest grid divisions, in this case 1. Grids are visible only in 
orthographic views that are parallel to one of the coordinate axes. (The <Z> view 
is parallel to both X and Y axes, so we see both vertical and horizontal grid lines  
in this case). Note that <G> is a toggle; pressing it again would toggle the grid off 
(leave it on for now).

Making the chine — another C-spline Curve
To create a ruled surface for the side, we need two curves between which to make the 
side panel. So, we will create another C-spline Curve.

1 <F5> to turn Symmetry Images off.

2 Take the or <Y> view.

3 Click to turn on Quick Spline Mode.

The coordinates of the moving cursor are displayed on the status bar at the lower left 
hand corner of the workspace.

4 Let’s move our cursor to around X=0.83 and  Z=-0.17 and click to place our first 
point.

5 Place two more points to the left roughly down the X-axis.   Don't forget to 
double click the last point to end the curve and don’t worry about the location of 
these points, we will fix that next.

6 Return to Select Mode.

You may have hit 0.83, 0, -0.17 exactly, but then again, you may not have. In many 
cases, placing a point by eye is perfectly adequate, but in this case we want everyone 
working with the same model; so, to keep things even:
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7 Click on the first point you just created to edit in the Property Manager and set:

Name = 'c1'
dx = 0.83
dy = 0
dz = -0.17
<OK>.

This is, in fact, often the way we locate points either by creating them or dragging 
them.  We insert or drag a point roughly where we want it, then Edit in the Property 
Manager,  look at the coordinates that come up, then type in the exact numbers if 
needed, particularly accurate zeroes.

One other thing you need to know about dragging points: the motion is all in the 
plane of the screen. In this case, since we are using the <Y> projection (an 
orthographic view in which the world X and Z axes are parallel to the screen axes), 
the dragging affects only the X and Z coordinates of the point we are moving.

Creating a Relationship 
Now we’ll edit one of the existing points to create a relationship.

1 Click the middle point on the curve we just created to enter edit mode.

Notice in the Property Manager for the point includes a section labeled 'Parents'.  
Every point in MultiSurf has two parents.  If the default parents are accepted, then 
the point location (dx, dy, dz) is measured from the global origin (*), and measured 
along the global coordinate system, also labeled *.  If a point other than the default 
point is entered then dx, dy and dz is measured from that point.

2 Change the name of the point to ‘c2’

We want 'c2' to be at the mid point of 'chine' so lets base its location on the midpoint 
of 'sheer', 's2'.  To do this, change its Point Parent from the default point to 's2'.

3 In the Parents box click in the Point field.  You should see the Point field turn 
salmon color.

4 Click the point ‘s2’ from the graphics view, the Available Entities pane or the 
Surface Manager.  This places the Point ‘s2’ in this field and brings up a box with 
two choices.  Since we will be changing the values of dx, dy and dz this choice 
does not matter. Preserve Absolute Location keeps 'c2' where it is in space, 
and adjusts the values to match.  Preserve Offset Values keeps the values, and 
moves the point to match.

5 Set dx = 0, dy = -0.25, dz = -1.50 (<Tab> from cell to cell).

6 Press <Enter> (or click <OK>) to accept the location.

The special thing about the relationship we've just set up is that 'c2' now stays in its 
specified relationship to 's2'.  To demonstrate this:

7 Try dragging ‘s2’ around a bit.  Notice that ‘c2’ follows it, moving by just the 
same amount, so it stays .25 units to the left and 1.50 units under ‘s2’. Note also, 
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when dragging ‘s2’, how 'sheer' and 'chine' update and adapt to the new
positions of ‘s2’ and 'c2'.

8 Undo the change with or Edit>Undo.

9 To create another relationship:

Edit the last point on the chine curve.
Rename the point ‘c3’.
Click in the Point field of the Parents box.
Click the point ‘s3’ from the graphics view, the  Entities Manager. This places 
the point ‘s3’ in this field.
Click either button from the "Preserve absolute location or offset values?" box.
Change the location of c3 to:
dx = -0.17, dy = -0.25, dz = -1.37
<OK> to the Edit dialog.

10 Click on the lower curve and change its Name to ‘chine’.

11 Click or press <G> or choose View>Grid to turn off Grid.

12 File>Save to protect your work so far.

'sheer'

'chine'

X

Z

Fig. 4.  Rowboat model with the chine added; <Y> view.

Creating the side surface — a Ruled Surface
Now we’re set to make our first surface, a Ruled Surface, that will be the side surface 
of our rowboat.

1 With 'chine' still in the Selection Set, click >Ruled Surface or
Insert>Surface>Ruled Surface.  Name the surface 'side'.

Notice that the "Control curves" field has 'chine' in it.  A Ruled Surface requires 2 
curves.  The first curve, 'chine' was "pre-selected" by us because it was in the 
Selection Set when we opened the Insert Ruled Surface Dialog.  This is one way to 
pick parents for entities.  The other way is to pick them after the Dialog is open.

2 In the graphics view, Ctrl+click ‘sheer’ any place along its length to place it 
into the 'Control curves' field.

Since one of the parents has already been selected, we need to add a curve to the 
Selection Set, which is done by holding down the Ctrl key while selecting.  (If we 
selected 'sheer' without using the Ctrl key, we would replace 'chine' with 'sheer').  
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You can tell when you are on the curve when the cursor becomes .  If you hold it 
still briefly, a tooltip appears saying "C-spline Curve sheer".  (If you place the cursor 

over one of the end- or midpoints, the cursor will become , showing that you are 
over a point).

Side trip.  MultiSurf has to try to figure out what you mean when you click in the 
workspace.  It helps do this by giving you feedback about what the mouse is 
pointing at.  It also selects the entity with the lowest dimensionality if you are 
pointing at more than one.  If, for example, a point and a line are coincident, it 
assumes that you want the point.  If you want the line, move the cursor just a 
little and you will get a shot at the line.  If you have two entities of the same 
dimensionality 2 points, say, or 2 lines, you get what is called an Ambiguous 
Selection.  This is explained in step 7 under "Making a watertight, horizontal 
bottom".

3 Be sure that u-Divisions are set to 32x1 and v-Divisions are set to 1x1.  We'll 
discuss surface u and v parameters below.

4 Click 'OK' to accept the new object (Fig. 5).

X

Z

Fig. 5.  Rowboat model with the side surface added; <Y> view.

5 (File>Save), just for good measure. [This should match our distribution 
model T2ROW2.MS2]

6 Rotate the model around to see what you have.

7 Press F5 (View>Symmetry Images) to see the symmetry image as well.

8 to get the original view.

9 Rotate to see the bottomlessness. (Yes, it’s sternless too!)

10 Then turn the Symmetry Images off with <F5>.



Making a Simple Model Show and Hide Entities to Simplify the display

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  39

Show and Hide Entities to Simplify the display
The model pictured on the screen is composed of points, curves, and a surface. 
Sometimes, it is simpler to work with only some of the objects displayed. MultiSurf
lets you show and hide objects in any combination you choose. The basic process is 
to create a Selection Set and then hide it.

We’re going to hide the ‘side’ surface (here today; gone tomorrow!):

1 Select the surface ‘side’.

2 Click or choose Show-Hide>Hide Selection Set (<Ctrl+H> also works).  
All you should see now is 6 points and 2 curves. Don’t worry, the ‘side’ surface is 
still in the model; we have just made it temporarily invisible. We could bring it 

back any time with or Show-Hide>Show All.

3 You can also  right click on an entity and select ‘hide’ from the drop down menu 
or edit its definition and on the Display tab choose "Hidden".

Making a watertight, horizontal bottom
The side looks nice, but now we need to do something about a bottom for the boat. 
We’ll make the bottom with another Ruled Surface. We want it to be watertight and 
flat, following the curve of the chine.  By using the chine for the bottom edge of the 
side and the outer edge of the bottom, we ensure a watertight join. If we could make 
a curve in the center of the boat that is parallel to ‘chine’ and lay the bottom between 
the curves, it would assure that the bottom is durably flat across the centerplane. The 
solution for our problem is a Projected Curve. A Projected Curve is a curve formed 
by projecting a basis curve onto a Mirror. Each point of the basis curve is projected 
normally (perpendicularly) onto Mirror; the Projected Curve therefore lies entirely in
Mirror. Mirror can be a plane, line, or even a point object. In this case we will use a 
plane.

1 Select 'chine' by clicking on it in the workspace.

2 Click >Projected Curve or Insert>Curve>Projected Curve.

Notice that the first support "Curve" is filled in with 'chine' because we had pre-
selected it. The second support "Mirror" is filled in with "EMPTY".  This is the 
way MultiSurf lets you know that no entity has been picked yet for this support.  
We want to project 'chine' parallel to the Y axis onto the y=0 plane.  This plane 
exists in MultiSurf as one of the default planes.  It is called *Y=0 and can be 
picked from the Entity Manager.  To do this:

3 Expand the System Heading in the Entity Manager.

4 The Insert Dialog opened with the Mirror support box active (salmon 
background).  If it is not now, click inside the box to make it active.
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5 Select *Y=0 from the list by clicking on it.  *Y=0 now appears in the Mirror 
support box.  Change the Name to 'bottom ctr'.  Did you notice that MultiSurf
automatically placed a '_' when you typed a space?  MultiSurf does not allow 
spaces in names, but you can type them, and we'll do the rest.  In the Display
tab, make the color bright blue.  Click OK. (Fig. 6)

X

Y

Z

projected curve

basis curve

Fig. 6.  Rowboat model with the bottom centerline curve (a Projected Curve) added; Home view.

Now we have the two curves needed to create the bottom surface. On with the 
project:

6 Pick or <Y> view.

7 Click on the bottom curve.  Since 'bottom_ctr' is directly behind 'chine' in this 
view, MultiSurf cannot tell which entity you want.  We call this situation an 
"ambiguous selection".  When this happens, MultiSurf informs you by changing 
the cursor to .  The result of clicking when you see this cursor is a "Which 
Entity?" box that lists all of the entities that can be selected at this location.  To 
select the one you want, click on it and then click on <Select>.  In this case, 
select 'bottom_ctr'.

8 Ctrl+click the bottom line again, and the "Which Entity?" box appears again.  
MultiSurf again does not know which entity you want.  This time select 'chine' 
and click <Select>.  The Selection Set pane should now show the two curves 
'bottom_ctr' and 'chine'.

9 >Ruled Surface

Name = ‘bottom’
Control curves = (pre-selected)
Color = brown
Click <OK> to create a flat, brown bottom to the boat. [This should match 
our distribution model T2ROW3.MS2.]

10 <F5> and rotate to see the symmetry image as well.

11 Clear the Selection Set.  To do this you can click or choose Select>Clear 
Selection Set or press <Ctrl+L> or left mouse button click in white space or
you can even click on each entity in the Selection Set and click .
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Filters 1
We would like to take a look at everything we have created so far, but remember that 
we hid the side surface? How can we select an entity if we can't see it on the screen?  
There are several ways we can show this surface again — we’ll demonstrate one that 
uses the Available Entities pane.  We will use a filter to help us:

1 Select>Hidden. This is one of the filters MultiSurf offers. Setting a filter makes 
only the objects that fit the filter available in the Available Entities pane. Our 
Available Entities now consist only of hidden objects and the default entities 
(which are always available).

Part of being available is being able to pass through any filters that might be set. In 
this case, we have the Hidden filter set, so the only entity available to be put in the 
selection set, other than the default entities, is our hidden object, the side surface 
‘side’.

2 In the Available Entities pane, click 'side'. This puts ‘side’ into the Selection Set.

3 From here you can either click or Show-Hide>Show Selection Set or 
<Ctrl+W> or Right click on ‘side’ in the Selection Set pane and choose 
Show.  Presto! there’s our side again.

4 Select>Both to turn on both Hidden and Visible filters.

5 Pick or <Shift+X> view.

6 Click on 's2' (the point midships on ‘sheer’) and drag it outward some to a new 
position.  Make sure you click on 's2' and not its symmetry image, which, 
because it is just an image, will not drag.

7 Note that:

the side stays slanted
the seam between the side and the bottom stays watertight
the bottom stays flat across the centerline.

As we mentioned before, these are durable qualitative properties of our model, which 
have resulted from our particular choice of entities and dependencies.

8 (Edit>Undo) to undo this last change.

And it’s time for another side-trip:

Filters 2
While we’re here, let’s do one more demonstration of filters. Let’s say you want to 
see just the surfaces of this model and none of the points, curves, or planes:

1 On the Filters toolbar click and to turn off Points and Curves filters.
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2 Click to invert the filter selection.  (Points and Curves filters back on, all the 
rest off).

3 Left mouse click and drag a box around the whole model.  This puts all 
points and curves in the Selection Set.

4 Click or Show-Hide>Hide Selection Set.

Now when you rotate the model all you can see is the surfaces.

5 To show the hidden objects this time click or Show-Hide>Show All.

The side-trip behind us,

6 Rotate the model to see the bottom.

7 Turn off Symmetry Images with <F5>.

Well, our boat is bottomless no more, but still wouldn’t float; the next step is to build 
a transom for it. The transom, too, has to join the sides and the bottom in a watertight 
seam.

Creating the transom surface
We will make another Ruled Surface for the transom. We will start the construction 
by creating an Edge Snake. Snakes are curves constrained to lie on a surface; an Edge 
Snake is a special line snake lying along one complete edge of a surface.

We’d like to preselect ‘side’, but what happens when you try clicking on ‘side’?

Nothing happens, right?  Why can’t you select it? Remember those class filters we set 
to just Points and Curves so we could hide those kinds of objects and just see the 
surfaces? Well, the filters are still set that way. You can see immediately that the filter 
for Surfaces is turned off by looking at the Filters toolbar.  The Surfaces filter is dark 
gray, meaning OFF; the Points and Curves buttons are light gray, meaning ON.

To be able to select surfaces, we could just click the surfaces filter button ON, but 
instead, let’s reset the filters so we can select all kinds of objects.

1 Select>Reset All Filters or <Ctrl+F> is quickest. Although this option sets all
filters (not just the class filters) back to the program defaults — all Class filters 
ON, the Current Layer Only filter to OFF, and the visible/hidden filter to Both —
we can take advantage of it here because our non-class-filter settings are the 
same as the defaults. (Select>Class Filters, Set All would have reset only the class 
filters.)

2 Now, click ‘side’ again; success!
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3 >Edge Snake or Insert>Snake>Edge Snake

Name = ‘tr_side’ (remember, you can just type 'tr side' and the program fills 
in the underscore)
Surface edge = u=1
Surface = ‘side’ (pre-selected)
<OK>

One curve is not enough to build a Ruled Surface, so we will project ’tr_side’ onto the 
centerplane for the other one. Remember that the parents for a Projected Curve are a 
curve and a mirror.  ‘tr_side’ is already selected.

4 >Projected Curve or Insert>Curve> Projected Curve

Name = ‘tr_ctr’
Curve = ‘tr_side’ (pre-selected)
Mirror = ‘*Y=0’
<OK>

And now for the transom surface:

5 Preselect ‘tr_side’ and ‘tr_ctr’.

6 >Ruled Surface or Insert>Surface>Ruled Surface

Name = ‘transom’
Control curves = (pre-selected)
u-divisions = 8x4
v-divisions = 1x1
<OK>  (Fig. 7)

[This should match our distribution model T2ROW4.MS2.]

X

Z

Y

Fig. 7.  Rowboat model with the transom surface added; Home view.

Let’s have a look:

7 <F5> to turn the symmetry images on.

8 Rotate to see the bottom as well.

Looks nice, doesn’t it, but is it also watertight? We argued earlier that the sides and 
the bottom joined in a watertight seam; how about the transom? The transom is 
watertight to the side since an Edge Snake lying on the edge of the side also forms an 
edge to the transom. And it’s also watertight to the bottom since both surfaces are 
Ruled Surfaces whose end rulings are straight lines between the same two points.
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Locating the oarlock — a Bead
The boat is watertight, but still not very useful until we can fasten our oars onto it; 
we need oarlocks. Oarlocks need to be located on the sheer and should stay there too, 
even if we might later decide to change the sheer. The entity to do the job is a bead: a 
point constrained to lie on a curve.

1 <F5> to turn the symmetry images off.

2 Select ‘side’ (green), and hide it again.

3 Preselect ‘sheer’.

4 >Bead or Insert>Point>Bead

Name = ‘oarlock’
<OK> to accept all the other defaults

Now we have a bead for the oarlock at the midpoint of the sheerline (default 
location). Before we decide on the final location, let’s take a little side-trip to explain 
how we specify the position of a bead along its curve.

The t parameter and tickmarks for a curve
1 Click ‘sheer’ to Edit in the Property Manager.

2 Turn on tickmarks by clicking in the check box.

3 Click <OK> to accept the edit.  The tickmarks may be easier to see if you remove 
the line from the Selection Set so that the line is no longer bold.

Every MultiSurf curve (curve, line or snake) has a parameter we call t which varies 
over the range of 0 to 1.  For any curve, you can see the distribution of t along its 
length by turning on its tickmarks found in its Edit dialog on the Display tab.  
Tickmarks are displayed at the nine t values: t=0.1, 0.2 … 0.9.

When you select a curve, orientation marks are displayed that show:

• A circle around the end where t=0.

• An arrow at t=0.5 pointing in the direction of positive t.

In the Tools>Options, General tab, under Auto Orientation you can select when 
these marks are displayed.  You can also force any particular entity to keep its 

orientation mark by selecting the entity and then clicking or View>Entity 
Orientation.

Let’s turn off the tickmarks:

4 Select 'sheer' to edit in the Property Manager..

5 Turn off tickmarks.  <OK>.
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Dragging a bead
Now to our oarlock. The default location for any added bead is t = 0.5. Let’s play 
with this bead for a moment, to see how it works:

1 Drag the bead several places along ‘sheer’. While you are dragging, watch 
the dynamic t-values on the status bar (the 3 values in parentheses to the left are 
the absolute coordinates).

2 Try to drag the bead sideways off the curve.  You can’t, of course, because 
beads are constrained to lie on a curve.  You can, however, drag it off the end of 
the curve, because MultiSurf defines a curve beyond its user defined endpoints.

3 Finally, click on the bead and type in its position at t = 0.7.

Let’s show the side again:

4 Click or Show-Hide>Show All.

5 Click or File>Save. [This should match our distribution model 
T2ROW5.MS2.]

Not bad!

Adding thwarts
Still something missing from our boat? Well, it would be nice to have something to 
sit on. We’ll want thwarts attached to the sides. As usual, the starting point is just 
that — a point, in this case a Quick magnet.

Looking at u, v surface parameters
Just as a bead is a point that stays on a curve, a “magnet” is a point that stays on a 
surface. How do we locate things on a surface? Well, any MultiSurf surface has two
parameters we call u and v, which are similar to the single parameter t on a curve. u 
and v vary independently, each over the range of 0 to 1. The mesh of lines that we 
use to display a surface is made up of two families of curves, one family running in 
the u-direction (along constant values of v) and one family in the v-direction (along 
constant values of u).

We’ll use the side surface to demonstrate the u,v mesh. Ruled Surfaces generally are 
displayed using only 1 x 1 divisions in the v-direction, but we can change that:

1 Click ‘side’ to edit in the Property Manager.  Set:

u-Divisions = 32x1
v-Divisions = 4x1
<OK>

With the surface still selected, look for its orientation marks:

1 a circle around the corner where both u and v are zero
2 a “u” along the edge that makes the u-direction, i.e. where v = 0
3 a “v” along the edge that makes the v-direction, i.e. where u = 0
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4 arrowheads along the u and v edges, showing the direction of increasing u, v.
5 an arrow emanating from the center of the surface and pointing in the direction 

of the positive normal to the surface.

These orienting tools show you that the mesh of lines is much like a 2D coordinate 
grid painted on the surface. We’ll use this information when we create the next 
object: a magnet, which is a point constrained to lie on a surface. The side surface 
‘side’ is already selected, so we’re ready to go.

2 Choose or <Q> or Insert>Quick Point Mode.

The entity created by Quick Point Mode depends on the entity in the Selection Set 
when it is turned on.  If the Selection Set is empty a Point is made, if there is a curve 
in the Selection Set a Bead is made, if there is a snake in the Selection Set a Ring is 
made and if there is a surface in the Selection Set a Magnet is made.  Because a 
surface was selected, magnets will be created here.

3 Move the mouse over 'side' and watch the status line.  Click the mouse to
drop the magnet when you get to roughly u = 0.50, v = 0.375.

4 Turn off Quick Point Mode.

5 Click the magnet to edit in the Property Manager.

u = 0.50
v = 0.375
<OK>

Three thwarts
We have our starting point. From this magnet we will create a curve upon which all 
three thwarts are based.

1 If it is not still in the Selection Set, select ‘magnet1’

2 >UV Snake or Insert>Snake>UV Snake

Name = 'snake1'
Type = 'v=constant'
Magnet = 'magnet1' (pre-selected)
<OK>

3 With 'snake1' in the Selection Set, go to Quick Point Mode again.  Now since 
there is a snake in the Selection Set, Rings will be created.

4 Hold the cursor off the end of the snake at the bow and click the mouse. You 
will see the Ring snap to the end of the UV Snake. Click 4 more rings on the 
interior of the snake and another off the end at the stern.  When you place rings 
or beads with Quick Points, the ring or bead will snap approximately 
perpendicularly from the cursor onto the curve.

5 Return to Select Mode

6 The rings were created and named, bow to stern, ring1 to ring6. Select ‘ring1’ 
and ‘ring2’.
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7 >Line Snake or Insert>Snake>Line Snake.

<OK> to accept all defaults

8 Repeat for the other 2 pairs. (Rings 3 and 4, and Rings 5 and 6).  This is most 
easily accomplished by selecting the next set of rings and pressing <F4> or 
Insert>Copy Last which repeats the last entity made.  Use <F4> for the next 
step as well.

9 Project all three Line Snakes on to the *Y=0 plane.  Recall from projecting 'chine' 

onto this same plane how to do this?  (Select a snake, choose >Projected 
Curve, select *Y=0 as the Mirror, <OK>).

10 Create Ruled surfaces between the Line Snakes and their Projected Curves.  
(You should have this down by now.)

11 Drag the rings on the UV snake to move the thwarts along the length of the 
boat and to adjust their width. 

XYZ Rings could be substituted to place the thwarts at an exact X position and to 
model the width with precise dimensions. Let’s do this with the center thwart.

12 Select the UV Snake ‘snake1’.

13 >XYZ Ring or Insert>Ring>XYZ Ring

Name = ‘seat_pos’
Ring/Snake = 'snake1' (pre-selected)
Location, Constrain to:   X=3.25
<OK>

14 Select 'snake1' again and <F4> or Insert>Copy Last to make another XYZ 
Ring.  If you have difficulty picking 'seat_pos' as the 'Relative to' constraint, try 
using the Surface Manager or Available Entities pane.

Name = ‘seat_width’
Ring/Snake = 'snake1' (pre-selected)
Location, Constrain to:   X=1
Relative to = ‘seat_pos’
<OK>

To substitute the XYZ Ring ‘seat_pos’ in place of Ring ‘ring3’ we will use a 
function called Adopt Children. We use this when we want to replace one entity with 
another or have one entity adopt all the children of the other. In this case ‘seat_pos’ 
will adopt the children of ‘ring3’.

For the operation to work properly we need to have both entities in the Selection Set. 
The entity to be replaced is first in the set. This order can be changed while in the 
Adopt Children dialog. For this example we will select them in the proper order.

15 Select ‘ring3’ and ‘seat_pos’ in that order. Press <Shift+A> or Tools>Adopt 
Children.

16 Check box to 'Delete old parent ring3?'.  <OK>
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17 Repeat for ‘ring4’ and ‘seat_width’.

18 Drag ‘seat pos’ to an approximate location or edit its location for a precise 
placement of the thwart. Drag 'magnet1' to raise or lower all of the thwarts at 
once.[This should match our distribution model T2ROW6.MS2.]

Fig. 8.  Rowboat model with three thwarts added; Home view.

Not bad! Now, who brought the oars?

Refining the rowboat
Note that we planned each of the relationships we built into the model; and we can 
change any of them at any time. 

Actually, this is a pretty big rowboat. Suppose we decide now, on reflection (before 
we have to carry it down to the water), that 11 ft overall length would be big enough, 
and we’d like to reduce the freeboards and depths in proportion. Easy enough with 
MultiSurf:

1 Edit>Transform>Scale

All transformable objects in the model radio button
Transform factor for X = 0.917 (that’s 11/12)
Transform factor for Y = 1
Transform factor for Z = 0.917 
<OK>

Don't worry about the Non-Transformable Entities warning box.  Since only Points 
are scaleable in MultiSurf, if you try to Scale an entity other than a Point, this box 
warns you that that entity will not scale directly.  If you put an entity's parent points 
in the Selection Set it will scale properly.  See Transform in the Reference Guide to 
Functions section of the manual for more details. 

Suppose beam is 2” wider than desired while transom is 2” too narrow.

2 Switch to or <Z> view.

3 Set filters for Points only.

4 Click ‘s2’ (midships on ‘sheer’).

5 Reduce dy by 1 inch to 1.917 feet.  (1" is 1/12 or 0.083 feet.)  <OK>.

6 Click ‘s3’ (at stern on ‘sheer’).

7 Increase dy by 1” to 1.583.  <OK>.
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Do you see what Relational Geometry has done for us? We built up a model 
consisting of 32 entities. At the very end, we went back to the second and third 
objects, on which all subsequent objects depend, and said “I wish I had done these a 
little differently.” So we make the changes, and presto! — we have our complete new 
design that maintains all the properties we specified:

• the boat is precisely symmetric about the centerplane
• slanted sides (the angles haven’t changed)
• a flat bottom
• a flat, slanted transom
• all watertight seams

These properties (aside from Y symmetry, which is a global property of the model) 
have all been preserved because of the relationships we captured through our choice 
of entities for the model:

• The side surface durably has its particular slant because of the relative points 
we used in making the chine relate to the sheer.

• The bottom remains flat because it’s a ruled surface between the chine and the 
chine’s projection onto the centerplane.

• The transom is flat because it’s a ruled surface between a straight line (the 
straight edge of another ruled surface) and its projection onto the centerplane.

• The seams are durably watertight because the panel edges share common 
curves or are identical straight lines.

That winds up this second tutorial. You’re well on your way with MultiSurf —
you’ve created an entire MultiSurf model!

8 Choose File>Exit to quit MultiSurf.

Tutorial wrap-up
In this lesson, you have created a simple MultiSurf model. You used four kinds of 
point entities:

• points — points in 3D space
• beads — points constrained to lie on a curve
• rings — points constrained to lie on a snake
• magnets — points constrained to lie on a surface

You used three kinds of curve entities:

• curves — curves in 3D space
• snakes — curves constrained to lie on a surface
• projected curves — curves projected onto a plane

And you made ruled surfaces. In the process, you’ve seen how MultiSurf models are 
built up from points to curves to surfaces and how you can build in durable 
relationships by using the right entity and type of dependency.

You’ve also been introduced to pre-selection of support objects, to filters, and to 
different kinds of views you can have of a model (graphics, Surface Manager).
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Interacting with Models

Overview
MultiSurf models are changed to achieve design objectives by a set of editing 
operations. In one way or another, you can change almost any attribute of any entity 
in your model. We will lead you through a series of transformations of the DEMO 
model. For clarity we will take these transformations one at a time, and we will 
generally go back to the unaltered DEMO model before starting the next change.

Entity introductions:

• Arc Lofted Surface
• Frame entity explained
• Line
• Point

Concept and Function introductions:

• , , cursor shapes
• consecutive points on a line make a straight section in a B-spline Curve
• Adjust Contours locations
• B-spline Curve always starts at first control point
• Change name in Entity Manager
• Contours entity must be built from shiftable entity if you want it to shift
• Contours filter
• C-spline Lofted Surface always attached to first curve
• Drag select
• Edit>Transform>Shift
• File>Export 3D>3DA wireframe
• Quick Bead
• Show only Boundary lines on a surface
• Show-Hide>Show Parents
• Surfaces filter
• Tools>Options, Dragging, Dragging, Orthogonal Dragging
• Tools>Options, Dragging, Snap increment
• Tools>Options, Dragging, Snap, Clear All Tools>Options, Dragging, 

Snap, Set All
• View>Display>Curvature Profile

• Zoom to Area+click centers the model at the click point

If at any time what you see doesn’t match what we are saying, just back up to the 
most recent place where we began with the original DEMO model and proceed anew 
(you may have done something as simple as skipping a line in the text), or use an 
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intermediate distribution file.  The intermediate .MS2 files for Tutorial 3 live in the 
\MultiSurf TUTORIALS folder.

“MultiSurf Marine Tutorials: Introduction” contains information about taking a 
break, what to do if your screen doesn’t match our instructions, basic terminology, 
typeface and symbol conventions, and trouble shooting.

When you Save As or Export files in this tutorial, you may get a “Replace existing 
file?” query. If you do, it just means someone has already run the tutorial and saved 
a file under that name. Go ahead and replace the file.

1 Start MultiSurf  

by choosing Start>Programs>AeroHydro>MultiSurf 

(or using Windows Explorer; the program filename is )WINDSURF.EXE.

2 File>Open, DEMO.MS2 from the \Marine Tutorials folder (directory) (Fig 1, 
top). 

3 Maximize the graphic display window.

Check program settings
Before we go on, let’s check some program settings. If we don’t all start with the 
same set now, what we say and what you see as we proceed will be different 
(aargh!). The set we use are the program’s initial defaults, but since the program is 
customizable, you may find differences if you or someone else has already worked 
with your program. This is what you should have:

On the View menu:

Axes and Status Bar should be ON (preceded by a checkmark; to turn an option 
on, simply click on the menu item or if it has a box next to it click on the box).

All Toolbars except Mechanical View Orientation should be ON.  To check 
this, click on Toolbars.  A toolbar is on when checked.

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

Scale model
One of the simplest editing operations is to scale the model uniformly in one, two, or 
three of the axis directions. For example, DEMO is a 30-ft sailboat hull. Suppose we 
wanted a 40-ft sailboat. One way to get this is to multiply the X-coordinate of every 
point by a constant factor of 40/30 = 1.333. Let’s do this and see the result.

1 Edit>Transform>Scale. The dialog box lets you set scale factors for X, Y, and Z.  
For this example, type 1.333 in the
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Transform factor for X field and click
<OK> then click <OK> to the non-

transformable entity box.  or <F> 
(Zoom to Fit) to see the new stretched 
model.  The X-scaled boat hull (Fig. 1, 
middle) is 33.3% longer than DEMO, but 
otherwise unchanged. In particular, the 
Y and Z coordinates of each point in the 
model were unaffected; just the X 
coordinates were multiplied by 1.333.

Now this does indeed make a 40-ft boat, but 
one that is out of proportion with practice. A 
typical 40-ft sailboat would have its beam 
(width) increased almost in proportion to 
length, to provide more stability and more 
room inside. Also, its heights (freeboard and 
depth) would normally be increased, by a 
somewhat smaller factor, again to gain space 
inside. Let’s do this:

Fig. 1

2 Edit>Transform>Scale again.

This time <Tab> to the Transform factor for Y field and type in 1.3.
Then <Tab> to the Transform factor for Z field and type in 1.25.
<OK> and <OK> to the transformable entity box. (You don’t repeat the 1.333 
factor for X scale; that’s already been done.)

The model updates and shows a hull that is in reasonable proportion for a 40-ft 
sailboat (Fig. 1, bottom).

You can also use a negative scale factor; this reverses the model’s orientation with 
respect to the axis involved. For example:

3 Press or <Y> to see a profile view.

4 Choose or <F> to see the whole boat (Fig. 2, left)



Interacting with Models Shift model

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  54

5 Edit>Transform>Scale.

X scale factor = -1; <OK>, <OK>.

6 to see the whole boat — it is now stretched along the negative X-axis with its 
bow toward positive X (Fig. 2, right). Some designers prefer this orientation.

Fig. 2

A zero scale factor is also permitted, but is not often a useful transformation:

7 Edit>Transform>Scale.

Y scale factor = 0 (zero); <OK>, <OK>. 

8 Look at the , (<X>) and , (<Z>) views and you can see the model has 
been completely flattened out onto the Y = 0 plane (because all Y-coordinates 
have been multiplied by zero).

9 4 times to get back to the original DEMO model — you’ll know you are 
back at the beginning when the toolbar undo arrow grays out.  If you prefer, just 
close the file without saving and re-open it.

10 Return to <Y> view and to see the whole boat again.

Shift model
Another simple change is to shift (translate) the model to a new location in the global 
coordinate system. For example, you might prefer to have X measured from the 
middle of the waterline, instead of the forward end of the boat. For the DEMO 
model, this requires a negative shift of all X-coordinates. Or you might like to have Z 
measured from a base plane at the bottom of the keel, instead of from the design 
waterline. For DEMO, this requires a positive shift of all Z-coordinates.

To do the shift that lets us measure X from the middle of the waterline, we need to 
find out the X-coordinate at that middle point. We can use the model’s Contours in 
the X-plane (stations) as our information source. They are an evenly-spaced set of 11 
stations, starting at the forward end of the waterline, ending at the aft end, and 
numbered 0 to 10; therefore station 5 falls at the midpoint. Let’s calculate its X-
coordinate:

1 Double click on ‘stations' (red) either in the graphics view or the Available 
Entities pane.  If you use the graphics view, you can tell when you are over a 
Contours entity when the cursor changes to .
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In the Edit Entity dialog:

Signed distance from Mirror/Surface to 0-index contour (the X-position of station 0) = 
1.8 and Contour spacing (the station spacing) = 2.735; so station 5 is at:  1.8 + (5 ×
2.735) = 15.475. This is the distance we must shift the boat in the negative X-
direction to make X = 0 be at midship.

Notice that the Mirror/Surface is 'plane1' (hidden).  In order to shift, a contour must be 
built from an entity that will also shift.  Since default planes do not shift, we had to 
create a 2-Point Plane for this contour and for 'waterlines' we made a 2-Point Plane 
on the Z=0 plane.

2 <Cancel> (or <Esc>) to close the Edit dialog without making any changes.

3 Display the Grid ( or <G>).

4 Zoom Out so you can see the shift.

5 Edit>Transform>Shift.

Click the "All transformable objects in the model" radio button
X shift = -15.475 (note the minus).
Z shift = 6 (this Z-shift will put the Z = 0 baseline at the bottom of an as-of-yet-
undesigned keel).
<OK>, <OK> (Fig. 3, bottom).

Fig. 3.  DEMO.MS2: initial model (top) and shifted model (bottom).

6 back to the original DEMO model again.

7 to see the original view of the model.

Reshape the stem
The next examples involve more steps, so we have provided intermediate model files 
for you, just in case. If you get confused and don’t want to go all the way back to the 
beginning of a sequence of edits, load an intermediate file, noting where it fits in the 
text. E.g: [This should match our distribution model DEMOTR3A.MS2].

Many model transformations and edits involve moving individual point entities. 
Recall that you can do this either by “dragging” the point on the screen and/or by 
typing in new coordinates or offsets in the Edit Entity dialog.
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For these examples, we’ll use a modification of the DEMO model — one that has a 
cylindrical transom surface (rather than no transom surface).

1 File>Open>DEMO-TR3.MS2.

Let’s start this editing by focusing on the bow.

2 Maximize the graphics window.

3 Move to the or <Y> view.

4 to display the grid.

5 Zoom in on the bow.  Click and drag a box with corners at about:

X = 5, Z = 5
and
X = -1, Z = -2

Return to Select Mode and turn off Grid.

In preparation for our next action, note the Grid scale shown on the status line: 1.0. 
This means the smallest grid squares are 1 unit on each side. The heavy grid lines are 
at 10-unit intervals.

We’re going to stretch the bow out to the right, so there’s more bow overhang, a 
straighter stem, and less freeboard, making the boat look more “racy”. We can do 
most of this by moving ‘P11’. Since we’ll be selecting and moving points for a while 
here, we’ll make it so only points can get through the filters.

6 Click and to turn Point filter on and all other filters off.

7 Click to turn on Point Nametags.

Move point ‘P11’
We’re going to drag ‘P11’. Here’s a tool that can help:

1 Go to the Tools>Options, Dragging tab and under Snaps:

Set X, Y, and Z increments to 0.1. This will make point coordinates snap to the 
nearest tenth (0.1) when you drag a point.

2 Drag ‘P11’ about 1.2 ft forward and .4 ft down to X = -1.2, Z = 3.2 — use the 
Grid and the dynamic coordinate display on the status line for reference. Notice 
that the coordinates snap by 0.1 increments. If you miss your mark, you can drag 
the point again, until the location looks right or until you get the coordinates you 
want. Or you can use the Property Manager and type coordinates into the dialog 
box (Fig. 4).
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 Fig. 4

When you drag points the motion is all in the plane of the screen. In this case since 
we are using the <Y> projection, the dragging affects only the X and Z coordinates.

Now notice a few things about the updated model:

• B-spline Curve ‘MC1’ (the curve that defines the bow) has changed to conform to 
the new position of ‘P11’. This is one of the properties of a B-spline Curve: it 
always starts at its first control point. You could move ‘P11’ anywhere you like, 
and ‘MC1’ would always reach the new position.

• C-spline Lofted Surface ‘hull’ has changed to conform to the new shape of ‘MC1’. 
This is one of the properties of a C-spline Lofted Surface: its v=0 edge is always 
along its first master curve. You could change ‘MC1’ to any shape at all, and the 
surface would still be attached to it.

• B-spline Curve ‘MC1’ has developed an inflected shape that is a little like a 
clipper bow, not quite the straight stem intended. This is because so far we have 
only moved ‘P11’; we now have to work on ‘P12’.

Move point ‘P12’

1 Click or Tools>Options, Dragging, Snap, Clear All to turn all snaps off.

2 Click or <F7> (next to on the same toolbar) to turn on 
Orthogonal Dragging. Orthogonal Dragging constrains movement to either vertical 
or horizontal, in relationship to the plane of the screen. In Orthographic view, this 
means MultiSurf 

will only let one coordinate of the point change.

3 Drag ‘P12’ forward a little bit, to where it is (as near as you can make it) on a 
line between ‘P11’ and ‘P13’.

‘MC1’ should now be nearly straight (Fig. 5). If not, you can adjust it again. We are 
utilizing a property of a type-2 B-spline Curve: if 3 consecutive control points are on 
a line, then a well-defined portion of the curve will be perfectly straight.
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 Fig. 5

However, adjustment by eye is never going to get this curve perfectly straight. What 
can we do to make it right? We’ll take advantage of MultiSurf 

’ power to capture relationships between entities:

4 again to turn off Orthogonal Dragging.

Make a durably straight stem
To make a durably straight stem, we’ll use the B-spline property that if 3 consecutive 
control points lie on a line, a portion of the B-spline curve will be straight. Here are 
the basic steps we’ll follow:

1 create a straight line guide between ‘P11’ and ‘P13’
2 put a bead on the Line
3 substitute that bead for ‘P12’ as the second control point for ‘MC1’

Ready?

Create the new entities

Create a Line from ‘P11’ to ‘P13’(just for practice, we’ll do it without preselecting 
supports):

1 >Line or Insert>Curve>Line

Name  = ‘guide’
Endpoints = ‘P11’ and 'P13'
<OK> (Fig. 6)

The model updates and your new line appears.

 Fig. 6

Create a bead on Line ‘guide’.
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2 With the line ‘guide’ still in the Selection Set, or <Q> or Insert>Quick Point 

Mode to turn on Quick Point Mode.  The cursor changes to .  Since we have 
a curve selected, a Quick Bead will be made.

3 Place the cursor close to point ‘P12’ and click to create the bead.

The model  (Fig. 7) with the green bead sitting on top of ‘P12’ (or nearly so).

 Fig. 7

Adopt Children

1 Click in white space to clear the Selection Set.

2 Now place the cursor in white space near 'P12' and 'bead1'.  Click and hold the 
left mouse button while dragging a box around the two points.  When you 
release the mouse button, you will have placed both points into the Selection 
Set.3 Tools>Adopt Children or <Shift+A>.  Make sure 'P12' is listed first.  If it 
is not, press the <Reverse Order> button.  Then check the "Delete old parent 
P12" box and press <OK>.

Now ‘MC1’ is truly and durably straight from the tip of the stem to half way between 
‘bead1’ and ‘P13’ (Fig. 8). [This should match our distribution model 
DEMOTR3A.MS2] 

 Fig. 8

Curvature profile

MultiSurf has a graphical aid that will show you the straightness as well:

1 Click to turn on Curves filter.

2 Select ‘MC1’ then click or choose View>Display>Curvature Profile. Arc 
length (measured from the t = 0 end of the curve) is the horizontal axis and 
curvature is vertical. The t = 0 end of the graph is marked by the white circle (Fig. 
9).
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 Fig. 9

Now, to read the graph you need to know that a high curvature value in the 
Curvature Profile indicates a tight curve; a zero curvature value shows the curve is 
straight. As you can see, the curvature of ‘MC1’ is now absolutely zero - the curve is 
absolutely straight - for nearly the first three-quarters of its length, from t = 0 to just 
before t = 0.5 (which is hidden in the first downward jog).

Note that the curvature displayed is that of the current projection of the curve.

3 Switch to the or <Z> view and see how the Curvature Profile changes (all 
zero, since ‘MC1’  lies in the centerplane).

4 <Close> the curvature profile display.

5 Return to the or <Y> profile view.

Hide Line ‘guide’

Hide ‘guide’ for the time being:

1 Select ‘guide’ and click .

The model updates, and ‘guide’ is invisible (Fig. 10). But it is still there, as a guide 
line for ‘bead1’.

 Fig. 10

File>Save As, DEMO1 (<Yes> to replace an existing file, if there is one). [This should 
match our distribution model DEMOTR3B.MS2]

Now let’s experiment a bit (more messing around!)

2 Drag ‘bead1’ (green) around a bit.  You’ll find you can only move it along the 
invisible line ‘guide’.

3 any changes you just made.

4 Drag either ‘P11’ or ‘P13’.  You’ll find that ‘bead1’ stays on the line between 
them.
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5 any changes you just made.

6 or <F> to see the full profile view. 

Bow editing discussion

By making ‘bead1’ a bead on the line (‘guide’) between ‘P11’ and ‘P13’, we 
constrained ‘bead1’ to always lie on the line between ‘P11’ and ‘P13’ — we can make 
many alterations in the position of ‘P11’, ‘bead1’, and ‘P13’, and still get a perfectly 
straight stem. Also, since ‘MC1’ is defined by just three free control points - ‘P11’, 
‘P13’ and ‘P14’ -, it will always lie in a plane, and as long as we keep Y =  0 for each of 
the points, the curve will lie in the centerplane.

Reshape the stern
A racy bow cries out for a racy stern. DEMO-TR3’s cylindrical transom has a 
moderate aft rake typical of a small cruising vessel. However, a reverse transom 
might look more racy, and some added waterline length would confer a 
hydrodynamic advantage. Let’s do both.

Move ‘P34’

First let's add some length by moving a single point to X = 32.  We’ll zoom in to find 
the point, then zoom out so we can see how the entire model updates when we move 
the point:

1 Make sure you are still in or <Y> view.

2 Select point ‘P34' from the Entity Manager and click or
View>Modify>Zoom to Selection.

3 Click and zoom with the mouse to make the whole stern visible.

4 (Tools>Options, Dragging, Snap, Set All) to turn on all snaps.

5 (Orthogonal Dragging).  We’re going to move ‘P34’ straight aft.

6 Return to Select Mode and drag ‘P34’ aft to X = 32 (Z stays at 0.4).

Notice that the transom stays accurately joined to the hull, and that it retains its 
curvature and rake.

Introducing the transom

When we constructed the cylindrical transom for DEMO-TR3, we kept in mind that 
we might want to modify it at a later date. We built in specific relationships that 
make it easy to change the rake, the radius, and the width of the cylinder while 
maintaining the watertight join to the hull. We’ll discuss the rake issue here.

To allow easy modification of the transom rake we used a Frame to “hold” it.  The 
Frame has an x, y, z coordinate system of its own.
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1 Right arrow 3 times and down arrow 3 times to latitude 30 longitude 120.

2 to turn off Point Nametags for a moment.

The Frame shows as 3 short grey axes: the Frame’s x-axis is solid (the transom 
centerline runs along it), the Frame’s y-axis has 2 dashes (“pointing” outward in 
relationship to the hull), and its z-axis has 3 dashes.

3 again.

4 Return to (<Y>) view.

At the top of the transom, on the centerline, there is a cluster of points which includes 
‘p0’, the point that controls the tilt of the frame and thus the rake of the transom.

5 Select ‘p0’ (click at the top center of the transom, then answer the "Which 
Entity?" dialog).

6 Edit its location.

7 Change Lat to 90 (from 80); <OK>. Notice that the whole cylindrical transom 
has tilted, yet it remains accurately attached to the hull. (This is the position in 
which we originally designed the frame and transom.) 

Make the reversed transom

1 Eit the location of 'p0' again.

2 This time, change Lat to 120 (Fig. 11). [This should match our distribution 
model DEMOTR3C.MS2] There is our reversed transom, still accurately attached 
to the hull and still cylindrical ...  but  ...

 Fig. 11.

3 and (turn off Point Nametags) to see the entire profile. Our boat is now 
rather skinny at the stern and the upper transom edge is too curved (but not for 
long!).

Let's assess the situation:

4 Go to the or <X> view and .
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The top of the transom (yellow) is definitely too curved. Let’s look a bit closer at how 
the transom is made:

5 Click to clear the Selection Set and to turn Point Nametags back on..

6 Select magnet ‘m1’ (it’s piled with ‘p0’ at the top of the transom, on the 
centerline; you’ll need to answer the Which Entity dialog).

7 Click (Show-Hide>Show Parents).  This displays the cylindrical basis 
surface (dark cyan) on which we have outlined the transom shape. (The cylinder 
sits in the frame, and the transom itself is a SubSurface on the cylinder.) To see 
better, let’s get the hull lines out of the way for a moment.

8 Click and to turn on the Surfaces and Contours filters.

9 Click ‘hull’ to select it — if you just click on one of the green u-constant lines, 
you can avoid having to answer the Which Entity? dialog.

10 <Ctrl+click> one of the red ‘stations’ lines to add the station contours to the 
Selection Set.

11 to hide them (Fig. 12).

12 Clear the Selection Set

The transom edges are formed by two 
snakes (yellow and magenta) whose 
control points are the magnets ‘m1’ -
‘m6’. The magenta snake also plays the 
role of the third master curve for ‘hull’.

It looks as though ‘m3’ is simply too low. 
Solution: move it up. We’ll need the hull 
surface and contours for reference, so 
let’s show them again.

Here is an easy way to show hidden 
entities that are no longer in the Selection 
Set.

Fig. 
12

13 In the Entity Manager, click next to  'Surfaces' to expand that category.

14 Click on 'hull' or the icon next to it.  This places 'hull' into the Selection Set.

15 Exand the 'Contours' category and <Ctrl+click> 'stations'.

16 With ‘hull’ and ‘stations’ now in the Selection Set we can show them again with 

.

Refinements
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1 With Orthogonal Dragging still on, drag ‘m3’ up to about du = 0 (or u = 1) —
watch the dynamic values on the status line; dv (and v) stays at 0.92 although 
you may not be able to see this if the report runs off the status line (du may also 
run off the line if your screen resolution is low enough).

The curve of the transom top and the height at the transom-side junction look fine, 
but compare the curve of the transom edge (magenta) with the curve of the aft 
stations (red) — the stations bow too much. It looks as though ‘m4’ and ‘m6’ need to 
go inboard.

2 Click ‘m6’.

3 Try changing dv to 0.5 (do not disturb du = 0).  <OK>.

4 Drag ‘m4’ to about du = -0.53.  Watch the status line value). Note: When Ortho 
dragging is on, dragging movement is constrained to one direction (up-down or 
right-left) in the plane of the screen. In our current  situation, the transom basis 
surface (on which magnet ‘m4’ is constrained to lie) is tilting towards us, so 
although we have moved ‘m4’ “straight left” in the plane of the screen, watching 
the du value, the dv value may also change a little bit (which is okay here).

6 Select the dark cyan surface s0.

7 to add its parents to the Selection Set.

8 to hide the Selection Set.

9 <F5> to turn on Symmetry Images.

10 <G>, <F> and to turn off the Grid, Zoom to Fit and turn off Point Nametags 
again.

Looks good. Let’s check the other standard views to be sure:

11 Go to the (<Y>) view; <F> to see the whole boat. OK here.

12 Look at the (<Z>) view. OK here too.

13 Rotate the model and admire your work.  Good enough. Let’s keep it.

14 File>Save As, DEMO2 (<Yes> to replace an existing file). [This should match 
our distribution model DEMOTR3D.MS2]

Stern editing discussion

A little planning ahead can make a big difference in MultiSurf . Anticipating that we 
might want to change the rake of the DEMO-TR3 transom, we constructed the 
transom in a frame. The frame was oriented so that by moving a single point, we 
could modify the transom rake. Actually, this is only one of several relationships we 
built into the transom. Another that we briefly mentioned is that the snake that forms 
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the transom edge also is the third master curve for the hull, making a durably 
watertight seam.

For alternative durable transom constructions, see Tutorial 6 topics “Mixing 
Developable and Compound-Curved Surfaces - Side trip: a planar transom” and 
“Cylindrical Transom.”

Realign stations
Naval architects commonly align their transverse sections with the endings of the 
waterline. The most common practice is to have uniformly spaced stations which 
divide the waterline length into 10 parts. DEMO-TR3 has this alignment quite 
accurately, but the changes made in both bow and stern in getting to DEMO2 have 
disturbed the alignment somewhat. Let’s restore it. Since we’re going to refer to some 
specific numbers and since your DEMO2 won’t be the same as ours or as your 
neighbor’s, let’s use the same version of the model:

1 File>Close, DEMO2.

2 File>Open, DEMOTR3D from the \MARINE TUTORIALS directory.

First let’s concentrate on the bow:

3 or <Y> to get the full profile view.

4 <G> to turn on the grid.

5 and drag a box around the bow to zoom it in.

6 Select ‘MC1’

7 (Zoom to Selection).

This hull was built with its waterline on the x-axis.  We put a purple contour on the 
waterline called, oddly, 'waterline'.  We want to find the x-value where it meets the
bow.  At this magnification the Grid should have minor divisions of 1.0 units.  You 
can tell this by looking at the status bar (which should read Grid: 1.).  Since units for 
the DEMO hull are in feet, you can see that the forward waterline ending is 
somewhere between 1 and 2 feet.

8 Click and click the center of the cross on the intersection of 'MC1' and 
'waterline'.  This centers the model on that point.  Now when we zoom, the 
intersection will remain pretty close to the center of the zoomed image.

9 Press <PgUp> a number of times or use the wheel to zoom in.  (You can also use 

the button and continue to drag a box around the intersection, but it can get 
a little confusing trying to figure out what grid line you are looking at.  Using the 
<PgUp> key allows you to keep track of that better.



Interacting with Models Realign stations

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  66

As you zoom in, you will notice that the grid will adjust as the magnification 
increases.  After about 9 presses you should be able to see that the intersection is 
between 1.6 and 1.7.

10 Do about 9 more <PgUp>’s. The grid should have subdivided to .01 and you 
should see the waterline crossing is between 1.61 and 1.62 (almost at 1.62).  If the 
intersection is drifting from the center, get in Zoom to Area mode and click on 
the intersection again.

11 Do about 9 (or so) more <PgUp>’s. The grid will subdivide again and show the 
crossing is just about 1.619 — that’s close enough. This will be the value for 
Distance from Mirror/Surface to first contour below.

Now we could go to the aft end of the waterline and do the same thing, but we’ll do 
it another way:

12 to show the original view.

13 Click on the magenta Contours 'waterlines' to select it.

14 File>Export 3D>3DA wireframe.

15 In the options, select Selection Set Only; <OK>.

16 For filename, enter 'temp' (<OK> to replace an existing file, if any).

17 Minimize MultiSurf

window

18 Start Notepad (from Windows Program Manager; it’s in the Accessories 
program group. Notepad is a Windows text editor).

19 File>Open.

20 In the list box of file types, select All Documents (*.*) or All Files (*.*).

21 In the \MultiSurf TUTORIALS directory, choose TEMP.3DA; <OK>.

The contents of a .3DA file is a table of numbers. The 0 and 13’s in the first column 
are pen colors, the zero meaning “move here with pen up”. The remaining 3 columns 
are X, Y, and Z coordinate values for the points along the waterline. The first point 
has X = 1.61920, the number we just found by zooming in on the forward end of the 
waterline.

22 <PgDn> (or scroll) to see the end of the file. The last point on the curve has X = 
29.33683. This is the aft end of the waterline, the point we’re looking for — this is 
the value for X10 below (29.337 will do).

23 Close Notepad.

Now we have the information we want; let’s use it:

24 Maximize MultiSurf
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(click its icon at the bottom of the screen).

25 Click on one of the red stations to edit in the Property Manager.

26 For Signed distance from Mirror/Surface to 0-index contour, enter the value we 
found above = 1.619.

For Contour spacing, enter (X10 - X0) / 10 = (29.337 - 1.619) / 10 = 2.772.

Now your stations should be nicely aligned. [This should match our distribution 
model DEMOTR3E.MS2] 

27 or <Y> to see the profile view again. We’ll zoom in and look more closely at 
the alignment.

28 and drag a window to zoom in on the forward end of the water line (Fig. 
13), where Sta. 0 now intersects it exactly (well, almost exactly — we did round 
off the values to .001; if you zoom in far enough, you’ll be able to see the slight 
discrepancy, but .001 would be plenty accurate for designing and building this 
hull).

 Fig. 13

File>Save As, DEMO2 (not as DEMOTR3D; <Yes> to replace an existing DEMO2).

Add a cove stripe
Just for fun, let’s add a decorative line (cove stripe) on the ‘hull’ surface of DEMO2. A 
snake will be a good tool for that. Snakes are not only useful for creating watertight 
joins between surfaces, but may be used for decorative purposes as well. First we’ll 
need two magnets for control points.

1 Select surface 'hull'.

2 (Zoom to Fit).

3 to turn on Quick Point Mode.

4 Place a Quick Magnet near the bow and another near the stern.
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5 With both of these Magnets in the Selection Set, >Line Snake or 
Insert>Snake>Line Snake.

Name = 'cove stripe'
End magnets = (pre-selected)
<OK>

Edit the endpoints of the new cove stripe.

6 Click 'm7'.

u = .05, v = .05

7 Click 'm8'.

u = .05, v = .95

The model has a nice magenta cove stripe (Fig. 14). You can adjust its position and 
appearance by dragging the magnets. The magnets and the cove stripe will continue 
to lie accurately on the surface even if you change the shape of ‘hull’.

 Fig. 14

8 If you’d like to, File>Save As, DEMO3 (<Yes> to replace an existing file).

We’re finished with this series of edits, so Close this model.

Add a deck surface
In this tutorial we’ve had occasion to create points, beads, magnets, curves, and 
snakes. Let’s go out on a high note by creating another surface for DEMO — the 
deck.

Change hull visibility:

1 File>Open, DEMO.ms2 (from the \MARINE TUTORIALS folder).

2 Double-click ‘hull’ to edit its definition.

3 On the Display tab under Visibility, turn on Boundary and turn off u-constant.  
We’re just getting rid of some lines so we can better see what we are doing (Fig. 
15).

 Fig. 15
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Create 2 deck beam master curves
Create support points for the middle deck beam master curve:

1 Press the Down arrow 5 times to get to Go to Lat 20, Lon 60.

2 (Point Nametags).

3 Preselect ‘P21’ (the sheerline point of ‘MC2’)

4 >Point or Insert>Point>Point

Name = ‘p0’
dz = 0.5
Point = ‘P21’ (pre-selected)
Display>Color = red
<OK> (Fig.16)

'p0'

  Fig. 16

Notice that the Point entity has two parents, Point and Frame.  The location of each 
Point, its Offsets, is in relation to each of these parents.  If no parents are chosen, the 
defaults are the origin of the global coordinate system.  See "Point" in "Entity 
Descriptions" in the "MultiSurf 

User's Guide" for more information.

5 Preselect ‘P31’ (the top sheerline point in the stern)

6 >Point (or press <F4> for Insert>Copy Last)

Name = ‘p1’ (default)
dz = 0.35
Point = ‘P31’ (pre-selected)
Display>Color = red
<OK> (Fig. 17)

'p1'

 Fig. 17

Create a Quick C-spline curve to establish the crown of the deck.

7 Clear Selection Set

8 In Tools>Options>Entity>Quick Spline Defaults ( or just type the letter 'o') set 
values to C-spline, Degree = 3 and keep Alternate spline creation checked.
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9 or <S> to turn on Quick Spline Mode.

10 Place cursor at the tip of the bow.  When the cursor changes to you are over 
the point there.  Click, release and move the cursor aft until you are over the 
point ‘p0’.

11 When the cursor changes shape again to indicate you are over the point, click, 
release and move aft again.

12 This time double click on the last point 'p1' to end the spline.

13 Edit the curve to rename it ‘crown’   Hint: Renaming can also be acomplished by 
using the slow double click method in the Entity Manager. This method of re-
naming is a Windows standard operation.  (Fig. 18)

'crown'

 Fig. 18

14 Reset the Quick Spline mode default back to B-spline.

Create the deck surface
In order to create the deck as an Arc Lofted Surface we first need to create a curve on 
'hull' that the deck can use.

1 Turn off Point Nametags and select the ‘hull’ surface.

2 >Edge Snake or Insert>Snake>Edge Snake.

Name = ‘hulldeck’
Surface edge = u=0
Surface = 'hull' (pre-selected)
<OK>

Next we need a curve to terminate the deck surface at the centerline.  To do this we'll 
project 'crown' onto the *Y=0 plane.

3 Select the C-spline Curve ‘crown’

4 >Projected Curve or Insert>Curve>Projected Curve.

Name = ‘centerline’
Curve = 'crown' (pre-selected)
Mirror = *Y=0  (select from the Entity Manager)
<OK>

5 Pre-select ‘hulldeck’, ‘crown’ and ‘centerline’, in that order, as master curves.

6 >Arc Lofted Surface or Insert>Surface>Arc Lofted Surface
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Name = ‘deck’
Type = Arc: tangent at curve 3 end.
Control curves = 'hulldeck’, ‘crown’ and ‘centerline’ (pre-selected)
<OK>
[This should match our distribution model DEMODK2.MS2.]

MultiSurf lofts the surface as an arc in the lofting direction.

7 Turn on the Symmetry Images (<F5>) and rotate the model so you can see how 
the deck joins its image smoothly across the centerplane (Fig. 19).

 Fig. 19

8 Turn off Symmetry Images.

Because we used Type = Arc: tangent at curve 3 end, the surface:

• does not pass through its control curves the way the surface 'hull' does

• is arc sections in the lofting direction

• ends normal to the centerline or phrased another way,  is tangent to a ruled 
surface between curves 2 and 3 at curve 3

Since the the outboard edge of ‘deck’ is made using the edge of the ‘hull’ surface, this 
is a watertight join, and will remain so even if changes are made in ‘hull’ and/or 
‘deck’. For example:

9 Look at the or <Shift+X> view — the bow is now pointing toward you.

10 (Zoom to Fit).

11 Click to select 'hull’.

12 Change visibility back to just u-constant (turn off Boundary lines; Fig. 21, left).

13 <G> to turn on Grid.

14 Use Pan to move the model to the right so you have some editing room to the 
left (outboard) of ‘P21’.

15 (Orthogonal Dragging on).

16 Drag 'P21' outboard a foot or so(Fig. 20, right). [This should match our 
distribution model DEMODK3.MS2.]
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Fig. 20

Now let’s see how the deck and hull have changed, but have also remained 
accurately joined:

17 Turn on Symmetry Images again and rotate around the model.  You'll probably 
need to zoom out in order to see the whole boat.

That’s all for this tutorial.

File>Exit; do not save changes.

Tutorial wrap-up
In this lesson you have utilized most of the ways that MultiSurf provides for 
interacting with models. You have created quite a number of entities, deleted a few, 
and edited several aspects of many other entities: their names, colors, visibility and 
parent entities. You have taken the simple hull DEMO, and its descendant DEMO-
TR3, through a series of transformations including: 

• scaling to new overall dimensions
• modification of bow and stern profiles
• modification of a set of stations
• addition of a deck surface

You have met several new entities and seen how they can be applied —
sometimes as a temporary construction guide, sometimes as a permanent 
part of the model — to capture and enforce relationships between model 
elements. We have emphasized the potential for building in qualitative 
relationships or properties that are durable — automatically preserved 
following changes in the underlying entities:

• a stem that is durably straight
• a transom that is durably attached to the hull (and is durably cylindrical)
• a cove stripe that durably lies on the surface
• a deck that is durably smooth at the centerline, and which durably joins the hull 

at its edge
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Introducing More MultiSurf Entities

Overview
In the first three lessons, you’ve been introduced to MultiSurf ' point entity, and a 
few simple curves and surfaces. One of the big advantages of MultiSurf is its 
support of a variety of curve and surface types, which have uses in a wide range of 
different design situations. Our purpose in this lesson is briefly to introduce some of 
the other entities, so you’ll have a better sense of what MultiSurf has to offer. Some 
of the model files used in this tutorial are found in the \ Examples folder.  These files 
are also used in the Entity Descriptions chapter of the main manual.

Entity introductions:

• Arc explained
• B-spline Curve explained
• B-spline Lofted Surface explained
• B-spline Snake explained
• C-spline Curves explained
• C-spline Lofted Surface explained
• PolyCurve
• SubCurve

Concept and Function introductions:

• cursor shape
• <Ctrl+A> shortcut key
• Degree 1 C-spline does not meet points in graphic view
• Drag magnet
• How to make Degree 1 B-spline meet points
• Polyline display
• Quick Spline Mode to make Quick Snake
• Reverse t distribution with SubCurve
• Select>All
• Show-Hide>Hide Points, >Show Points
• SubCurve, change curve parameterization
• Surfaces should be made between curves of similar t distributions
• Tickmarks concentrated in areas of high curvature for B-splines and C-splines
• Tickmarks evenly spaced for Arcs, Lines and PolyCurves
• View>Entity Orientation
• View>Nametags, Curve

In this lesson, we’ll be opening a series of simple models and discussing and editing 
them. Each time we close a model in preparation for opening a new one, MultiSurf  
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will ask if you want to save the changes we’ve made. Respond <No>, i.e. do NOT
save. That way the sample models will be intact if you or someone else wants to 
repeat part of the lesson or if you want to look at the model files used for the 
examples in the “Entity Descriptions” section of the manual. “MultiSurf Tutorials: 
Introduction” contains information about taking a break, typeface and symbol 
conventions, and trouble shooting. So ...

Start MultiSurf  and File>Open, switch the folder to \Examples, then open 
ARC1.ms2

Check program settings
Let’s check those program settings and make sure we’re all starting with the same 
ones (the initial program defaults). This is what you should have:

On the View menu:

Axes and Status Bar should be ON (preceded by a checkmark; to turn an option 
on, simply click on the menu item or if it has a box next to it click on the box).

All Toolbars except Marine View Orientation should be ON.  To check this, 
click on Toolbars.  A toolbar is on when checked.

On the Tools>Options, General, tab:

Rotation Constraint should be set to Free tumble

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

Arcs
There are six types of arc, each supported by three points. Arcs are true circular arcs. 
They are useful whenever you need a partial or complete circle as part of your 
design.  As you go through this section you might find it helpful to turn on Point 

nametags ( or View>Nametags, Point).

Arc through 3 points
ARC1.ms2 is a Type "Arc through 3 points", which passes through its three points in 
sequence (Fig. 1). 

Y
'middle'

'bottom'
at t = 1

'top'
at t = 0

Z

Arc through 3 points
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Fig. 1.  Arc1.ms2.

1 Drag the points around, to see how the curve responds.

2 File>Close ARC1.ms2 (don’t save changes!)

Arc: start-center-plane guide
1 File>Open ARC2.ms2 (Fig. 2).

This is a Type "Arc: start-center-end guide", which starts at the first Control point 
(‘start’), has its center at the second Control point (‘center’), and ends on the line from 
the center to the third Control point (‘end_guide’).

X

'end-guide'

'center'

'start'
t = 1

at t = 0

Z

Arc: start-center-end guide

Fig. 2  Arc2.ms2.

2 Click or View>Nametags, Point.

3 Try moving ‘end_guide’ and see how the curve responds. Notice you can’t 
make an arc of more than 180 degrees this way.

4 File>Close ARC2.ms2.

Circle: start-center-plane guide
1 File>Open ARC3.ms2.

This is a Type "Circle: start-center-plane guide" (Fig. 3), which is a complete circle. It 
starts and ends at the first Control point (‘start’), and has its center at the second 
Control point (‘center’). In this type of arc, the roles of the third Control point
(‘plane_guide’) are to specify the plane the circle lies in and to designate which way 
the circle is traversed as t runs from 0 to 1. Let’s explore this t-direction aspect a bit:

2 Click or View>Nametags, Point.

3 Select the arc ‘full_circle’.
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X

'center'

'start'

'plane-guide'and t=1
t=0

Z Circle: start-center-plane guide

Fig.3  Arc3.ms2

You can see that ‘start’ is indeed at t = 0 and that the parameter t is running around 
the circle clockwise (in the direction the arrowhead is pointing). Notice also that from 
its starting point, the circle heads out in the direction that is “toward” ‘plane_guide’.

4 Turn on View>Entity Orientation.  This will make the orientation marks stay on 
the circle even when it is not in the Selection Set.

5 Drag ‘plane_guide’ approximately straight down.

When 'plane_guide' goes below the imaginary line that connects 'start' with 'center', 
the arrowhead switches direction.  The t parameter of the circle is now running in the 
opposite direction, that is, counter clockwise around the circle. Again, the circle 
begins by heading “toward” ‘plane_guide’.

6 Move ‘plane_guide’ to various other positions and see how the t-direction is 
affected.

From its starting point, this type of arc always heads “toward” its third Control point. 
More specifically, the closest point on the circle to the third Control point has a t-value 
less than t = .5.

7 Close ARC3.ms2.

Arc: tangent at one end
1 Open ARCS4-5.ms2.

These two arcs (Fig. 4), built from the same 3 points, have durable tangencies built 
into them. They are displayed with their polylines (which are identical).  A curve's 
polyline connects all of its parent points with straight line segments.
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X

Y

'p2'

'p1'
at t = 0

'p3'
at t = 1Z

Arc: tangent at point3 end

Arc: tangent at point1 end

polyline

Fig. 4  Arcs4-5.ms2

2 In Tools>Options, General, Auto Orientation, click the "All selected 
entities" radio button.

3 Click (Select>All or <Ctrl+A>) to select both curves (and the Points) and 
turn on Point nametags.  Both curves have the same orientation — t=0 is at ‘p1’.

4 (View>Nametags, Curve) to view curve nametags.

‘arc4’, the Type "Arc: tangent at point1 end" arc, is tangent to its polyline at t = 0 
(‘p1’); ‘arc5’, the Type "Arc: tangent at point3 end" arc, is tangent to its polyline at t = 
1 (‘p3’).

5 Select ‘p3’ and move it around. Notice that the arc curves maintain the 
respective tangencies no matter where you move ‘p3’.

6 Reset Auto Orientation to Single selected entity.

7 Close ARC4-5.ms2.

Semi-circle: start-center-plane guide
1 Open ARC6.ms2.

This Type "Semi-circle: start-center-plane guide" arc (Fig. 5) is a semi-circle made 
from the same set of points as in ARC3.ms2. This type of arc starts at the first Control 
point (‘start’), uses the second Control point (‘center’) as its center, and lies in the 
plane of the 3 points.  The third Control point (‘plane_guide’) is used to determine 
which of the two possible semi-circles you get (always the one that passes closest to 
the third Control point.
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t=1

'center'

'plane-guide'

X

'start'
at t=0

Z

Semi-circle: start-center-plane guide

Fig. 5  Arc6.ms2

2 Drag ‘plane_guide’ to other locations and watch the behavior of the arc 'semi-
circle'.

3 Close the model (remember: don’t save changes).

SubCurves
Sometimes you need to use just part of a curve in constructing another object. This is 
done with a SubCurve, delineated by two beads.

1 Open SUBCURVE1.ms2 (Fig. 6).

The basis curve (cyan) is a Type "Arc through 3 
points" arc. ‘bead1’ and ‘bead2’ are two green 
beads. The SubCurve ‘sidepanel’ is red.

2 Select the cyan Arc ‘midsection’.  The circle 
marks the t = 0 end of the arc.

3 Select the red SubCurve ‘sidepanel’.  This 
circle denotes the t = 0 end of the SubCurve 
(t = 1 is the other end, of course).  The black 'V' 
indicates the direction of increasing t.

4 or View>Entity Orientation to keep the 
orientation marks visible on 'sidepanel'.

t = 1

t =

t =

t = 0

SubCurve

Z parent curvparent

parent

subcurv

subcurv

Fig. 6

5 (Point nametags)

6 Drag the beads around and note that the t = 0 end stays at ‘bead1’. If you slide 
‘bead2’ past ‘bead1’, or vice versa, the SubCurve’s parameter will run the 
opposite way from that of the basis curve.  This is indicated by the change in 
direction of the black 'V'.

7 You can also drag the beads beyond the ends of the basis curve — try it. 
They will stay on the fair extension of ‘midsection’, i.e., the continuation of the 
circle. (Note: when dragging beads or rings, once you get very far beyond t = 0 or 
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t = 1, dragging may become unpredictable, but you can still move the bead or 
ring accurately by typing in t-values.)

8 Close the model (don’t save changes).

PolyCurve and Quick Spline
SubCurves have another important function. They can be used to change the 
parameterization of a curve. For an example of this functionality,

1 Open POLYCURVE1.ms2 from the \Marine Tutorials folder.  (The rest of the 
model files in this tutorial are also found in the \Marine Tutorials folder.)

X

Z

'pt6'
'pt4'

'pt2'

'xarc2'

'xarc1'

 Fig. 7

In this model we have 2 arcs we will convert into a single curve using a PolyCurve.   
A PolyCurve is a single curve made by joining two or more parent curves end-to-
end.  Following is a way to select multiple entities by dragging a box around them.

2 Place the cursor in white space near 'pt4'.  Click and hold the left mouse button
while dragging a box around 'pt4'.  When you release the mouse button, you will 
have placed 'pt4' into the Selection Set, along with the two arcs, because all three 
entities ended up within the box.

3 Click on 'pt4' in the Selection Set pane and then click to remove it from the 
Selection Set.

4 >PolyCurve or Insert>Curve>PolyCurve.  Click OK to accept defaults.

5 Hide 'xarc1' and 'xarc2'

6 Select point ‘pt2’

7 >Point or Insert>Point>Point.

Name = 'pt7' (default)
dz = 5
Point = 'pt2' (pre-selected)
OK

Notice that the Point entity has two parents, Point and Frame.  The location of each 
Point, its Offsets, is in relation to each of these parents.  If no parents are chosen, the 
defaults are the origin of the global coordinate system.  See "Point" in "Entity 
Descriptions" in the "MultiSurf User's Guide" for more information.

8 On the Tools>Options, Entity tab, Quick Spline Defaults, Click the B-Spline 
radio button and make sure the Alternate spline creation is checked.
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9 With 'pt7' still in the Selection Set (this sets the "depth" for the Quick Points), 

Turn on Quick Spline Mode ( or <S> or Insert>Quick Spline Mode).

10 Hold the cursor over ‘pt7’ and click.

Because 'pt7' and 'pt2' are on top of each other in this view, MultiSurf cannot tell 
which point you want to select for the first point of your spline.  The cursor changes 

to to indicate this.  When you click, you get the Which Entity? box.  This box 
comes up any time MultiSurf cannot tell which entity you are interested in selecting 
and provides a list of entities at that location for you to choose from.  In this case, 
select 'pt7'.

11 Continue clicking and creating a Quick Spline. Try to match the PolyCurve with 
your B-Spline. Use as few points as possible. Be sure not to place a point if the 

cursor changes to .  (Doing so would put one of the spline points on the 
PolyCurve).  Finish by double clicking near the end of the PolyCurve.  If 
necessary drag the points around to closely approximate the PolyCurve. It 
doesn’t have to be perfect. How many points did you use? You probably don’t 
need more than 7 or 8.  (Fig. 8)

X

Z

'pt7' B-spline
'pt2' PolyCurve

'pt14' B-spline
'pt6' PolyCurve 'pt4' on PolyCurve

PolyCurve and B-spline

 Fig. 8

12 Return to Select Mode.

13 Rotate (center mouse button or wheel if you have one) and see what you have 
created. You should have a spline in the plane determined by the location of the 
point selected when you started the Quick Spline. You have not created a 
relationship. You just used ‘pt7 to set the depth of the plane in which our spline 
will lie. You have also used ‘pt7' as the starting point of the spline, although this 
is not required. If your curve didn’t come out as advertised, click Undo and try 
again. Using Quick Spline can take some practice to get right.

A Ruled Surface
1 To make sure we are all working from the same model, Close POLYCURVE1

and open POLYCURVE2.ms2

2 Go to (Top view).

3 or Show-Hide>Hide Points.

4 Put the just created B-spline and the PolyCurve into the Selection Set.
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5 Multiple Edit in the Property Manager

6 Turn on tickmarks.  OK.  Tickmarks are placed at t=0, .1, .2 etc. along the curve.  
(These may be easier to see if you clear the Selection Set to remove the bold 
representation of the curves).

t=.9 t=.1t=.5

PolyCurve

B-spline  Fig.9

Notice that the PolyCurve's tickmarks are evenly spaced along the curve.  This is also 
true for Arcs and Lines.  The B-spline's tickmarks are concentrated in its area of high 
curvature (the right side in this view).  This is true of all B- and C-spline curves.  If 
we were to make a surface between these two curves, we would see that the u-
constant lines would mostly be skewed.  That is because the u-constant lines run 
along equal values of t between the two curves, and these values do not line up 
properly.  This causes the resultant surface to have curvature where you don't want 
it.  Fortunately we have a fix for this.

7 Turn off tickmarks on both curves

8 Select the PolyCurve and the B-Spline (if they are not still selected from the 
previous step) in either order.

9 >Ruled Surface or Insert>Surface>Ruled Surface.  OK to accept defaults.

[This should approximately match our distribution model POLYCURVE3.ms2]  A 
ruled surface is made with only the u-constant rulings showing. As we hinted above, 
they are not, for the most part, vertical in this model.  If you press the right arrow key 
a number of times and watch along the right edge of the surface, you will begin to 
see curvature in the surface where it should be straight.  To get to 15 degrees 
longitude, go to 20 and then Shift + right arrow 5 times to get to 15.  (Fig. 10)
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PolyCurve

B-spline Lat 15

Ruled Surface

Lat 90  Fig. 10

SubCurve fix

1 Select the B-spline curve, go to view and or <Q> to turn on Quick 
Point Mode.

2 Hold the cursor off one end of the spline, click and release.

3 Create 6 more beads along the length of the curve, the last one should be at 
the opposite end of the B-spline. Notice all the beads are being added to the 
Selection Set.

4 Return to Select Mode and with the beads still in the Selection Set:

5 >SubCurve or Insert>Curve>SubCurve.  OK to accept all defaults.

Now we swap the SubCurve for the B-spline Curve as a parent of the Ruled Surface.

6 With the SubCurve still in the Selection Set Ctrl-select the B-Spline Curve.

7 Tools>Adopt Children or <Shift+A>. If we look at the dialog closely we see the 
selections are in the wrong order. Click the ‘Reverse Order’ button.  Ok.  This 
replaces the SubCurve as the parent for the B-spline Curves children [This 
should match our distribution model POLYCURVEEND.ms2]

8 Go back to (Top view)

9 The surface has already changed. To improve from this point, move the 
interior control beads to change the surface rulings to a more vertical orientation 
(Fig. 11). You can use any number of interior control beads to get the desired 
results. With Quick points it is easy to create these points so you can err on the 
side of too many and you will be sure you will have control you are looking for.



Introducing More MultiSurf Entities C-spline Curves

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  85

PolyCurveSubCurve

Lat 15

Ruled Surface

Lat 90 Beads
 Fig. 11

10 Close Polycurve2.  Do not save.

C-spline Curves
A C-spline Curve is a free-form curve that passes through a series of control points 
— as an Arc Type "Arc through 3 points" does — but a C-spline Curve can have any 
number of control points. C-splines (as curves, snakes, and lofted surfaces) can be of 
three types: Degree 1 = linear, Degree 2 = quadratic or Degree 3 = cubic.

1 Open CSPL1-3.MS2. This shows C-spline Curves of all three types, based on the 
same set of points.

Look at the Left and then the Front views; these show an important property of 
C-spline Curves: if the control points all lie in a plane, so does the curve.

2 Return to the view

The Degree 1 C-spline Curve (cyan) is just a Polyline connecting the points. Note: the 
Degree 1 curve itself is made of an infinite number of points and does indeed pass 
through all its control points. The screen display, though, is made with only 32 
divisions (the same as for the other 2 curves in the model) and it doesn’t hit the 
points. Try this:

3 Click to select the cyan C-spline Curve ‘type1’ to edit in the Property 
Manager.

4 Change divisions to 64x1. The 
display is better, and with 255x1 
divisions it’s even better (Fig. 12), but 
still not exact (zoom in on a corner 

and you will see; then or to 
return to this view). There’s no magic 
way to make divisions on a Degree 1 
C-spline Curve break precisely at the 
control points. Fig.12

The Degree 2 C-spline Curve (red) is a smoother curve, made up of parabolic arcs. 
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The Degree 3 C-spline Curve (magenta) is still smoother, but “stiffer” or “springier”, 
so it bounces more in passing through the points.

Instead of descriptions, we have a tool for analyzing curvature called Curvature 
Profile.  By selecting a curve and showing its Curvature Profile, you can see details 
about its curvature that you cannot discern by looking at the curve alone.

5 With ‘type1’ still selected, choose or View>Display>Curvature Profile. 
This shows that the curvature is all concentrated in spikes at the sharp bends 
which occur at the data points.

6 Select the red C-spline Curve ‘type2’.

7 again. Here you can see the discontinuities in curvature that occur at the 
“knots” where the three parabolic arcs join.

8 Select the magenta C-spline Curve ‘type3’.

9 one more time. Here you see the curvature distribution is smoother, in fact 
it varies continuously along the curve. This degree of smoothness is characteristic 
of Degree 3 spline curves.

10 Move the control points around and see how the curves respond. Be wild —
make the curves cross themselves even.

11 Close the model (DON'T save changes!).

B-spline Curves
If you have been following the tutorials in sequence, you will have run across a B-
spline Curve and a B-spline Snake while using Quick Spline Mode.  We have not yet 
talked about them, but we do here.  A B-spline Curve is a free-form curve that is 
shaped by a series of control points. It starts and ends at the first and last control 
points, but unlike a C-spline Curve, in general it does not pass through the other 
(“interior”) control points; instead it “imitates” the Polyline joining the control 
points. A B-spline Curve can have any number of control points. B-splines (as curves, 
snakes, and lofted surfaces) can be of any integer type desirable greater than zero: 
Degree 1 = linear, Degree 2 = quadratic, Degree 3 = cubic, etc. although degrees 
higher than 3 are rarely used.

1 Open BSPL1-3.MS2.

This example uses the same control points, and the same three types (Degree's 1 - 3), 
as CSPL1-3 in the C-spline Curve example above.

The Degree 1 B-spline Curve (cyan), like the Degree 1 C-spline Curve, is just a 
Polyline joining its control points in sequence. Note that unlike for a Degree 1 C-
spline Curve, the display for a Degree 1 B-spline Curve readily breaks at its control 
points — all you need to do is make:

(t-divisions × t-subdivisions) = a multiple of (number of control points - 1).
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In this case Divisions are 32x1 and there are 5 control points.  Since 32 is a multiple of 
4 we're ok.

The Degree 2 B-spline Curve (red) is made up of parabolic arcs that join with 
continuous slope. The Degree 3 B-spline Curve (magenta) is made up of parametric 
cubic arcs that join with continuous slope and curvature. The higher the type, the 
smoother the curve, but the less closely it follows the Polyline.

2 Look at the Left and the Front views to confirm an important property of B-
spline Curves: if the control points all lie in a plane, so does the curve.

3 Return to the <Home> view (=

same as the Bottom view; Fig. 13).

4 Set X,Y,Z snap to 1.0 (Tools>Options,  
Dragging, Snap).

5 (View>Nametags, Point) Fig. 13

6 Move ‘p3’ up to (16, 0, 12). This

gets it on the same line as ‘p2’, ‘p4’, and 
‘p5’. Here we see another useful 
property of B-splines: if (Degree + 1) 
control points lie on a line, a portion of 
the curve is absolutely straight (Fig. 14). 

Fig. 14

7 Look at or View>Display>Curvature Profile of ‘type2’ and ‘type3’.  Close 
the curvature display when done.

8 Move ‘p2’ left to (0, 0, 12). Notice

that the tangent to all three types 
becomes vertical at the end control 
point, ‘p1’. A B-spline is always tangent 
to its Polyline at both end points 
(Fig. 15).

Fig. 15

9 Move ‘p5’ down to (27, 0, 4). This

leaves 3 interior control points in a line. 
The Degree 2 B-spline Curve still has a 
straight section — from the midpoint 
between ‘p2’ and ‘p3’ to the midpoint 
between ‘p3’ and ‘p4’. The Degree 3 B-
spline Curve gets quite flat near ‘p3’ 
(curvature is zero at one point), but 
none of it is completely straight, because 
only three of its control points are in a 

Fig. 16
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line (Fig. 16).

10 Look at the curvature profiles of ‘type2’ and ‘type3’ again.

B-spline Curves are especially useful when designing curves that need to have 
straight portions or curves that require precise control over end slopes.

Close the model.

B-Spline Snakes
1 Open BSNAK1-3.MS2.

This model has three B-spline Snakes, of 
Degrees 1 to 3, each using the same six 
control points (magnets), on a translation 
surface (Fig. 17).

You can see how the B-spline Snakes 
share many of the properties of B-spline 
Curves: 

Fig. 17

• they approximate the shape of the Polyline snake joining the control points
• they start and end at the end control points
• the higher the type, the stiffer and smoother the spline

2 Go ahead and drag the magnets around; watch how the snakes respond.

Create your own B-spline Snake with a Quick Spline.

3 Select the surface

4 Turn on Quick Spline Mode.

5 Click to drop points. Notice the points are Magnets and the spline is a Snake. If 
you click the cursor off the edge of the surface, the resultant magnet will snap to 
the closest point on the edge.

6 Double-click to end the Quick Spline. 

7 Close BSNAK1-3.MS2 (don’t save changes).
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C-spline Lofted Surfaces
1 Open CLFT5X4.MS2.

This is a C-spline Lofted Surface 
using 5 B-spline Curve master 
curves. Just as a C-spline Curve 
passes through all its control points, 
so a C-spline Lofted Surface passes 
through all its master curves.

X

Y

Fig. 18

2 (View>Nametags, Curve), to identify the master curves.

3 or Show-Hide>Show Points to see the points that support the B-spline 
Curve master curves (Fig. 18).

4 (Show-Hide>Hide Points) to get them out of the way again.

5 Select the five master curves (this is probably most easily done by dragging a 
box around them and then removing the surface from the resulting Selection 
Set).

6 In the Property Manager change visibility to add tickmarks.

The green lines are the u=constant lines on the surface ‘hull’. Each is formed by first 
taking a point from each of the master curves, where its parameter t is equal to u. 
Then a C-spline is formed using these 5 points as control points. Since the surface 
(‘hull’) has 10 u-divisions and we’ve turned on the tickmarks for the master curves, 
you can see that the u=constant lines (the C-spline Curves) that make up the display 
of the surface pass through the tickmarks (t and u = 0.0, 0.1, 0.2, ... 0.9, 1.0).

7 Look also at the Right view and<F> or Zoom to Fit.  Rotating the model from 
this view, notice that the surface passes through each of its control curves.

Close the model.
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B-spline Lofted Surfaces
The B-spline Lofted Surface shares many similarities with B-spline Curves.

1 Open BLFT5x4.MS2 (Fig. 19).

This hull uses the same five master 
curves as the C-spline Lofted 
Surface in CLFT5x4.

X

Y

Fig. 19

2 and <F> (Right view, Zoom to Fit).  Rotate the model from this view.  
Notice that the surface does not pass through the middle control curves.

The B-spline Lofted Surface starts and ends at its first and last master curves, but 
unlike the C-spline Lofted Surface does not pass through the interior master curves; 
instead, it is “guided” by them or “attracted” to them, in the same way as a B-spline 
Curve is related to its control points.

3 and <F>.

4 or <G> or View>Grid to turn on the grid.

The Grid displays equally spaced lines superimposed on the graphics display.  Every 
tenth line is a bold line   The distance between each Grid line is reported in the Status 
Bar at the bottom of the display as "Grid: x.".  For instance, "Grid: 0.1" means each 
Grid line is 0.1 units apart and every unit is a bold line.  Grids are available only in 
orthographic views that are parallel to one of the axes. (The Front View is parallel to 
both the X and Y axes, so we see both vertical and horizontal grid lines in this case.  If 
this is confusing to you it may be because as you look at the screen, your line of sight 
is perpendicular to the plane of the screen in this case the X - Y plane, but the image, 

the View, is on the X - Y plane and is, therefore, parallel to it). Note that or <G> 
is a toggle; pressing it again would toggle the grid off (leave it on for now).

5 If necessary, Zoom in until the Y = 10 grid line is in the window.

6 , (Show points and turn on point nametags).

7 or <F7> or Tools>Options, Dragging, Dragging, Orthogonal Dragging.  
Orthogonal Dragging constrains points to move only vertically or horizontally 
with respect to the plane of the screen.

8 Drag ‘P31’ out to Y = 10.

9 <G> to turn off grid and to turn off point nametags
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10 Rotate around the model to see how the surface, especially the upper edge, the 
“sheerline”, stretches out toward the edited master curve (yellow), as if attracted 
to it.

11 Close BLFT5X4.

Projected Curves
1 Open PROJCRV1.ms2 (Fig. 20).

This is the DEMO hull model, with a 
little modification: master curve ‘MC1’ 
has been moved a little off center. The 
yellow rectangle is the plane 
‘centerplane’. The magenta curve 
‘profile’ has been made by projecting 
‘MC1’ perpendicularly onto the 
centerplane. The cyan ruled surface 
‘half_siding’ is formed by joining ‘MC1’ 
to ‘profile’.

2 Select 'MC1' X

Y

Z

Fig. 20

3 or <F10> or View>Modify>Zoom to Selection.

4 Zoom out to about radius 20.

5 Now, change ‘MC1’ by dragging one or more of its points.

6 you can see that ‘profile’ (magenta) continues to be the projection of the 
modified ‘MC1’ (cyan).

7 Close the model (don’t save changes).

Tutorial 4 wrap-up
In this tutorial we focused on introducing more of the MultiSurf curve, snake, and 
surface entities. A great deal of the power of MultiSurf comes from the richness of 
entity types available, allowing you to use the entity that best fits each purpose. In 
the next tutorial, we’ll introduce more entities, particularly surface entities, in the 
context of their use in various kinds of marine designs.
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Building Tangency with B-splines

Overview
In this tutorial, we will demonstrate the end tangency principle of B-spline Curves 
and show you how to create durable tangency relationships between two ends of a 
single curve or surface, and between two different curves or surfaces. After finishing 
each section, close the model files without saving the changes.

Entity introductions:

• B-spline Curve
• B-spline Lofted Surface
• Mirrored Curve
• Mirrored Point
• Mirrored Surface
• Projected Point
• Relative Curve

Concept and Function introductions:

• B-spline Curve ending normal to plane plus mirror symmetry makes G2 join.
• B-spline Curve is tangent to the line between its end and next-to-end control 

points
• B-spline Lofted Surface ends normal to plane if 2nd last curve is projected onto 

plane of symmetry
• B-spline Lofted Surface with 2 control curves is ruled surface
• Ctrl+shift+click adds second instance of entity to Selection Set
• G1 continuity
• G2 continuity
• Select B-spline Curve points in spatial order
• Tangency across a Mirrored Point
• Tangency between 2 arbitrary B-spline Lofted Surfaces
• Tangency between B-spline Curve and Line
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Here are the basic steps we’ll follow:

• Create durable relationships between two ends of a curve or surface.

• Show curve tangency by displaying polylines. Connect the ends of a B-spline 
curve into a smooth loop.

• Make the end points of a spline normal to a plane, and mirror that spline. Take
the concepts learned about curves and apply them to surfaces.

• Make two independent surfaces tangent to one another.

For this tutorial and the rest of the tutorials it is assumed that you already know 
something about using MultiSurf and that you are familiar with the basics of 
inserting entities, modifying the display of the model, etc.  If you do not understand 
how to perform a task, you should probably look at the earlier tutorials.

B-spline Curves: The Endpoint Tangency Property
We’ll begin by demonstrating one of the tangency properties of B-spline Curves: at 
each endpoint, they are tangent to the line between the end and next-to-end control 
points.

1 File>Open TANGENT1.ms2 from \ Tutorial Files. 

Check program settings
Let’s check those program settings and make sure we’re all starting with the same 
ones (the initial program defaults). This is what you should have:

On the View menu:

Axes and Status Bar should be ON (preceded by a checkmark; to turn an option 
on, simply click on the menu item or if it has a box next to it click on the box).

All Toolbars except Marine View Orientation should be ON.  To check this, 
click on Toolbars.  A toolbar is on when checked.

On the Tools>Options, General, tab:

Rotation Constraint should be set to Free tumble

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

The B-spline Curve
So far, this model consists solely of seven points. We will use them as control points 
for a B-spline Curve.

1 (View>Nametags, Point).

2 Put points ‘pt1’ through ‘pt7’ into the Selection Set.  (In this instance, if you 
drag a box around all of them, they will all end up in the Selection Set in order).
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It’s important for a B-spline Curve to select the points in spatial order; it happens in 
this case that they’re named in sequential order, but this won’t always be true.

3 >B-spline Curve or Insert>Curve>B-spline Curve.  OK to accept all the 
defaults.

Now, we’ll make lines between the end and next-to-end control points to help 
visualize the end tangencies.

4 Put ‘pt1’ and ‘pt2’ into the Selection Set.

5 >Line.  OK to accept the defaults.

6 Select ‘pt7’ and ‘pt6’.

7 Press <F4> to make another Line (Fig. 1). The ends of ‘curve1’ are tangent to 
‘line1’ and ‘line2’. This is one of the tangency principles of a B-spline Curve: it is 
tangent to the line between its end and next-to-end control points. This should 
match our distribution model TANGENT2.ms2.

Fig. 1

Note that a B-spline Curve does not pass through its control points (except its end 
ones), but acts as if attracted to them or attached to them with springs.

8 Drag one of the interior (non-end) control points around and watch how the 
curve responds.

9 Undo any changes you made in step 8.

The Polyline Display
We’ll show you another way you can visualize this tangency:

1 Hide ‘line1’ and ‘line2’.  Try right-clicking on each line and selecting 'Hide'.

2 Click ‘curve1’ to access Editing in the Property Manager.

3 Check the Polyline check box.  OK (Fig. 2).
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Fig. 2

With the polyline displayed you can visualize the tangency at the ends of B-spline 
Curves.  Drag one of the end points and watch the polyline remain tangent to the end 
of the curve.

With this image on the screen, we’d also like to point out that the B-spline Curve 
makes a smooth imitation of the polyline shape. This is one of its key design 
properties.

4 Close this file, don’t save changes.

Tangency and B-spline Curve Loops
We’ll use the next model to demonstrate how you can construct a B-spline loop that 
is durably smooth across the joining ends. We do this by constructing the ends so 
they are tangent to the same line.

1 File>Open LOOP1.ms2 from \ Tutorial Files. 

Here again we want to select all the points in the model, in order, and use them to 
make a B-spline Curve. Since the points are named sequentially, here’s another way 
we can select them:

2 or <Ctrl+A> to select all the points.

3 (View>Nametags, Point).

In the Selection Set pane, notice that the points are listed sequentially from ‘pt1’ to 
‘pt5’ — that’s the order we want them in for the curve we’re creating, so we can 
proceed without having to reorder them in the Selection Set.

4 >B-spline Curve and OK to accept the defaults.

5 Select ‘pt1’ and ‘pt5’ and make a line between them (see Fig. 3 below).

6 With the Line still selected, click and place a bead on the line near its 
middle.  Return to Select Mode.
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Fig. 3

Add the Bead as a Control Point
Now we’ll add this bead as the first and last control point for the B-spline Curve:

1 Click ‘curve1’ to edit in the Property Manager. Click Control points field to 
activate (salmon), so we can proceed to adding control points:

2 In the graphic image, Ctrl+click ‘bead1’, and then Ctrl+shift+click ‘bead1’ 
again — this adds ‘bead1’ twice to the Selection Set of control points for the 
curve. 

3 In the Selection Set pane, highlight one of the ‘bead1’ entries, then use to 
move it to the top of the list. 

4 Click OK (Fig. 4). This should match our distribution model LOOP2.ms2 in 
Home View.

Fig. 4

5 Drag ‘pt1 or ‘pt5’ around (e.g. Fig. 5). The loop remains closed and the 
curvature remains smooth across ‘bead1’.
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Fig. 5

6 Now, drag ‘bead1’ back and forth on its line. Again, the loop remains closed 
and the curvature remains smooth across ‘bead1’.  As the bead nears the end of 
the line, the tangency requirement forces one end to become nearly 
perpendicular to the line and then to form a sharp point in the B-spline curve, 
making it anything but smooth.  If model requirements demand the placement of 
the bead further out along the line but you still want the rounded shape, try 
lengthening the line first and then moving the bead to the proper location.

We’ve used the tangency property of the ends of a B-spline curve to our advantage. 
We know that the end of the spline is tangent to a line between the last two control 
points. If both ends of the spline share the same line, both ends will be tangent to the 
line and to each other.

7 File>Close the part; don’t save changes.

Tangency Between a B-spline Curve and a Line
This time, we will construct the model so that only one end of the B-spline Curve is 
tangent to the Line. To do this, we will change the control points on each end of the 
B-spline Curve and then pull the bead out beyond the end of the Line, onto the 
extension of the Line.

1 LOOP2.ms2 from \ Tutorial Files. 

2 Edit ‘curve1’ in the Property Manager.

3 In the Selection Set pane, highlight ‘pt5’, then click to remove it from the list 
of control points. 

4 Still in the Selection Set pane, remove the second instance of ‘bead1’.

5 At the top of the list, highlight the first instance of ‘bead1’, then click to move 
it into second position in the list.

6 In the Edit dialog, click OK.
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Fig. 6

The curve has developed an S-curve (Fig. 6), but we’re not quite done with it yet. We 
need to put the bead into position:

7 Select ‘bead1’ and drag it off the end of the line to the right (Fig. 7). Now you 
can see that the end (‘pt1’) and next-to-end (‘bead1’) control points of the B-
spline Curve are in line with the Line, thus making the B-spline Curve tangent to 
the Line. This join is G1 — there is continuous slope at the join. (To make the join 
G2 — continuous slope AND curvature, you could add another bead on the line 
and include it, in sequence, as another control point for the B-spline Curve.)

Depending on how far off the line you dragged the bead, your model should now 
resemble the distribution model TANCURVELINE.ms2.

Fig. 7

8 Drag ‘bead1’ back and forth along the extension of the line. Notice that the 
farther right you drag the bead, the smoother the transition between the line and 
the B-spline.

9 As with the previous example, you can move the endpoints of the line and the 
tangency between the line and the B-spline will be maintained (e.g. Fig. 8). Try it.

Fig. 8
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10 Close the part; don’t save changes.

Tangency and Mirrored Curves
In this example, we’ll use Projected Points to make a B-spline Curve end 
perpendicular to a plane, then we’ll mirror that curve across the plane. The B-spline 
Curve and its Mirrored Curve will join durably and smoothly across the plane.

1 File>Open TANPLANE1.ms2 from \ Tutorial Files. 

2 Select ‘pt1’.

3 >Projected Point or Insert>Point>Projected Point.

Name = 'pt5' (default)
Point = 'pt1' (pre-selected)
Mirror = ‘xpl0’ (default)
OK

4 Now put ‘pt4’ into the Selection Set and press <F4> to make another Projected 
Point.  OK to accept the defaults.  (Fig. 9).

Fig. 9

Add the Projected Points as Control Points
We’ll add these two Projected Points as the first and last control points of the B-spline 
Curve, thus making the B-spline ends meet the plane perpendicularly:

1 Click ‘curve1’.

2 Add ‘pt5’ and ‘pt6’ to the set of Control points.

3 In the Selection Set pane, select ‘pt5’, then use to move it to the top of the 
list.

4 In the Edit dialog, click OK (Fig. 10).
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Fig. 10

Make a Mirrored Curve
Now for the Mirrored Curve:

1 Place ‘curve1’ in the Selection Set.

2 >Mirrored Curve or Insert>Curve>Mirrored Curve.  OK to accept the 
defaults.

3 (Zoom to Fit) (Fig. 11)  This should match our distribution model 
TANPLANE2.ms2.

Fig. 11

In this case, we’ve made both ends of a B-spline normal to a plane, then mirrored 
that spline across the plane, resulting in a loop completely symmetric and smooth. 
The combination of the B-spline Curve ending normal to the plane plus the mirror 
symmetry makes the joins G2 — continuous slope and curvature.

4 Close the part; don’t save changes.

Tangency and Mirrored Points
In this example, we’ll use Mirrored Points to establish tangency between both ends of 
two B-spline Curves, making a very flexible loop.

1 File>Open TANPOINTS1.ms2 from \ Tutorial Files. 

2 Select ‘pt2’, and make a >Mirrored Point or Insert>Point>Mirrored Point.
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Name = 'pt5' (default)
Point = 'pt2' (pre-selected)
Mirror = ‘pt1’.
OK

3 <F> (Zoom to Fit).

4 Make a second Mirrored Point, this time using 'pt3' as the Point and ‘pt4’ as the 
Mirror.

5 Select ‘pt1’, ‘pt5’, ‘pt6’, and ‘pt4’ in that order.

6 Make a >B-spline Curve. Check that the control points are listed in the 
correct order (if they are not, select them again now).  OK to accept defaults 
(Fig. 12). This should match our distribution file TANPOINTS2.ms2.

Fig. 12

7 Drag ‘pt2’ and notice that the tangency is maintained at ‘pt1’. Similarly, if you 
were to drag ‘pt3’, tangency would be maintained at ‘pt4’.  Notice that you 
cannot drag the two Mirrored Points 'pt5' and 'pt6'.

8 Close the model; don’t save changes.

Tangency Between Surfaces
Everything we’ve said about B-spline Curves so far can be applied to B-spline Lofted 
Surfaces as well. Just as the B-spline Curve is tangent to the line between the end and 
next-to-end control points, the B-spline Lofted Surface is tangent to the imaginary 
ruled surface between the last two control curves.

1 File>Open TANSURFACE11.ms2 from \ Tutorial Files. 

2 Select the upper curve (‘xcv7’) and the plane, then make a >Projected 
Curve or Insert>Curve>Projected Curve.  OK to accept all defaults.

3 Select the lower curve (‘xcv14’), and make another Projected Curve.  OK to 
accept all defaults. (Fig. 13).
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Fig. 13

Now, when we loft a B-spline surface over these curves — the upper Projected 
Curve, the upper spline, the lower spline, and the lower Projected Curve — the 
lofting B-splines that pass through each of the four control curves will end normal to 
the plane. Let’s do it:

4 Select ‘xcv15’, ‘xcv7’, ‘xcv14’, and ‘xcv16’ in that order.

5 (the one with the cyan control curves)>B-spline Lofted Surface or 
Insert>Surface>B-spline Lofted Surface.  OK to accept all defaults.

A Mirrored Surface of this B-spline Lofted Surface will also end normal to the plane 
and, therefore, make a smooth join with the first surface:

6 With ‘surface1’ in the Selection Set:

7 (the one with the all blue boundary)>Mirrored Surface or 
Insert>Surface>Mirrored Surface.  OK to accept all defaults.  (Fig. 14).  This 
should match TANSURFACE2.ms2.

Fig. 14

8 Close the model; don’t save changes.

Tangency Between Two Arbitrary B-spline Lofted Surfaces
This final Tutorial 5 example demonstrates how to make two arbitrary B-spline 
Lofted Surfaces tangent to each other. To build a durable tangency relationship, we’ll 
use two Relative Curves, the second based on mirrored endpoints of the first.
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1 File>Open 2SURFACES.ms2 from \ Tutorial Files. 

2 to show Curve Nametags.

To give you an idea of where we’re headed: ‘curve1’ and ‘curve2’ will be the edge 
control curves for one B-spline Lofted Surface and ‘curve3’ and ‘curve2’ will be the 
edge control curves for another. We’ll begin by making a Relative Curve to control
the tangency of the upper surface-to-be.

The First Relative Curve

1 (View>Nametags, Point).

2 Select ‘pt17’ (at the left end of the middle curve), then >Point or 
Insert>Point>Point.

Name = 'pt23'
Offsets:  dx=dy=dz=0 (default)
Point = 'pt17' (pre-selected)
Frame = '*' (default)
OK

3 This puts the new Point at dx = 0, dy = 0, dz = 0, which is right on top of its 
parent ‘pt17’.

4 Drag the new point (‘pt23’) about 1/4 the distance toward ‘pt0’ (at the end of 
the uppermost spline; see Fig. 15 below).

5 Select ‘pt22’ (at the other end of the middle curve), and make another Point.  
Name this point 'pt24'.  OK.

6 Drag the new point (‘pt24’) toward ‘pt5’, about the same distance and in the 
same direction that you dragged ‘pt23’ (Fig. 15).

'pt23'

'pt24'

Fig. 15

Remember that a Relative Curve should have the same entity orientation as its parent 
curve — that is, its starting point should be the point offset from the parent curve’s 
starting point (and its ending point should be the point offset from the parent curve’s 
ending point).

7 Select ‘curve2’ (the middle curve).  Now we know the orientation of the parent 
curve.



Building Tangency with B-splines Tangency Between Two Arbitrary B-spline Lofted Surfaces

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  105

8 With ‘curve2’ still selected, add ‘pt23’ and ‘pt24’ to the Selection Set, in that 
order (you should now have three entities selected).

9 >Relative Curve or Insert>Curve>Relative Curve.  

Name = 'relcvupper'
Curve = 'curve2' (pre-selected)
Point1 = 'pt23' (pre-selected)
Point2 = 'pt24' (pre-selected)
OK

(Fig. 16).

Fig. 16

The Upper B-spline Lofted Surface
Now we’re ready to make the first B-spline Lofted Surface:

1 Select ‘curve1’, 'relcvupper', and ‘curve2’ in that order. These will be the 
control curves for the upper B-spline Lofted Surface.

2 >B-spline Lofted Surface.  OK to accept all defaults.

To visualize the tangency here, let’s make the ruled surface between the last two 
control curves:

3 Select 'relcvupper' and ‘curve2’.

4 >B-spline Lofted Surface (a B-spline Lofted Surface with just two control 
curves is a ruled surface).

Display>Color = Brown
Advanced>u-divisions = 8x4
Advanced>v-divisions = 1x4
OK

5 Click on point 'pt17', and rotate the model.  With the two surfaces end-on 
you should be able to see that ‘surface1’ ends tangent to the new surface (Fig. 17).
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'surface2'
'surface1'

Fig. 17  Lat 1.7, Lon -52, Tilt 59.5

6 In Select mode, drag ‘pt23’ around a bit and watch how the B-spline Lofted 
Surface responds, while always maintaining tangency to the ruled surface.

7 Undo the changes made in step 6.

The Second Relative Curve
Now let’s work on the lower surface, beginning by making a Relative Curve that will 
control its tangency.

1 (Home view).

2 With ‘pt23’ (at the left end of ‘curve1’) still selected, make a >Mirrored Point.

Name = 'pt25'
Point = 'pt23' (pre-selected)
Mirror = ‘pt17’
OK

3 Select ‘pt24’ and ‘pt22’ in that order and make a second Mirrored Point.

Name = 'pt26'
Point = 'pt24' (pre-selected)
Mirror = ‘pt22’ (pre-selected)
OK

Now we’ll make a second Relative Curve, also with the same entity orientation as 
‘curve2’.

4 Select ‘curve2’, ‘pt25’ and ‘pt26’, in that order, and make another Relative 
Curve .  Name this Relative Curve 'relcvlower'.  OK (Fig. 18)
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Fig. 18

The Lower B-spline Lofted Surface
1 Select ‘curve3’, ‘relcvlower’, and ‘curve2’ in order. These will be the control 

curves for the lower B-spline Lofted Surface.

2 >B-spline Lofted Surface.  OK.

For visualization, let’s extend the ruled surface straight through to the second 
Relative Curve:

3 Edit the (brown) surface (‘surface2’).

4 In the Edit dialog, the “Control curves” field is active. In the graphic image or in 
the Available Entities pane, add ‘relcvlower’; OK to the Edit dialog (Fig. 19).  
(This surface started as a ruled surface because it was a B-spline Lofted Surface 
with two control curves.  In general, a B-spline Lofted Surface with more than 
two control curves is not ruled.  In this case, however, because of the way the 
three parent curves are related, this is still a ruled surface).  Both ‘surface1’ and 
‘surface3’ are tangent to this surface (‘surface2’). This join is G1 — continuous 
slope.

'surface1'
'surface2'

Fig. 19  Lat 3.6, Lon -62.2, Tilt 57.5

5 Drag ‘pt23’ (or ‘pt24’) around and watch the surfaces adjust, all the while 
maintaining tangency at their join.  You’ll probably have to rotate and zoom to 
get the best view.  Cool.

6 Close without saving and exit.
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Marine Design Examples

Overview
MultiSurf has broad applications throughout the world of engineering design. At 
AeroHydro, the focus of our engineering experience and expertise is in the design 
and manufacture of boats and ships, so it is natural that in the short history of 
MultiSurf we have already created hundreds of models exploring and demonstrating 
marine applications. For our naval architect friends, we take this opportunity to 
present and discuss many of these models. We hope that non-marine users as well 
will find it worthwhile to explore these examples with us, to meet additional entities 
and techniques for “real-world” applications of MultiSurf.

Entity introductions:

• Contours
• Developable Surface
• Offset Surface
• Plane

Concept and Function introductions:

• Bow Rounding
• B-spline Curve with straight section
• C-spline Curve with straight section
• C-spline Lofted Deck
• C-spline Lofted Hulls with B-spline Master Curves
• Cylindrical Transom
• Developable Deck (No camber)
• File>Export 3D>RUL surfaces
• Mix Developable and Compound-Curved Surfaces
• Movable Bulkhead
• Movable Cabin
• Planar Sheerline
• Planar Transom
• Planing Powerboat
• Preference for Degree-3 B-spline Curve Control Curves
• Right click in Offsets window white space>Export OFE
• Round Stern
• Sailing Yacht Keels
• Show-Hide>Hide Unselected, >Show Children
• Skin Deduction by Offset Surfaces
• Spars and Rigging
• Window>Tile Horizontal
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• Tools>Hydrostatics, >Mass Properties
• Tools>Measure>Clearance, >Distance
• Tools>Options, Performance, Model, Divisions multiplier
• View>Display>Offsets
• View>Display>Surface Curvature, Gaussian
• View>Nametags, Surface

As you may have gathered from the list of topics, this tutorial is quite extensive, and 
we suspect that you’ll tackle the material in chunks rather than at one sitting. In fact,
you may want to use this tutorial more like a reference, choosing first the topics 
which most interest you. The examples are self-contained and not based on any 
particular sequence. We do assume that by now you will have some facility with the 
program, e.g. setting filters for points or curves only, for preselecting parents during 
the Create process, etc.

The format of the discussion is basically the same as in Tutorial 4 — we have you 
load sample model files, note certain features, make some changes often times, note 
the effects, etc. Do NOT save any of these models under their original names after 
making changes in them. This is so you will have the original model to go back to in 
case you or someone else wants to repeat one of the examples. 

“MultiSurf Tutorials: Introduction” contains information about taking a break, what 
to do if your screen doesn’t match our instructions, basic terminology, typeface and 
symbol conventions, and troubleshooting. 

So, to begin: 

Start MultiSurf (from the Windows Start menu, or from Explorer, Program 
Manager, or File Manager; program filename is WINDSURF.EXE).

Most of the files for these examples are in the \MARINE TUTORIALS folder; we’ll 
specifically tell you when a file resides in a different folder. When you finish each 
example and close the file, do NOT save changes.

C-spline Lofted Hulls with B-spline Master Curves
A central task of marine design is the geometric definition of hull surfaces. If you 
have followed the tutorials, you have already seen hull examples: DEMO, CLFT5X4, 
BLFT5X4. You may have detected our preference for C-spline Lofted Surface hulls 
with B-spline Curve master curves. C-spline Lofted Surfaces are composed of C-
spline Curves “sprung” (lofted) through a set of master curves. They are natural 
candidates for hull design because their longitudinal C-splines: 

• behave similarly to a drafting spline
• behave similarly to planking and ribbands
• are likely to automatically fair themselves if you use a modest number of control 

points
• pass through all their control points, which gives you more direct shape control
• are naturally parameterized in proportion to arc length

1 Open DEMO.MS2.

This is a C-spline Lofted Surface with just three master curves, each a B-
spline Curve with 4 control points. This really seems to make a nice hull, and 
there are many possible variations on this shape just working with the 12 
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control points. The fewer master curves you use, the more automatic is the 
longitudinal fairing.

2 Close DEMO.

3 Open CLFT5X4.

To obtain more control over the longitudinal distribution of displacement, it 
is natural to add more master curves. This is the same basic hull as DEMO, 
but with 5 master curves.

4 (Show-Hide>Show Points) (Fig. 1).

5 (Point nametags).

Z

X

Y'p22'

'p23'

'p42'
'p43'

 Fig. 1

6 or <X> view and <F> to Zoom to Fit.

7 Move ‘P22’, ‘P23’, ‘P42’, and ‘P43’ around — moving these four points, you 
can make many variations (from subtle to dramatic) of hull shape while retaining 
the existing shape of the sheerline, profile, and master curves 1, 3, and 5.

8 Remove the point nametags, hide the points, turn on symmetry images and 
rotate around the model.

Before closing this model, let’s be sure we’re all together on program 
settings.
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Check program settings
This is what you should have:

On the View menu:

Axes and Status Bar should be ON (preceded by a checkmark; to turn an option 
on, simply click on the menu item or if it has a box next to it click on the box).

All Toolbars except Mechanical View Orientation should be ON.  To check 
this, click on Toolbars.  A toolbar is on when checked.

On the Tools>Options, General tab:

Set Rotation Constraint to Free tumble mode

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

Close the model (do NOT save changes).

Bow Rounding
It is unusual for a hull to come to a sharp edge at the bow, as DEMO and 
CLFT5X4 do, partly because a sharp edge is both vulnerable to damage and 
prone to inflict damage, and also because it is difficult to fabricate with most 
materials. With MultiSurf we can define the rounded region in detail. Here is 
one way.

1 Open PROJCRV1. This is a modification of DEMO, with ‘MC1’ moved off 
center and a Ruled Surface added to make a ‘half-siding’ surface between ‘MC1’ 
and its projection on the centerplane.

2 Delete the Ruled Surface ‘half_siding’ (cyan).

3 Select the surface ’hull’.

4 Turn on Quick Spline Mode.

5 Create a vertical snake near the bow of the boat. The spline should have 4 
control points. Double click to end the spline. Don’t worry about point locations, 
we will place them precisely in the next step.

6 Change the positions of the magnets to the following by double clicking each one 
in turn:

'magnet1' u=0, v=.06
'magnet2' u=.25, v=.03
'magnet3' u=.75, v=.01
'magnet4' u=1, v=0

7 Rename the B-spline Snake ‘tangent’ (Fig. 2)
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8 Preselect ‘profile’ (magenta), ‘MC1’ (cyan), ‘tangent’ (magenta).

9 >B-spline Lofted Surface or Insert>Surface>B-spline Lofted Surface

Name = 'bowround'
Degree = 3
Control curves = (pre-selected)
Advanced>Divisions = 10x2, 3x2  (Fig. 3)
<OK>

'tangent'

'profile''MC1'

 

'bowround'

Fig. 2 (Left) Fig. 3 (Right)

10 Hide ‘MC1’ (cyan) so it doesn’t confuse the picture.

11 Click on 'bowround' and .  Take a look at what you have created.

(Alternatively, you can open BOWROUND.MS2, which is this same 
example.) This makes a nicely rounded bow which is durable with respect to 
arbitrary movements of the control points ‘P11’, ‘P12’, P13’ etc. Also the v
parameters of ‘mag1’, ‘mag2’, and ‘mag3’ can be adjusted to control the 
extent of the rounding. 

If you’d like to see the use of a SubSurface to “trim off” the portion of ‘hull’ 
forward of ‘tangent’, open Subsurf2.ms2 and see the discussion in Example 2 
of the entity description for SubSurface.

Close the model (don’t save changes).
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Round Sterns
A B-spline Lofted Surface can similarly be patched on at the stern, to 
accomplish a rounding there, when desired. However, because rounded 
sterns typically involve much larger areas of the surface, we would probably 
opt to make the whole boat a B-spline Lofted Surface.

1 Open BLFT5X4.

2 or <Y> view.

3 Zoom in on the stern master curve ('MC5', blue).

4 , and (Show Points, Point nametags, and Grid).

To start the stern rounding, we’ll eyeball ‘MC5’ into a curved profile by 
moving ‘P54’ and ‘P53’:

5 Tools>Options, Dragging, Snap and set X, Y and Z snaps to 0.1.

Next we'll show you how to drag a point when it is too close to another point to be 
able to just click on it and drag.

6 Click on the bottom of the three visible points on 'MC5' and select 'P54' from 
the "Which Entity?" box.  When you click on that spot again, you will click on 
'P54'

7 Drag ‘P54’ forward along the profile to about X = 28.6, Z = -.1 (Fig. 4).

8 (Orthogonal Dragging).

9 Drag ‘P53’ forward to about X = 29.6 (Fig. 5).

Fig. 4 Fig. 5

10 or <Z> view (move or re-size view if necessary to bring all of ‘MC5’ (blue) 
into view).
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11 >Projected Curve or Insert>Curve>Projected Curve

Name = ‘MC6’ (default)
Curve = ‘MC5’ (blue)
Mirror = ‘*Y=0’ (from the Available entities pane.)
Advanced>Divisions = 5x4  (Fig. 6)

Projected Curve

 Fig. 6

12 Look at the or <Y> view again, you’ll see that ‘MC5’ is drawn right on top of 
‘MC6’.)

13 Click on 'hull_b’

14 For Control curves, <Ctrl+click> ‘MC6’ (This is easy to find in the Entity 
Manager) to add it as the last Control curve.

15 Turn on Symmetry Images, look at the or <Z> view and Zoom to Fit.

X

Y

Fig. 7

Now you can make adjustments to the stern shape by moving control points 
‘P51’, ‘P52’, etc. The smooth join between the port and starboard sides at 
‘MC6’ is durable because of our use of a Projected Curve and a B-spline 
Lofted Surface.

Close the model (don’t save changes).

Tangent Boundary Surface Hulls
Support of Tangent Boundary Surfaces, which are based on their edge 
curves, provides an interesting and attractive approach to the design of 
many hulls.
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1 Open PWRB2.

This chine hull uses Tangent Boundary Surfaces for both topside and bottom 
panels.  The focus of a Tangent Boundary Surface design is on the boundary 
curves.

2 (Curve nametags). This will identify the principal lines ‘sheer’, ‘chine’, 
‘keel’, etc.

Taking advantage of MultiSurf' capabilities to establish and maintain 
connections between entities, we have used dependencies here to make the 
connections of these curves durable; for example, ‘stem’, ‘chine’, and ‘keel’ 
all use point ‘A3’ as an endpoint.

3 (Point nametags) to identify ‘A3’ (and the other supporting points for this 
model).

The ‘topside’ surface has the four edge curves ‘stem’, ‘chine’, ‘E’, ‘sheer’ (in the entity 
definition of a Tangent Boundary Surface, the four basis curves have to be named in 
sequence around the surface). The ‘bottom’ surface has the edge curves ‘A3’, ‘keel’, 
‘F’, ‘chine’. Notice that the first side, ‘A3’, is degenerate, i.e. a single point rather than 
an actual curve.

4 View>Display>Ship Lines.

Body plan factor = 2

Notice in the body plan how the topside 
sections transition smoothly from the flared 
character of the stem master curve to the 
convexity of the stern master curve (Fig. 8). 
This results from the linear blending (G0 
tangency for the Tangent Boundary Surfaces). 
The ‘bottom’ starts with a pronounced hollow 
at the stern, which gradually fades away as 
you come forward.

Keel with a Durably Straight Portion
With PWRB2 still open, it is also interesting to note how the straightness of 
the keel in the aft half of the boat is accomplished. ‘keel’ is a B-spline Curve 
(Degree 2), and four of its five control points lie on the line ‘baseline’ (three 
of them are beads, and one is an end of ‘baseline’). This makes ‘keel’ durably 
straight, from the midpoint between beads ‘D2’ and ‘D3’ to its end.

You can also make C-spline Curves with durably straight portions using the 
following method. Make the control points be:

• a bead at the mid-point of the line (t = 0.5)
• a bead very close to the end (t = 0.0001 or t = 0.9999)
• the point at the end of the line (t = 0 or t = 1)
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For an example, see STRGTPART.ms2. This method makes excellent chines and keels 
for powerboats.

Close the model (don’t save changes).

Developable Surfaces
Developable surfaces — surfaces that can be made by bending flat material without
stretching it — are advantageous for metal and plywood boats because of the ease 
with which they can be formed from the flat sheet material. In MultiSurf, you can 
make developable surfaces in two basic ways:

1 as Ruled Surfaces joining two curves which are specially selected to assure 
developability, for example cones and cylinders

2 as explicitly developable surfaces joining two arbitrary curves

One of the ways to check for developability is to look at the Gaussian curvature 
display.

Ruled surface
1 Open Ruled1 in the \Examples folder. This is a single Ruled Surface spanning 

two curves named ‘sheer’ and ‘chine’ (Fig. 9, left).

2 or <Z> view (Fig. 9, right). This shows that the two curves are actually 
congruent, i.e. parallel and identically shaped, therefore this Ruled Surface is a 
general cylinder and by definition is developable (as noted in (1) above).

Z

X

Y

'chine'

'sheer'

ruled surface

X

Y
 Fig. 9

3 (Home view) so you can see the surface again.

4 Select the surface (green)

5 or View>Display>Surface Curvature

Curvature Type = Gaussian. 

This opens a new window and presents the color-coded Gaussian curvature display. 
The key for the color-coding shows at the left side of the drawing area. In this case, 
the display is all green, indicating Gaussian curvature is zero over the whole surface. 
(The white lines on the surface are an artifact of small rounding errors in the 
calculation of the surface curvature.  The calculated values for this surface are not 
always precisely zero, falling to one side or the other of 0.0.  The white lines 
represent those places where the value calculates to precisely 0.0.)  This is a necessary 
and sufficient condition for a surface to be developable.
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6 Close the Gaussian curvature window.

Next, we’re going to edit the model:

7 Click the point ‘sh2’ (near

the middle of the upper edge). 

8 Change dy to 7. Now ‘sheer and 
‘chine’ are no longer congruent (Fig. 
10). X

Y

Fig. 10

9 Select the surface and View>Display>Surface Curvature, Gaussian again.

Now the surface is a rainbow of pretty colors with Gaussian curvature ranging from 
6.13e-15, or essentially 0, (red) in the central portion to -0.005644 (blue) in the “lower” 
corners.  This surface could not be made from a flat plate without stretching some 
material.

10 Close the Gaussian curvature window.

11 Close Ruled1.

Developable surface
1 Open DEVSURF0 from \Marine Tutorials.

This model is the same as Ruled1 except that the surface is a Developable Surface.  
This type of surface is still a ruled surface, formed by straight lines (rulings) 
connecting the two edge curves, however, the rulings are rearranged to satisfy the 
condition of developability.  When you open the model it doesn't look any different 
than Ruled1 because the lines are congruent, and no rearranging needs to be 
performed, but move 'sh2' again and you will see the power of the Developable 
Surface.

2 Click the point ‘sh2’. 

3 Change dy to 7 (Fig. 11).

4 Select the surface and 
View>Display>Surface Curvature,  
Gaussian X

Y

Fig. 11

Now the surface is all green, indicating zero Gaussian curvature everywhere, as 
required.

5 Close the model (don’t save changes).
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6 Open DEVSURF1 from the 
\Examples folder. This is a single-

chine boat hull made from two 
Developable Surfaces, sharing the 
common edge ‘chine’ (Fig. 12).

7 File>Export 3D>RUL surfaces. Fig. 12

8 <OK> to the 3D Export Options dialog.

9 <Save> to accept the default filename Devsurf1.RUL (<Yes> to replace).

This creates a .RUL file containing two panels. The file can be loaded into the 
MultiSurf utility MSDEV for plane development (expansion) and other operations 
related to developable-surface manufacturing.

Close the model (don’t save changes).

Mixing Developable and Compound-Curved Surfaces
Round-chine or radius-chine construction combines the putative aesthetic and 
hydrodynamic advantages of a round bilge with the fabrication advantages of large 
developable areas.

1 Open RCSH0.

This is an example of a “radius-
chine” or “round-chine” sailing 
yacht hull (Fig. 13). The bulk of the 
hull area is in the two developable 
surfaces ‘topside’ and ‘bottom’, with 
all compound curvature limited to 
the relatively narrow C-spline Lofted 
Surface ‘chine_strake’.

'chine1'

'p54'

'chine2'

'pp14'
'p14'

Z
Y

X

Fig. 13

2 (Curve nametags).

The four curves ‘sheer’, ‘chine1’, ‘chine2’, and ‘profile’ are the basic framework of 
this design. The upper pair and lower pair define the two developable panels. 
Between ‘chine1’ and ‘chine2’ we have built a C-spline Lofted Surface using 4 B-
spline master curves. The C-spline Lofted Surface accurately joins the C-spline 
Curves ‘chine1’ and ‘chine2’ because it is composed of C-spline curves in the 
longitudinal (u = constant) direction. The four middle control points ‘p31’, ‘p32’, 
‘p33’, ‘p34’ are conveniently located to achieve (approximate) tangency between the 
three surfaces. These control points were carefully positioned in the <X> view, while 
observing the smoothness of the stations (red Contours) as they cross the chines.

3 Tools>Mass Properties shows the surface areas.
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Durably Planar Transom
With RCSH0 still open, it is also interesting to note how a durably planar transom
was achieved:

1 We created a 3 Point Plane ‘tr_plane’

for the transom to lie in, specifying it 
with the points ‘p14’ (sheer point on last 
master curve), ‘pp14’, and ‘p54’ 
(centerline point on last master curve; 
Fig. 14). Our use of ‘p14’ and its 
perpendicular projection onto the 
centerplane, ‘pp14’, ensures that the 3 
Point Plane will be perpendicular to the 
centerplane (the line between ‘p14’ and 
‘pp14’ is perpendicular to the 
centerplane; any plane that includes that 
line will also be perpendicular to the 
centerplane).

'tr_plane'

'pp14'

'p54'

'p14'

X

2 Then we placed three Points points ‘p24’, ‘p34’, ‘p44’ close to this plane, and 
made three Projected Points ‘pp24’, ‘pp34’, ‘pp44’ which are the projections of 
these Points onto ‘tr_plane’. Two of the Projected Points are used as the aft 
endpoints for ‘chine1’ and ‘chine2’, and all three control points are used for 
‘mc4’; the Projected Points lie accurately on the plane. The three Points ‘p24’, 
‘p34’, and ‘p44’ then just serve as “handles” to drag the three Projected Points 
around with.

If we had wanted a cylindrical transom, we could have created a cylindrical surface 
(e.g., with a Translation Surface or a Revolution Surface) in place of the plane 
‘tr_plane’, and used three magnets on the cylinder as end points and control points 
for ‘chine1’, etc. For cylindrical transom examples see Tutorial 3 “Reshape the stern" 
and Tutorial 6 "”Cylindrical Transom” on page 139.

Close the model (don’t save changes).

Sailing Yacht Keels
Accurate attachment of a keel to a hull is an important issue. We achieve this in 
durable fashion by using a snake on the hull for the upper edge of the keel surface. If 
there is a bulb, we would design the hull and bulb as separate, independent surfaces, 
then build the keel between them, using a snake on the bulb for the lower edge of the 
keel surface.

1 Open BKRY0 (Fig. 15). Here

‘hull’ is a B-spline Lofted Surface 
with five B-spline Curve control 
curves. ‘bulb’ is a 180-degree 
revolution surface, using a Type-
4 foil curve as its meridian.
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Fig. 15

2 or <Y> view.

3 Zoom in on the ‘bulb’.

4 Hide the surface ‘bulb’ (green). This allows you to see ‘meridian’ (dark cyan), 
making the top edge of ‘bulb’.

5 Show ‘bulb’ again and select it.

6 Notice the surface orientation. This shows the origin of ‘bulb’ is at the pointed 
aft tip, and u runs along the ‘meridian’ edge. (Foil curves and snakes all have 
their t = 0 end at the trailing edge.) There are 2 arrow heads in this view.  The one 
pointing to the right shows the direction of u.  The one pointing to the left is the 
head of the surface normal arrow.

7 Zoom to where the whole ‘keel’ surface is in sight.

8 (Curve nametags). The control curves for ‘keel’ are:

the Projected Snake ‘keel_root’ on ‘hull’
the Foil Curve ‘mid’
the Projected Snake ‘keel_root1’ on ‘bulb’

9 (Curve nametags).

This model will hang together through many possible parametric changes: 

• changes in the control points of ‘hull’
• changes in the diameter, length, and position of ‘bulb’
• changes in the chord, thickness, and planform of ‘keel’

For example:

10 <F> (Zoom to Fit) to see the entire <Y> view.

11 Drag the point ‘bulb_nose’ down to about X = 29, Z = -15. In this change the 
bulb stays horizontal, because the other end of ‘axis’ is a Point with ‘bulb_nose’ 
as its Point parent.

12 Where the front of the keel meets the hull you will find a red point called 
‘keel_ctrl’. Drag this point and notice how the keel stays durably attatched and 
constrained to the centerline. The point ‘keel_ctrl’ is a ring, which in this case is 
constrained to the edge of the hull surface.

Close the model (don’t save changes).
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Decks

C-spline Lofted deck
Along with our preference for C-spline Lofted hulls using B-spline Curve 
control curves goes a preference for the same combination in making simple 
decks. (This is an alternative method to the deck you made in Tutorial 3).

1 Open HULLDECK. This is a C-spline Lofted Surface hull similar to DEMO, but 
with 4 control curves.

2 Move the viewpoint to Lat +30, to see the ‘deck’ better. ‘deck’ is a C-spline 
Lofted Surface, also with 4 control curves. Its first control curve is just the point 
‘P11’; the other three are B-spline Curves (magenta) with 3 control points each. 
‘deck’ durably joins ‘hull’ because their control curves share the end control 
points ‘P11’, ‘P21’, ‘P31’, and ‘P41’. The u = 0 longitudinal C-splines on both 
surfaces are identical.

3 (Point nametags).  The points ‘D23’, ‘D33’, ‘D43’ along the deck centerline 
are Projected Points based on ‘D22’, ‘D32’, and ‘D42’ respectively. This ensures 
that each of the deck-beams meets the centerplane orthogonally, so the deck has 
continuous slope across the centerplane. 

4 Turn on Symmetry Images (<F5>) to see this.

Close HULLDECK.

Developable deck (no camber)
For a deck that has no camber, a Developable Surface is very handy because 
it’s so easy to build. For this next model, we’ll create a Ruled Surface in the 
shape of a general cylinder. (Recall that while all Developable Surfaces are 
ruled surfaces, NOT all ruled surfaces are developable. A general cylinder is 
one of the special cases of ruled surface that is indeed developable.)

1 Open PWRB2.

2 Go to Lat 30.

3 >Projected Curve or Insert>Curve>Projected Curve.

Name = ‘deck_ctr’
Curve = ‘sheer’ (magenta).
Mirror = ‘ctr_plane’ (Fig. 16, left).
<OK>

4 >Ruled Surface or Insert>Surface>Ruled Surface.

Name = ‘deck’
Control curves = ‘sheer’ and ‘deck-ctr’
Advanced>Divisions = 16x1, 1x1 (Fig. 16, right)

This closes the hull in with a flat-across deck that durably joins the hull.
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Fig. 16

5 Turn on Symmetry Images and see what you have.

Close PWRB2 (don’t save changes).

A Movable Bulkhead
1 Open BULKHD1 (yes, we looked briefly at this model in Tutorial 1).

2 (Point nametags).

3 Select the bead ‘e0’ (green).

4 or Show-Hide>Show Children.

 Fig. 17

‘p0’ and ‘p1’ (yellow) are the endpoints of a line that runs along the X-axis. ‘e0’ and 
‘e1’ (green), beads on this line, define the 2 Point Plane ‘a0’ that is perpendicular to 
the X-axis. Since ‘e1’ is a Bead relative to ‘e0’, you can move the plane anywhere 
along the length of the hull by moving ‘e0’.

5 Drag ‘e0’ aft and watch the transverse plane ‘a0’.

6 (Curve nametags).

‘n0’ and ‘n1’ (magenta) are Intersection Snakes along the intersection of the ‘hull’ and 
‘deck’ surfaces and the plane ‘a0’. They move when the plane moves. In addition, 
they make the bulkhead-hull and bulkhead-deck joins watertight.

The bulkhead surface (white) is a Ruled Surface between the Intersection Snakes, and 
it therefore also moves with the plane ‘a0’.
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7 Drag ‘e0’ forward and aft to various locations and focus on how the 
dependencies we’ve set up make the bulkhead position flexible yet maintain the 
accurate joins to the hull and deck.

8 (Point nametags off).

What if you have a certain X location where this bulkhead is to be placed. Right now 
the bead is measured in units of t but our boat is measured in feet or inches. Here is a 
quick way to remedy the situation.

9 Select the line ‘l0’.

10 >XYZ Bead or Insert>Bead>XYZ Bead

Name = ‘e2’
Constrain to: X
X = 10
<OK>

11 Add bead ‘e0’ to the Selection Set

12 <Shift+A> (Adopt Children)

Reverse Order
Delete old parent 'e0'
<OK>

The bulkhead can now be placed by typing an X value in to the Edit Dialog for the 
XYZ Bead ‘e2’.

13 Close the model (don’t save changes).

Superstructures
Superstructures that durably join the deck can be created with surfaces built 
off snakes on the deck surface.

A movable cabin
1 Open 2CABINS (yes, this is the same file we looked at in Tutorial 1).

2 <F5> (Symmetry Images).

The deck surface here is a C-spline Lofted Surface similar to the one in Hulldeck.

3 Zoom in on the cabin.

4 (Point nametags).

‘r0’ and ‘r1’ (white) are rings on an Edge Snake (‘n0’; magenta) that runs along the 
centerline edge of the deck surface — ‘r1’ is a Ring relative to ‘r0’.

‘dm1’, ‘dm2’, ‘dm3’ (red) are three magnets on ‘deck’ — ‘dm1’ and ‘dm2’ are 
Magnets relative to ‘r0’; ‘dm3’ is a Magnet relative to ‘r1’.
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Notice also ‘rp1’, ‘rp2’, ‘rp3’, ‘rp4’ (blue); each of these Points has one of the magnets 
or rings on ‘deck’ as a support.

5 , (Point nametags off and Curve nametags on).

‘snake1’ (green) is a B-spline Snake,  and ‘snake2’ and ‘snake3’ (magenta) are Line 
Snakes on ‘deck’ joining the deck magnets and rings. Through sharing magnets 
‘dm2’ and ‘dm3’, these snakes join durably end-to-end. 

‘rc1’, ‘rc2’, and ‘rc3’ (also magenta) are Relative Curves based on the respective 
snakes. Through sharing endpoints ‘rp2’ and ‘rp3’, these curves join durably end-to-
end.

The cabin sides (dark green) are three Ruled Surfaces joining ‘snake1’ to ‘rc1’, etc. 
Built off snakes on ‘deck’, the cabin sides join the deck accurately.

The cabin top (dark cyan) is a Tangent Boundary Surface which joins its edge curves 
accurately.

6 (Home view).

7 and (Point nametags on and Curve nametags off).

Now that you have had a more close-up view of this model, briefly take it 
through the same set of changes as in Tutorial 1 — focus on how the 
dependencies built into the model allow editing flexibility while keeping the 
cabin intact and watertight:

8 Drag ‘r0’ aft along the centerline, to 
just ahead of the red deck beam (Fig. 
18).

The entire cabin moves when you move 
‘r0’ because all the supporting points for 
the cabin are based directly (‘r1’, ‘dm1’, 
etc.) or indirectly (‘rp2’, ‘rp4’, etc.) on 
‘r0’.

Fig. 18

The cabin is durably watertight along the centerline because the rings ‘r0’ and ‘r1’ 
cannot be moved off the Edge Snake that runs along the centerline of the deck (unless 
you change the deck so it doesn’t end on the centerline!).

9 Now drag ‘r0’ directly forward, to about halfway between the tip of the bow 
and the cyan deck beam.

10 Drag ‘r1’ aft along the centerline to 
the red deck beam (Fig. 19).

The aft end of the cabin moves when you 
move ‘r1’ because the supporting points 
for the aft surface are based directly 
(‘dm3’ and ‘rp4’) or indirectly (‘rp3’) on 
‘r1’.

Fig. 19
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11 Select ‘r0’ again (at the front of the cabin).

12 Drag ‘r0’ aft to the cyan deck beam.

The whole cabin moves again. Pretty slick! Okay, let’s leave 2CABINS and 
move on.

13 Close the model (don’t save changes).

A cabin with a flying bridge
1 Next, open PWRB1. This is a more complex superstructure model, and we’ll just 

point out some of its features. You’ve already seen this hull and the Ruled 
Surface deck.

2 (Show All). Now you can see the next element in our design, the cylindrical 
Translation Surface ‘top_surf’(blue; used as a basis for the upper deck), and the 
construction line 'baseline'.

After ‘top_surf', we added B-spline 
Snakes ‘deck_snake’ (red) on ‘deck’ 
and ‘ts2’ (cyan) on ‘top_surf’ to serve 
as edge curves for the Ruled Surface 
‘windows’ (cyan; Fig. 20 top). You 
can hide ‘coaming’ and ‘sub_ts2’ to 
see the entirety of ‘ts2’; when you’ve 
finished looking, show them again.

'deck_snake'

'ts2'

Fig. 20

We made another B-spline Snake 
‘top_bdry’ (white), on ‘top_surf’, to 
serve as the curved outline of the 
upper deck (if you can't see it try 
hiding ‘top_deck’; then show it 
again). The upper deck itself, 
‘top_deck’ (green), is a SubSurface  
on ‘top_surf’, bounded by: 
‘top_bdry’, two line snakes 
(‘ts_aft_edge’ and ‘ts_ctr’) along 
edges of ‘top_surf’, and Magnet 
‘tm1’ (Fig. 21). Then we hid ‘top_surf’.

'ts_aft_edge'

'ts_ctr'

'tm1'

'top_bdry'

Fig. 21
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The flying-bridge bulwark is another 
Ruled Surface ‘coaming’ (yellow), 
using a SubSnake ‘sub_ts2’ (red) of 
‘ts2’ as its lower edge, and a Relative 
Curve ‘coaming_top’ (magenta) 
based on ‘sub_ts2’ as its upper edge 
(Fig. 22. You can hide ‘coaming’ to 
see the basis curves).

'coaming_top'

'sub_ts2'

Fig. 22

Close the model (don’t save changes).

Spars and Rigging
MultiSurf can be used to advantage in 
planning spars and rigging for sailing 
yachts. 

1 Open CUTTER.

This is a proposed cutter rig for the 
Hulldeck model you met earlier in these 
examples (Fig. 23).

Here’s how we made it:

We placed a magnet ‘step’ (bright white; 
at bottom of ‘mast’) on ‘deck’ at the 40%-
waterline Contours based on the *X=0 
plane. Then we deleted the Contours. 
We also placed magnets on deck for the 
three chainplates (red) and for the inner 
forestay pelican hook (also red).

Fig. 23

We made a point ‘truck’ (magenta) using ‘step’ as its support, 38 ft. up and .76 ft. aft. 
This builds in a 2% rake. ‘mast’ is a yellow line from ‘step’ to ‘truck’.

On ‘mast’ we placed three beads: ‘gooseneck’, ‘lower_bead’, and ‘upper_bead’ (all 
cyan).

‘backstay’ is a line running from ‘P41’, the quarter (the aft corner of the deck), to 
‘crane’, a point .375 ft. aft of ‘truck’. (We favor double backstays, based on painful 
experience).  ‘headstay’ is a line from ‘truck’ to ‘P11’ (at the point of the stem). 
‘forestay’ is a line from ‘upper_bead’ on the mast to ‘pelican’ on the deck.

The boom, spreaders, and jumper strut are lines from the beads on ‘mast’ to the spar 
tips, which are points off their respective beads.
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The lower shrouds are lines from ‘lower_bead’ to their respective chainplates. The 
jumper stay, intermediate shroud, and upper shroud are type-1 B-spline Curves with 
t-divisions = 2, 2, and 3 respectively.

All the connections in the model are durable with respect to movements of the mast 
step, changes in mast height, positions of spreaders. For example:

2 Select ‘truck’ (magenta; at top of mast). 

3 Change dz to 42. The model updates, and all elements are proportionally 
located.

With a slightly less idealized model (for example, we would represent the thickness 
of the mast), a model like this could be used to calculate accurate rigging lengths. For 
example:

4 Add ‘P11’ to the Selection Set (Selection Set now = ‘truck’ and ‘P11’).

5 Tools>Measure>Distance and click in graphics white space.

We get 44.125 for the tall rig. With appropriate deductions for end fittings, tangs 
toggles, and turnbuckle this would provide an accurate wire length for the forestay.  
For details about how the Distance function works, see its description in the 
reference section

Close the model (don’t save changes).

Offsets and Hydrostatics
Analysis of the hydrostatic forces and moments acting on the ship hull is an 
important element of naval architecture. MultiSurf includes capabilities for 
evaluation of intact hydrostatics, and it connects (through the Offsets view right click 
menu and Export OFE or Export OF4) to other AeroHydro programs for further 
hydrostatic and hydrodynamic analysis.

Viewing offsets
1 Open DEMO.

2 View>Display>Offsets. 

3 In the Offsets Options dialog, click Add Deck.  Since we’ll be running 
hydrostatic calculations from these offsets and the DEMO hull has no deck to 
enclose positive volume, we ask MultiSurf to supply one for us.

4 Read the warning message then move it out of the way.

The Offsets view (Fig. 24) shows transverse sections through the hull and deck 
surfaces, as cyan polylines. This view of the model consists of just the data that you 
see here: a series of transverse (X = constant) sections, each represented as a polyline. 
Y mirror symmetry is assumed.
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Fig. 24

As the program detected and warned us about (and you probably have noticed, as 
well), there are some deficiencies in this particular representation of the DEMO 
model. First, the whole bow is missing. Less obviously, a piece of the stern is missing 
— the last section is at X = 29.25, while the hull extends to X = 30. Use of just 11 
sections (stations 0 through 10) looks a little skimpy.

5 Leaving the Offsets view open, return to the graphics window.

Creating more cross-sections
First we'll double the number of cross-sections:

1 Edit the definition of ‘stations’ (red).

Index of first contour = -1
Index of last contour = 20
Signed distance from Mirror/Surface to 0-index contour = 1.8 
(unchanged)
Contour spacing = 1.368
<OK>

Notice that the Offsets Warning box now only shows that the last station has a 
problem (we’ll fix that in a bit).

2 or Window>Tile Horizontal to see the results thus far (Fig. 25).

Fig. 25

The number and location of offset stations is controlled by visible Contours entities 
which lie in a transverse plane.  Next we will create stations at the extreme ends of 
the hull. (MultiSurf will sort all the stations into ascending order of X-position).

3 Insert>Contours

Name = ‘xbow’
Mirror/Surface = *X=0
Index of first contour = 0
Index of last contour = 0
Signed distance from Mirror/Surface to 0-index contour = .04
Contour spacing = 1
Surfaces to cut = ‘hull’
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<OK>

4 Look in the Offsets window. Note: this forward-most contour is very small —
barely, if at all, visible. To see it:

5 Zoom in on the bow.

6 Zoom to fit the Offsets image so you can see all the contours again.

7 Go back to the graphics window.

8 <F4> or Insert>Copy Last

Name = ‘xstern’
Mirror/Surface = *X=0
Index of first contour = 0
Index of last contour = 0
Signed distance from Mirror/Surface to 0-index contour = 30
Contour spacing = 1
Surfaces to cut = ‘hull’
<OK>

Saving offsets
1 Back in the Offsets window, right click in the Offsets window>Export OFE.

For filename, take the default (<Yes> to replace an existing file). 

This saves the offsets data as DEMO.OFE, a file which can be used as input to the 
AeroHydro Offset File Editor (OFE/x), Hydrostatics (HYDRO/x), Velocity
Prediction (AHVPP/x), and Slender Ship Resistance (SSR) programs.

Hydrostatics
1 Tools>Hydrostatics. (Note: this option is available only when you are in the 

Offsets window).

The hydrostatics dialog prompts for five input quantities:

Specific Weight is the specific weight of water. The default value is the specific 
weight of sea water:  64.0224 lbs/ft3 in the DEMO model’s ft-lb units.

Z c.g. is the vertical position of the center of gravity in the model’s coordinate 
system. This should really come from a summation of weights and vertical 
moments for the complete boat. The default value of 0 (zero) is a reasonable 
guess for most ballasted sailboat designs.

Sink and Trim together specify the position of the boat relative to the water 
surface. The default values of 0 (zero) use the Z = 0 plane for the waterplane.

Heel is rotation of the model about the X-axis (-180 to 180 degrees). Positive 
heel initially raises the starboard (positive-Y) side and lowers the port 
(negative-Y) side of the boat.

For now, just take the defaults offered for each of them.

MultiSurf opens a text window and displays the results. These begin with a station-
by-station tabulation of sectional quantities: X-position, immersed section area, 
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centroid of area, wetted girth, and waterplane width. Then there is a table that echoes 
the input quantities and gives about 25 computed results: wetted dimensions, 
displacement, center of buoyancy, center of flotation, wetted surface, initial stability, 
and several coefficients.

The coefficients and the % waterline positions of LCB and LCF are dimensionless, 
but the other quantities have units which are determined by your choice of Model 
Units.

For example, when your Model Units are Feet/Pounds and you give the specific 
weight in lbs/ft3, as in this example, volume will be in cubic feet, displacement in lbs, 
GM in feet, and righting moment per degree in ft-lbs. If the Model Units are Meters / 
Metric Tons and you give specific weight in tonnes/meter3, displacement will be in 
tonnes and righting moment per degree in tonne-meters.

You can save these text results by right clicking in the Hydrostatics window and 
choosing Save As Text; and you can print that file using Windows WordPad (or 
Notepad).

2 Close the model (don’t save changes).

For a more complex model:

3 Open SAILBOAT.ms2

4 View>Display>Offsets (no deck, no bottom).

Note how the station polylines automatically follow the exterior envelope of the keel, 
hull, deck, and cabin. Portions of surfaces that are enclosed by other surfaces are 
omitted - for example, the part of the hull enclosed by the keel, and the part of the 
deck enclosed by the cabin.

Close the model.

Skin Deduction by Offset Surfaces
One-off boat hulls, plugs, and prototypes are usually molded over a set of transverse 
frames or “mold frames”. Because the material of the hull — frames and planking, or 
core material and skins — as well as temporary mold materials such as ribbands and 
temporary core, intervene between the finished outer surface of the hull and the 
contours of the mold frames, the mold frames need to be undersized by a thickness 
deduction. In a typical male-molding process, the deduction would comprise the 
thicknesses of ribbands, plus core, plus outer skin. It is incorrect to make this a 
constant deduction in the transverse plane; this would not take into account the local 
bevel of the hull. The deduction needs to be taken perpendicular to the local hull 
surface.

The Offset Surface is the key to making frame patterns with thickness deduction. If a 
Single Offset is used, the Offset Surface will be parallel to its basis surface and a 
constant distance away from it. If this constant offset is equal to the required 
thickness deduction, sections cut on the Offset Surface will have the correct thickness 
deduction, including the appropriate allowance for bevel.

Hint: An Offset Surface will be smoother and more accurate if it has the same 
number of divisions as its basis surface in both u and v directions. 
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Let’s make patterns for the DEMO hull with a 2-ft. frame spacing and a skin 
deduction of 0.200 ft.

1 Open DEMO.

2 Select the hull surface. On this C-spline Lofted Surface, u is along the control 
curves and v is longitudinal. The normal orientation arrow shows that the 
positive normal direction is into the hull (you can see this better in the if you 
rotate the model), so we will need to use positive offset values. Back (or still) in 
the <Home> view:

3 >Offset Surface or Insert>Surface>Offset Surface

Name = ‘inside’
Surface = ‘hull’ (pre-selected)
Single Offset radio button
Offset = .2 Offsets are in the same units as the model, in this case, feet.
Display>Color = blue
Advanced>Divisions = 5x2, 5x4
<OK>

4 Edit the definition of ‘stations’ (red).

For Surfaces to cut, add ‘inside’ (<Ctrl>+click it in the drawing or the Entities 
Manager).

5 Clear the Selection Set.

Now you can see that each station contour 
is doubled. We are seeing each contour 
cutting both the original ‘hull’ and the 
Offset Surface ‘inside’. If you move (left 
arrow) over to Lon 40 or 50, you can see 
this even better (Fig. 26).

Next, we’ll set up 'stations' for the 2-ft 
spacing we want for the frames, and we’ll 
make those contours cut only the ‘inside’ 
surface:

Fig. 26

6 Edit ‘stations’ again.

Index of first contour = 0
Index of last contour = 14
Signed distance from Mirror/Surface to 0-index contour = 1
Contour spacing = 2
Surfaces to cut = ‘inside’ (either remove 'hull' from the Selection Set, or 
click on 'inside' to replace the current Selection Set with 'inside').
<OK>

7 Select ‘hull’ and hide it, so it doesn’t clutter up the picture.
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You may have noticed that the lower (u = 1) edge of the Offset Surface has a hollow 
appearance forward, near the forefoot. This is because of the large amount of twist in 
the hull surface in this area. Because of the twist, the edge of the Offset Surface winds 
up crossing over the centerline. The Offset Surface at the centerline is a smooth curve, 
though. To see this, let’s look at the Y = 0 buttock:

8 Create a Contours object parallel to the Y=0 plane:

Name = ‘buttock0’
Mirror/Surface = *Y=0
Index of first contour = 0
Index of last contour = 0
Signed distance from Mirror/Surface to 0-index contour = 0
Contour spacing = 1
Surfaces to cut = ‘inside’
Display>Color = dark cyan
<OK>

9 (<Y>) and Zoom In on the bow.

As you can see, the centerplane 
buttock is a smooth curve (Fig. 27). 
The part of the Offset Surface in 
negative-Y would not be used in 
making patterns.

10 Set Tools>Options, 
Performance, Model, Divisions 
multiplier to 4.

'MC1'

'buttock0'

edge of
Offset Surface

Fig. 27

We have increased the divisions to 40 by 80 on both surfaces (‘hull’ divisions = 10x1, 
20x1 multiplied by 4 = 40 by 80; ‘inside’ divisions = 5x2  5x4 multiplied by 4 = 40 by 
80). For this model, this is an appropriate number of divisions for making drawings 
that will be used for cutting actual parts, or for making N/C files).

11 Hide 'inside' and Show 'hull'.

12 View>Display>Ship Lines.  <OK> to accept defaults.

The body plan here can be captured as a 2D file.  Plotted full size, it would make the 
patterns required for mold frames.

We have been speaking as if the deduction is always positive. However, some boats 
are formed using “female” mold frames, where the deduction is negative, i.e., the 
mold frame is outside the hull and is oversize by a constant amount normal to the hull. 
This is easily accomplished using an Offset Surface that is outside the hull surface, in 
this case a negative value for the Single Offset.
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Occasionally a boat uses different thicknesses of core material in different parts of the 
hull. This can be handled by the following steps (assuming for this example that 
there are two core thicknesses): 

1 Create a snake ‘core_step’ on ‘hull’, along the line dividing the two thicknesses.

2 Make two SubSurfaces:  ‘lower’, from the portion of ‘hull’ below ‘core_step’, and 
‘upper’ from the portion above ‘core_step’.

3 Make two Offset Surfaces: one from ‘lower’ and one from ‘upper’, each with the 
required offset.    

4 Set surfaces to cut for the Contours to just the two Offset Surfaces, and cut 
sections as before.

Close the model (don’t save changes).

A Planar Sheerline
It has long been known to naval architects that achieving a pleasant 3D appearance 
of the sheerline (and other visually prominent lines) requires coordination between 
many views. It is much less widely known that the proper coordination can be stated 
as a simple geometric rule: besides being fair, the curve should lie in a single plane.

1 Open CLFT7X4A. The sheerline of this model has been faired in profile and plan 
views. Let’s take a look:

2 (<Y>) and Zoom to Fit. From this direction, the sheerline presents a concave 
curve.

3 Hide the hull surface (green).

4 Select the C-spline Curve ‘sheer’ and View>Display>Curvature Profile. The 
curvature profile for the sheer in this view shows all negative curvature. (Putting 
yourself in bug-mode may be the easiest way to understand how the curvature 
profile relates to the curve itself. So, imagine you are your favorite bug, walking 
on your screen in the direction of increasing t, along the ‘sheer’ curve (not the 
curvature profile display). As you walk, you are always curving to your right, 
which indicates negative curvature. (For more details on reading curvature 
profiles, see "Editing Models - Fairing Curves”).

5 Up arrow to Lat -40. From this direction, the sheerline presents a completely 
convex curve. The curvature profile shows this as all positive curvature (the bug 
is always curving to the left; Fig. 28). 

 Fig. 28
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The question is, what happens in between?

6 Down arrow to Lat -10.

In this view (like seeing the boat heeled 10 degrees away from us), the sheerline has 
an inflection point near midships; the curve is concave aft and convex forward. This 
is magnified for us in the curvature profile (Fig. 29). This is the “powderhorn” sheer 
which most designers wish to avoid.

 Fig. 29

7 Close the Curvature Profile.

Another way to visualize problems in the sheer is to look at foreshortened 
perspective views from bow or stern. First we’ll use inverting the Selection Set to get 
some extraneous lines out of the way:

8 Add the following objects to the Selection Set (which currently consists only of 
‘sheer’):

‘profile’, ‘MCA’, ‘MCD’, and ‘MCG’

9 or Show-Hide>Hide Unselected

10 <F5> (Symmetry Images).

11 (<X>) view.

12 Zoom to Fit (Fig. 30).

  Fig. 
30 Left, Fig.31 Right

13 Now use the shift-cursor keys to move your viewpoint around and watch 
the sheerline. In some positions you can get hairpin turns, tight loops, multiple 
inflection points, and other irregularities. Lat -5, Lon 175 looks especially 
squirrely (Fig. 31)

We will make some small adjustments to the sheerline control points, removing the 
powderhorn, then repeat these visualizations.

First, how far is the present sheerline from lying in a single plane?
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14 (Home view), (Point nametags) and Turn off Symmetry Images.

15 Select ‘sheer’.

16 or Show-Hide>Show Parents. This is the quick way to show ‘P11’, ‘P21’, 
‘P31’, ‘P41’, ‘P51’, ‘P61’, ‘P71’.

17 Insert>Plane

Name = ‘a0’
Type = 3 Point Plane
1st Point = 'P11'
2nd Point = 'P41'
3rd Point = 'P71'
Display>Color = red
<OK>

This creates a plane through these three points. The right-hand rule shows this plane 
has its positive normal direction downward, because of the order in which we took the 
points.

18 (<Y>).

19 Move to Lat -11 (Fig. 32). Now we are seeing the plane edge on. You can see that 
‘P21’ and ‘P31’ lie above the plane, and ‘P51’ and ‘P61’ lie below it.

Plane 'a0'

'sheer'  Fig. 32

20 Select ‘P61’, then add the plane ‘a0’ to the Selection Set — you get an 
unambiguous selection for the plane if you <Ctrl>+click it beyond the ends of the 
boat.

21 Tools>Measure>Clearance.

22 Repeat for ‘P51’, ‘P31’, ‘P21’.  For an easy method of selecting a point and the 

plane simultaneously, turn off Curves filters, ( ) and drag a box around each 
of the points in turn.  The plane will be selected with the point each time.

We found the following clearances:

‘P61’  +.114
‘P51’  +.069
‘P31’  -.050
‘P21’  -.048

23 Now click on the points in sequence to make the indicated adjustments:
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‘P61’ up .114 to Z = 2.124
‘P51’ up .069 to Z = 2.059
‘P31’ down .050 to Z = 2.290
‘P21’ down .048  to Z = 2.585 (Fig. 33)

'sheer' and Plane 'a0'

 Fig. 33

24 Select ‘sheer’ and View>Display>Curvature Profile again. (Don't forget to 
turn Curves filter back on.) 

 Fig. 34

In this view, the curvature profile (Fig. 34) shows us the sheer is still not quite 
straight. Why not? Well, clearance measured distances perpendicular to the plane, 
which is inclined; on the other hand, we moved the points vertically — so we’d 
expect some discrepancy.

The next step would be to run clearances again. Since you most likely have the hang 
of clearances, we’ll just share our results: 

‘P61’  +.002
‘P51’  +.001
‘P31’  -.001
‘P21’  -.001

which isn’t worth fussing about, so we won’t (fuss). [This should match our 
distribution file CLFT7X4B.MS2.]

This method utilizes an important C-spline property: If all the control points lie in a 
plane, then the entire curve does too.

25 Watch the Curvature Profile display as you move up and down in Latitude 
and you can see how the sheer can go from concave at Lat 0 (0 deg. heel) to 
convex at Lat -40 (40 deg. heel) without being a mixture of concave and convex at 
any intermediate heel: it changes all at once, passing through zero as your eye 
passes through the plane (the minor discrepancies noted above 
notwithstanding).

26 Close the Curvature Profile and Hide the plane and points.

27 Turn Symmetry Images on.
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28 Revisit the foreshortened perspective

views from near Lat 0, Lon 180. From all 
directions now (including Lat -5, Lon 175 -
Fig. 35), the “planarized” sheerline presents 
either a straight or simple parabolic 
projection — no loops, no kinks, no flat 
spots — pure grace and beauty!

Fig. 35

Alternative durably planar sheerline constructions
There are two ways a more durably planar sheerline could be accomplished for this 
model:

1 This is our recommended method. (We walked you through the previous 
method because it allowed us to introduce you to added program features.)

Start the design off by creating a Translation Surface ‘sheer_plane’, in the 
position of the 3 Point Plane ‘a0’. ‘P11’ could naturally be one corner of this 
Translation Surface, but ‘P21’, ‘P31’ ... ‘P71’ would be magnets on ‘sheer_plane’ 
instead of Points.

2 This one takes off from the example we walked you through:

Create four Projected Points, say ‘P21p’ ‘P31p’ ‘P51p’ ‘P61p’, from ‘P21’, ‘P31’, 
etc. projected on the plane ‘a0’. Then substitute ‘P21p’ as the first control point on 
‘MCB’, ‘P31p’ as the first point on ‘MCC’, etc. Also ‘sheer’ would then use ‘P11’, 
‘P21p’, ‘P31p’, ‘P41’, P51p’, ‘P61p’, ‘P71’ for its control points. Then you could 
drag ‘P21’, ‘P31’, etc. around to reshape the sheer to your heart’s content, and the 
curve would always lie in the plane ‘a0’.

Now, we’ll admit that on some boats you just can’t do a planar sheer. In motor yachts 
the sheer in plan view is often highly curved forward, providing flare and deck 
space, and nearly straight aft. For the sheer to lie in plane, the profile view would 
have to either be straight, or have this same curvature distribution — almost straight 
aft, curving rapidly toward the bow — not very appealing, at least for a concave 
sheer. Since motor yachts don’t heel over (much), you’re much more likely to see a 
horizontal projection, so in some sense the 3D properties of sheer and chines may be 
less critical than for sailing yachts. However, your motor yacht might be 
photographed from the air, or viewed from a high vantage point from almost any 
angle, or during a banking turn.

Note that this principle works equally well for a reverse (convex) sheer. The plane 
then slopes up and outboard rather than down and outboard.  

The planar sheer principle applies equally to other visually prominent lines: chines, 
guards, rubbing strakes, boottop, etc.

Close the model (don’t save changes).
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Cylindrical Transom
In yacht design, a transom is usually a portion of a cylinder, most often circular. 
When drafting lines, the conventional procedure is to fair the lines to a last transverse 
station near or just beyond the transom, then locate the intersection of the hull 
surface with the transom cylinder. Our preferred approach in MultiSurf is to create 
the cylindrical surface ‘transom_cyl’; create a snake ‘transom_edge’ on this surface; 
then use the snake for the last master curve on the hull. This approach has the 
advantage that the hull surface ends cleanly at the transom edge, with nothing extra 
to be trimmed off.

1 Open CylTran. This is a 3-master curve

C-spline Lofted hull derived from DEMO by 
replacing the last master curve with a snake 
on a cylinder (Fig. 36).

2 You may want to turn on various nametags, 
show and hide various parts of the model, 
and look from other viewpoints as you 
follow the discussions below.

Fig. 36

The transom cylinder
‘transom_cyl’ (is a Translation Surface made from an Arc ‘circle’ and a Line 
‘transom_cl’.  Since one of its basis curves is a line, the Translation Surface is a 
cylinder. To make it a circular cylinder, ‘a0’, the Plane the Arc lies in, is perpendicular 
to ‘transom_cl’. Here are the steps we used to make the cylinder:

1 Insert point ‘p0’ on the centerline.

2 Insert point 'p1' using 'p0' as its Point parent.  This point serves as the x-axis of 
our frame, sets the radius of the transom by serving as the center of the Arc and 
determines the rake of the transom.   We used polar coordinates and gave this 
point a lat of 16 (16 degree rake) and a rad (radius) of 8.

3 Insert point 'p2' using 'p0' as its Point parent.  Anywhere on the default frame's 
y-axis will do.

4 Insert Frame 'frame1' using 'p0', 'p1' and 'p2' as parents.

5 Insert Point 'p3' on 'frame1's z-axis and make a Line ‘transom_cl’ from ‘p0’ to 
‘p3’.  This line is perpendicular to 'frame1's xy-plane.

6 Insert Point 'p4' to be used as the Arc's end guide.  'p4' uses 'frame1' as its Frame 
parent and is placed on 'frame1's y-axis, dy greater than the widest part of the 
stern.

7 Insert the Arc using 'p0', 'p1' and 'p4' as its parents.  This puts the arc in the xy-
plane of 'frame1'.

8 Insert Translation Surface ‘transom_cyl’ from the line ‘transom_cl’ and the arc 
‘circle’.
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If you go to (<Shift+Y>) or (<Y>)view you can move 'p1' at will by 
dragging, or if you want more control you can change the lat and rad using the edit 
dialog and change the rake and radius of the transom.

The transom surface
‘m0’ to ‘m3’ are four magnets (red) on ‘transom_cyl’, and ‘transom_edge’ (magenta) 
is a B-spline Snake made from them. 

‘m4’ and ‘m5’ are two additional magnets on ‘transom_cyl, and ‘transom_top’ 
(magenta) is a B-spline Snake made from ‘m0’, ‘m5’ and ‘m4’. Here’s what we did:

1 Insert the magnets in their rough positions on ‘transom_cl’.

2 Insert the B-spline Snakes. (Or combine 1 and 2 and use Quick Spline mode).

3 Edit ‘hull’:  Control curves = ‘MC1’, ‘MC2’, and ‘transom_edge’.

4 Delete ‘MC3’, ‘P31’, ‘P32’, ‘P33’, and ‘P34’ as a group.

5 Adjust the locations of the magnets until the B-spline Snakes make the exact 
desired transom edge shapes.

6 Make a Line Snake, 'transom_ctr', using magnets 'm3' and 'm4' for 
supports.

7 Make a Trimmed Surface using 'transom_top', 'transom_edge' and 
'transom_ctr'

8 The final step is to hide 'transom_cyl' and see the beautiful result.

Close the model (don’t save changes).
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A Planing Powerboat
1 Open PLANE1.

2 or View>Nametags, Surface.  The surface names may be easier to see if you 

click for Wireframe view.

This is a planing powerboat model made from two C-spline Lofted Surfaces, 
‘topside’ and ‘bottom’, and one narrow Ruled Surface, ‘flat’. Each of the C-spline 
Lofted Surfaces has 5 control curves. Except for the bow, all the control curves are 3-

point B-spline Curves.  Return to Shaded view, .

3 and (Surface nametags off and Curve nametags on).

'sheer'

'outer'

'inner'

'profile'

Fig. 37

The model includes 4 longitudinal C-spline Curves (yellow): ‘sheer’, ‘outer’, ‘inner’, 
and ‘profile’. The three component surfaces join accurately along their common 
edges because ‘outer’ is identical to the last lofting spline u = 1 on ‘topside’, and 
‘inner’ is identical to the first lofting spline u = 0 on ‘bottom’.

Here are some considerations in the construction of this model. First, to get the 
general character of the longitudinal curves, which (typical of planing powerboats) 
are highly curved forward and only slightly curved or even straight aft, with cubic 
splines requires a minimum of 5 control curves: the splines need to have a knot about 
midships, and it takes 5 points for a C-spline Curve to have one knot.

4 (<Z>) view

5 View>Display>Curvature Profile of ‘sheer’, then ‘outer’. 

6 (<Y>) view and look at the curvature profile for ‘outer’ in this view.

7 View Curvature Profile of ‘sheer’, then ‘profile’ (Fig. 38).
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Fig. 38

In each case the profile is V-shaped, showing an abrupt change of slope at the single 
knot amidships. None of the curves have inflection points. ‘profile’ is accurately 
straight from the third master curve aft. The straightness was accomplished by: 

1 making sure ‘p36’, ‘p46’, and ‘p56’ were on a straight line

and
2 making small adjustments in the Z-coordinate of ‘p26’ (at the bottom of the 

second control curve, 'C2') until the curvature of ‘profile’ vanished aft of 
midships, according to the curvature profile display

To see how this works:

8 and (Point nametags on and Curve nametags off).

9 Click ‘p26’.

10 Lower dz by .02 to -1.000. The curvature profile for ‘profile’ updates, showing a 
small amount of positive curvature (concave downwards) aft of the third master 
curve, and a small amount of negative curvature (concave upwards) at the stern.

11 In the curvature profile window, click the up arrow of the scroll bar a few 
times to zoom in on the display (Fig. 39).

Fig. 39

12 Edit ‘p26’ again.  Raise dz by .06 to -0.940.

13 In the Curvature Profile window, drag the box in the scroll bar down to the 
bottom to see the entire range of the profile. Now the pattern is reversed: it is 
slightly negative aft of the third master curve, and slightly positive at the stern.

14 Zoom in on the Curvature Profile display a bit again (Fig. 40).
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Fig. 40

15 Undo twice to restore ‘p26’ to its original location. This restores the aft end of the 
curve to straight.

What you’ve been seeing is typical behavior for a C-spline Curve. To get it to run 
accurately straight over some interval, there has to be a knot at the end of the 
interval, and any control points inside the interval need to be on a straight line; then 
you have to fiddle with the position of the next control point outside the interval to 
remove any wave or oscillation between control points.

Close the model (don’t save changes).

Preference for Degree-3 B-spline Curve Control Curves
The higher the order of a spline, the smoother the curve, but the less tightly it is 
related to its control points. A Degree-1 spline can have abrupt changes 
(discontinuities) of slope; a Degree-2 spline can have abrupt changes in curvature. A 
Degree-3 spline must have continuous curvature — i.e. with no abrupt changes. 

For many years, for our previous hull design program, Fairline/2, we promoted use 
of Degree-2 splines for control curves. Our preference lay with Degree-2 as having 
“sufficient” smoothness for transverse sections, while being very transparently 
connected to the control points by the midpoint tangency property. However, for 
several years we have been developing a growing appreciation for Degree-3 master 
curves, and now prefer them and use them for most hull design purposes.

The experience leading to this preference is mostly subjective. We have been 
involved in many hundreds of fitting and lofting jobs during these years. During the 
fitting process, we apply various fairness tests, especially normal curvature profiling. 
We have encountered a number of cases where, even though the fitted surface passes 
all objective fairness tests we can apply, it still doesn’t look “right”. Often the 
problem would show up in a body plan with lots of stations. In other cases there 
would be some waterlines or buttocks that looked somehow indefinably unhappy. In 
every such case, when we converted the master curves to Degree-3, we became 
happier with the lines.

As an exercise in converting from Degree-2 to Degree-3 control curves, we will load 
the DEMO hull (three Degree-2 control curves), and convert its control curves one by 
one to Degree-3.

1 Open DEMO.

2 (<X>) view and Zoom to Fit.

3 (Curve nametags).
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4 Select ‘MC3’.

5 View its Curvature Profile (Fig. 41).

Fig. 41

As expected from the general character of the control curve, the curvature is most 
intense near the tight turn of the bilge, diminishing smoothly in both directions. 
However, right at the knot there is a discontinuity in curvature — an abrupt change 
by approximately a factor of two. This discontinuous curvature profile is typical of 
type-2 splines.

Let’s capture a copy of the existing control curves:

6 With ‘MC3’ still selected, add ‘MC1’, and ‘MC2’ to the Selection Set
(<Ctrl>+clicks).

7 File>Export 3D>3DA wireframe. 

In the options dialog, choose to export the Selection Set Only; <OK>.
Give the filename DEMOMCS (<Yes> to replace existing file).

And now we’ll read them back in for comparison:

8 Insert>WireFrame 

Name = ‘oldmcs’
Frame /Point = '*'
Filename = demomcs
Display>Color = uncheck "Use 3DA colors" and make Color blue
<OK>

9 Edit ‘MC3’

Degree = 3.
<OK>

In order to make it easier to see what is happening:

10 Add ‘MC1’, ‘MC2’, and the wireframe (‘oldmcs’) to the Selection Set.

11 (Show-Hide>Hide Unselected)(Fig. 42).

Now you can see the shapes of both the wireframe copy of the original Degree-2 
master curve (blue) and the new Degree-3 ‘MC3’ (cyan). ‘MC3’ is much less tightly 
curved, because of the relative “stiffness” of a Degree-3 spline. We will reshape 
‘MC3’ to approximately its old shape, by moving ‘P32’ and ‘P33’.
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12 , and (Show Points, Point nametags, and Orthogonal Dragging 
on).

13 Drag ‘P32’ down about 0.6 ft. (to about Z = 0.72).

14 Now drag ‘P33’ outboard about 0.65 ft. (to about Y = 3.15)

 

Fig. 42 (Left) and 43 (Right)

This produces a Degree-3 curve that matches the old shape pretty well (Fig. 43). You 
can make some more adjustments to get it closer. We ended up at:

‘P32’     30.000   3.500   0.723
‘P33’     30.000   3.150  0.120

Notice that the curvature profile of ‘MC3’ has become much smoother; still showing 
the most intense curvature in the middle, but now a gentle dish-bottomed valley 
instead of a crevasse (Fig. 44).

Fig. 44

Now repeat the process with ‘MC2’:

15 Select ‘MC2’ and View its Curvature Profile (Fig. 45).

Fig. 45
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16 Change Degree for ‘MC2’ to 3.

17 Drag ‘P22’ down about 0.6 ft and a little outboard (to about Y = 5.08, Z = 0.01).

18 Drag ‘P23’ outboard about 1.0 ft. (to about Y = 4.62)

We ended up at:

‘P22’     15.000   5.086   0.014
‘P23’     15.000   4.620   -0.870

Again, the Curvature Profile is much smoother (Fig. 46).

Fig. 46

And similarly with ‘MC1’:

19 Switch to (<Y>) view and Zoom to Fit so you can find ‘MC1’.

20 Select ‘MC1’ and View its Curvature Profile (Fig. 47).

21 Zoom in on 'MC1'

Fig. 47

22 Change to Degree 3.
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23 Pull ‘P12’ toward ‘P13’, and pull ‘P13’  forward a little and down a hair to tighten 
the curve, ending up at:

‘P12’     1.659   0.000   -0.011
‘P13’     2.003   0.000   -0.727 (Fig. 48).

Fig. 48

24 To make sure we’re all together at this point, close DEMO without saving 
changes and open the sample file DEMOTYP3.

25 Re-open DEMO and compare the two models.

Now as far as the screen displays go, you probably can’t see any significant change in 
the model shape. But if you plotted out lines from DEMO and from DEMOTYP3, we 
suspect you would prefer DEMOTYP3, perhaps for reasons that you couldn’t put 
your finger on. As we’ve said, that at least is our experience with Degree-2 vs. 
Degree-3 control curves.

The End! As you’ve seen, MultiSurf provides a wide variety of entities and tools that 
allow you virtually unlimited flexibility to create and modify designs.

File>Exit (do not save changes).
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Procedural Surface Tutorial

Overview

We feel this is an important technique for creating free form shapes. A single 
Procedural Surface is used to bridge between two profile curves. Because of the 
different shape of the two profiles, it is necessary that the swept shape be free to scale 
to a proportional shape given the differences in span. This technique can be used 
when two or more profiles are given and the surface is expected to match the vertical 
and horizontal profiles exactly. There is provision for interior surface manipulation 
for any other profile matching if needed.

The model will be put together in such a way as to be dependent on the profile 
sketches. When we change the profile, the surface updates with no further editing 
needed.

Getting Started - The Upper Profile

Open a new .ms2. SolidWorks Integration users should use the stand-alone version 
of MultiSurf.

If working with SolidWorks and MultiSurf, go to SurfaceWorks/Modeler.

This first step is to insure users of MultiSurf stand-alone and the integrated version 
are working in the same coordinate system. SolidWorks has a left-handed system 
and MultiSurf Solo is right-handed. This is a good opportunity to practice relations 
to Frames and the use of RPY Frame “handedness”.

1. Insert/Point at 0,0,0. 

2. Insert Frame/RPY Frame using the above point as a parent.

3. Select the RPY Frame and create a Point at 0,0,36. 

Rename this Point  ‘Center’.
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4. Select the RPY Frame and point ‘Center’ and press <F4> on the keyboard. Locate this point at 
48,0,0.

Rename this Point  ‘Start’.

5. Select the RPY Frame and point ‘Center’ and press <F4> on the keyboard. Locate this point at 
0,12,0.

Rename this Point ‘Guide’.

6. Select the points ‘Start, ‘Center’, and ‘Guide’ in that order

7. Insert/Curve        /Arc

From the drop down list you want to choose Semi-Circle made from the pre-selected 
points. Start, Center and Guide

<OK>

As you can see by your model and the image, the spa will be round on top and we 
are modeling one-half, which will be mirrored at a later time.
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The Lower Profile

The Lower profile will be brought in as a component.

1. Press <z> to change the view.

2. With nothing in the Selection Set, change to Quick Point mode. 

With the mouse drop a point to represent one corner of the rectangular bottom of the
spa. The image below is an example.

3. With the new point selected go to File/Component/Load. Browse to the MultiSurf Tutorial 
folder and choose the component Half_FilletedLoop.mc2. <OK> <OK>

4. From the Entity Manager, note a Variable has been brought in to the model with the Component

This variable controls the radius of the corner fillets. Feel free to edit the radius value 
to observe different fillet shapes.
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Creating the Cross-section - Construction Entities
The following steps can be done from most views. Feel free to rotate the model to get a feel for what 
has been accomplished so far.

1. Select the Top Profile semi-circle ‘curve1’.

Feel free to re-name this curve, or any other object, to help in identifying objects.

2. With Quick Points, place a point on the arc at an arbitrary location. Of course, a point on a curve 
is a Bead.

3. With that Bead in the Selection Set, Ctrl-Select the PolyCurve which represents the Lower Profile

4. Insert/Bead   Copy Bead

A Copy Bead is Inserted at the same t location as the parent bead, but on the new curve. Drag the 
bead on the Upper Profile and see the Copy bead move with it.

Side Trip – Orientation
1. Press <O> as a shortcut to Tools/Options

2. Under the sub-heading “Auto-Orientation” choose “All Selected Entities <OK>

3. Change to the <z> view

4. Select the Upper Profile and the PolyCurve, which is the Lower Profile.

Take note of the orientation arrow on both curves. Are they both pointing in the 
same direction? They need to be so our cross section travels in the same direction on 
both curves. If the arrows are pointing in different directions, the easiest fix is to 
move the one free corner of the lower corner to the opposite hemisphere. If the point 
is in –X space, change it to + or visa versa.
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Back to the Cross-Section
5. Select the Bead on the Upper Profile

6. Insert Point/Projected Point.    Choose *Z=0 as the mirror plane from the Entity Manager.

With the 2 beads and the projected point 
we have 3 corners of a rectangle. The best 
way to complete the rectangle is with a 
Copy Point (NEW!). In creating a Copy 
Point you select a point you want to copy, 
a location where you will copy it from (A 
Frame. A point can act as a frame) and a 
frame you will copy it to. A mite confusing, 
but this should clear up after the next step.

7. The Copy Bead is the point we want to copy. Select the Copy Bead.

8. Ctrl-Select the Projected Point (Frame1) and the Top Profile Bead (Frame2).

9. Insert/Point/Copy Point

Name ‘CP1’

Color: Yellow

10. Insert 2 Lines. One between the bottom two points and one between the top two points.

11. Select the 2 Lines and create a Ruled Surface between them
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Name ‘S1’

Divisions 2X1, 2X1

Drag the Bead on the Top Profile to see our construction entities move as one.

Creating the Cross-section (almost)

Let’s clear up the view to avoid confusion and ambiguous selections.

Select the construction surface ‘S1’.

Show-Hide/Hide Unselected or click the toolbar icon.  

Creating the Cross-section

1. Select ‘S1’

2. Insert/Snake/Edge Snake
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The intention is to have this edge snake along the bottom of the surface. Depending on the order you 
chose the parent curves, it will either be the v=0 edge or the v=1 edge. Select your surface, look at the 
orientation and choose the proper snake from the drop down list. Extra-credit if your first choice is 
correct. Positive or negative orientation is not important at this time.

3. With the Edge Snake in the selection set press <q> for Quick Point Mode.

The Snake was in the selection set. In Quick Point Mode we will create Rings with every click.

4. With the cursor near the Origin, click one Ring. Move the cursor over the snake and click another. 

5. Right-click/Select or <Esc>

The first Ring was placed at the end of the snake or the corner of the surface (the start of our cross-
section). The second ring ensures tangency with the bottom plane.

6. Select ‘S1’

7. Insert/Snake/Edge Snake

This snake should be perpendicular to the first on the edge opposite from the origin. 
Did you get it on the first try?
The reason for this snake is to have a support for the point at the opposite corner of the cross section 
shape. Our shape will be a snake on the surface using magnets for supports. It is preferable to use a 
ring in the corner, which has more constraint, than a magnet with its 2 degrees of freedom.

8. Select Surface ‘S1’ and Toggle to Quick Spline Mode  <s>.

9. Start at the inner bottom corner, the cursor will change to show you are hovering over a ring at the 
corner of the surface. Click, release and move to the Ring on the Edge Snake.

10. Click and release, continue dropping magnets and drawing out a B-Spline Snake. Now is your time 
to be creative. Draw the Cross-section of a hot tub seat. End at the opposite corner by double-clicking 
the mouse.

11. Double Click to end the Spline.

Some notes on using Quick Splines: The trickiest part of using Quick Splines 
is ending them. If the double-click is hesitant or does not register to the computer as 
a double-click, another point could be made at the same location. The spline could be 
ended there (with co-incident points) or it may continue to another place. When the 
spline is ended, it is placed in the Selection Set, where its properties can be viewed. If 
there are any doubts, it’s a good idea to review the set of parent points.

The Cross-Section Curve: The example, below-left, shows a reasonable cross-section curve 
for a hot tub. Of course it is a free-hand sketch and may not be suitable if strict dimensions are to be 
followed. It is quite possible sketched geometry, from another system needs to be used as a cross 
section. Here is a quick breakdown of the steps:

1. Import the cross-section from SolidWorks, IGES, or DXF



Procedural Surface Tutorial Finishing up

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  156

2. Create a rectangular surface in the plane of the cross section. Two of the opposite corners should be the 
ends of the cross-section curve. (See below)

3. Make a PolyCurve from the cross-section elements.
4. Project the PolyCurve onto the planar surface. 
5. In another part of the model create the top and bottom profile curves. They might be imported as well.
6. Create the same movable surface as we did in the above exercise.
7. Place a Copy Snake on the movable surface based on the projected snake on the stationary surface.
8. Confusing? We hope not. If so, please give us a call.

The image, below-right, shows one modification. Between 2 parent magnets a line snake (yellow) was 
inserted. On the snake 2 Rings (blue) were placed with Quick Points. Tools/Adopt Children was used 
to replace the old magnet parents with the rings. This is to create a durably straight section in our B-
Spline Snake.

Finishing up

1. Show-Hide/Show All and View/Modify/Zoom to Fit or     and <f>.        

2. Drag the Bead on the upper profile. The whole construction should move along.

3. Select the cross-section curve and the moving bead on the top profile.

4. Insert Surface/Procedural Surface

Name Spa

<OK>
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Looks good! Just some final thoughts and we’re done. The cross-section curve 
divisions should be changed to 8X16. Select the Spa surface and see how the 
orientation falls. The u direction is in the direction of the sweep. And the v direction 
follows the cross-section. It would be our suggestion to change the u divisions of that 
surface to 8X8 and to match the divisions of the cross-section curve in the v direction 
at 8X16.

There is plenty more to do before anyone gets wet, but the hard part is done with this 
surface.
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Working with Components

Introduction
A MultiSurf component is a group of objects, captured in a special file, which can be 
imported into a MultiSurf model as a group, in a single operation 
(File>Component>Load). The component objects usually have dependency 
relationships amongst themselves, which are maintained intact during the 
component load. Further, the component objects can have dependencies on other 
objects not included in the component; these dependencies are transferred to existing 
objects in your model. This allows the component to adapt itself automatically to the 
existing geometry of your model, and to become a full participant in its dependency 
structure.  Once in your model, the component can be scaled, repositioned, edited 
and modified just like any other MultiSurf entity, to accommodate your specific 
requirements and preferences.

MultiSurf components are a powerful tool because they allow us to take chunks of 
geometry from one model and put them into other models, without having to 
construct them object-by-object. In this tutorial we’ll guide you through saving and 
loading a number of components to create a fairly detailed sailboat model — about 
175 objects.  Only a couple of these will be made using the Insert menu!

There is only one significant issue in saving a component file:

Choosing the right set of objects to make up the component. We’ll demonstrate 
several techniques for planning and managing this selection.

There are three main issues that need to be addressed in loading a component:

1 Parents resolution. We have to supply suitable parent objects in our model to 
satisfy the dependency requirements of the component.

2 Names resolution. We have to adjust the names of the component objects so that 
they don’t conflict with names of any objects already in the model.

3 Assigning a component name.  Every component must have a name to 
accommodate the listing in the Entity Manager

4 Orientation of Parents. When a component attaches to curves or surfaces in our 
model, the t or u,v orientation of the new support often needs to be the same as 
that of the component’s original Parents.

Each of these issues will be addressed in one or more situations as we go through the 
exercises of this tutorial.
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If at any time what you see doesn’t match what we are saying, just back up to the 
most recent place where we had you open a specific .MS2 file and proceed anew (you 
may have done something as simple as skipping a line in the text), or use an 
intermediate distribution file (see “MultiSurf Tutorials: Introduction - Taking a 
break”). The intermediate .MS2 files for "Working With Components" live in the 
MultiSurf \Tutorials folder.

“MultiSurf Tutorials: Introduction” contains information about taking a break, what 
to do if your screen doesn’t match our instructions, basic terminology, typeface and 
symbol conventions, and troubleshooting.

When you Save, Save As or Export files in this tutorial, you may get a “Replace 
existing file?” query. If you do, it just means someone has already run the tutorial 
and saved a file under that name. Go ahead and replace the file.

Let’s go!

The beginning model

MultiSurf for SolidWorks Users
When MultiSurf is integrated with SolidWorks, the component feature operates  the
same as detailed in this exercise. For this Tutorial we ask that you run MultiSurf in 
the Stand-alone mode for simplicity's sake.

In MultiSurf
1 File>Open>3MCS.MS2 from the \MultiSurf \Tutorials folder. This is a set of 3 

lofting curves. 

2 Switch to <y> view for a moment to see how they are different from the DEMO 
Master curves (Fig. 1):

• The transom slants and ends below the design waterline (DWL).

• The bow is rounder.

Fig. 1

3 Switch back to <Home> view.

Check program settings
Before we go any further, let’s all get together on program settings. This is what you 
should have:



Working with Components The beginning model

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  161

On the View menu:

Status Bar should be ON (preceded by a checkmark; to turn an option on, 
simply click on the menu item or if it has a box next to it click on the box).

All Toolbars should be ON.  To check this, click on Toolbars.  The resulting list 
should have all of its boxes checked.

On the Tools>Options, General tab:

Set Rotation Constraint to Z axis vertical mode

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

A few memory aids
We assume that you have been following the tutorials in order and that by now you 
are familiar with using the settings, menu choices, and toolbar buttons, and we will 
direct you to them less frequently than we did in the earlier tutorials. We encourage 
you to use them as you see fit as we move along. Here’s a little collection of 
reminders, just in case:

To select an entity in the drawing, click it. If your choice is ambiguous (more 
than one entity is in the center box of the cursor), you will need to answer the 
Which Entity? dialog.

To add an entity to the Selection Set, <Ctrl>+click it.

To remove an entity from the Selection Set, <Ctrl>+click it.

To clear the Selection Set, click or click in the model background.. 

To Edit>Definition of an entity, you can double-click it. If it is an ambiguous 

selection, you can select it and use (or use Edit>Definition from the menus).

The nametag buttons (or View>Nametags) show you the names of selected 
classes of entities.

Filters are very useful tools, especially when selecting from the Available 
Entities list in the Selection Set window and in more complex models consisting 
of many entities. If all the class filters are on and you want to filter just for points, 

you can click the Points Filter off, then click Invert Filters .

Zoom to Fit ( or <F>) sizes the view to fit the screen and center the screen 

image. You can also use the center mouse wheel, <PgUp>) and <PgDn>) or 
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and click and move the mouse to Zoom In and Out and to Zoom to 
Selection.

And don’t forget center-mouse-button dragging and the arrow keys, which let 
you take a walk around your model and admire it from all sides.

Hull skin and contours
Back to our boat: the first thing we’ll add is a component that skins these 3 master 
curves.

1 First, select the 3 master curves in order (click, <Ctrl>+click, <Ctrl>+click), 
bow to stern (right to left in this view) — we’re actually preselecting them as 
Parents for the component we will load. 

2 File>Component>Load.

3 In the Load component dialog, pick CLFTHULL.MC2 from the \MultiSurf 
\Tutorials folder.

4 In the Resolving Parents dialog, note the message “Component consists of 3 
objects. Required Parents ( 3)”.  In the big list box, the Parents are filled in 
because we preselected the master curves:

If any of these is not correct, highlight the incorrect parent (click it), then choose 
the correct parent from the Available Parents list box (double-click; or highlight 
then click the <Select ^> button).

5 <OK> to the Resolving Parents dialog.
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6 In the Resolving Names dialog, no name conflicts are indicated, but a component 
name is required, click <OK>.

Fig. 2

Now we have a hull with stations and a waterline (Fig. 2). The component we added 
was actually 3 objects taken straight out of the DEMO model by saving them as a 
component:

CloftSurf ‘hull’

Xcontours ‘stations’
Zcontours ‘waterlines’

In the original model, DEMO.MS2, the group of component objects depended on 
some objects not in the group; namely, ‘hull’ depended on three master curves. When 
the component was made, we disconnected it from these three Parents. So when we 
load this component, the connection to three Parents needs to be reestablished. The 
component knows its Parents were three curves, so in the Parents Resolution dialog 
MultiSurf only allowed us to select objects that can serve as a curve: that is, a point, a 
line, a curve or a snake. 

Deck
Let’s add a deck. We happen to have one that we saved as a component from a 
racing yacht.

1 Rotate the model so you can see the top of the hull.
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We will need a support for the deck component; the hull is already preselected, so:

2 File>Component>Load>DECK1.MC2 (from \MultiSurf \Tutorials).

3 In the Resolving Parents dialog, “CloftSurf hull” should be filled in for the 
required surface support (if it isn’t, select it now from Available Parents list box); 
<OK>.

4 In the Resolving Names dialog, no name conflicts are indicated but a component 
name of “Hull” is needed,  then click <OK>.  

While the whole deck is still selected, let’s put the entire component on its own layer, 
which can have several advantages. For one thing, it makes it easy to hide the entire 
component if we want to clear out the drawing while working on some other part of 
the model.

5 The Property Manager heading changes to Multiple Edit, change layer
to 1.

Although the component consists of 8 objects, only the final one, surface ‘deck’, is 
visible (Fig. 3). This is because the other 7 objects are all hidden in the component file.

 Fig. 3

This is a crowned deck made from an Arc Lofted Surface. It attaches to the 
supporting surface through an Edge Snake, the first generation parent of the 
component.  This deck component would fit on any hull, as long as the u,v 
orientation of the surface to which it is attached (in this case, the hull) is the same as 
for the DEMO hull surface, i.e. u from sheer to keel, v from bow to stern. To see this,

7 Select ‘hull’ and look at its orientation marks.

8 or Edit>Show>All to see the deck master curves.

9 to turn on Curve Nametags.

The 3 master curves for ‘deck’ are: the EdgeSnake ‘n0’, the RelCurve ‘c0’, and the 
ProjCurve ‘c1’.

10 or Edit>Undo to hide the deck support objects (and keep the picture less 
cluttered).

11 Turn off the nametags as well.

12 Expand the “Components” heading in the Entity Manager and the two added 
components can be seen. From here they can be re-ordered, deleted, selected, 
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shown, hidden, made internal, and made current. Use the right click button to 
access the context sensitive menu for these choices.

13 File>Save As>COMPONENTBOAT.MS2 (in the \MultiSurf \Tutorials folder).  
[This should match our distribution model COMPBT1.MS2.]

Cabin

Cabin from 2CABINS.MS2
Now for a cabin. There’s a nice one in 2CABINS. Let’s just make a component of it 
and slap it right on our deck. 

Saving the cabin component
1 Open 2CABINS.MS2 in the \MultiSurf \Tutorials (leave COMPONENTBOAT 

open as well).

In order to save a component, we select the objects that will be in it. We could select 
them one by one, until we (hopefully) had them all, but that would be tedious. Yes, 
there is a better way. From Tutorial 1, you know that you can move the entire cabin 
by dragging just one point. So let’s select that point, then add all the generations of 
objects that depend on it (that is, all the “direct” or “first generation” dependents of 
‘r0’, plus all their direct dependents, plus all their direct dependents, etc.). MultiSurf
has a menu option that makes this easy to do.

2 to turn on Point Nametags.

3 Select ‘r0’ (white, along the centerline where the front end of the cabin crosses 
it).

4 Select>Children>All Generations.  MultiSurf adds 19 objects to the Selection 
Set.

Now let’s check in the other direction: Parents.

5 Scroll down to the bottom of the Selection Set Manager and notice that 'rp1' is the 
last entity in the Selection Set.

6 or Select>Parents>1st Generation.  One entity, the Edge Snake ‘n0’, was 
added to the Selection Set.  This is the Parent for ’r0’. We’d like this component to 
attach to the deck in our component model, so let’s keep ‘n0’ in our selection of 
entities to include in the component.
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7 or Select>Parents>1st Generation again. Now C-spline Lofted Surface 
‘deck’ has been added. We don’t want the deck in our component (we want the 
component to attach to another deck), so click on 'deck' in the Selection Set 
Manager and click to remove it from the Selection Set.

We have now collected in the Selection Set all the objects we want for our 
component. Time to save it!

8 File>Component>Save or Alt + <S>

9 The Component Save dialog says the component will consist of 21 objects, and 
needs one parent. Type in the ID message cabin; <OK>.

10 Give it the filename COMPONENTCABIN.MC2 (you don’t need to type in the 
.MC2 extension), and put it in the \MultiSurf \Tutorials folder.

Loading the cabin component into the tutorial model
Now let’s put the cabin on our deck:

1 Activate the COMPONENTBOAT wireframe window (click in it or use 
Window>componentboat.MS2).

2 Preselect ‘deck’.

3 File>Component>Load>COMPONENTCABIN.MC2.

4 In the Resolving Parents dialog, be sure “Arc Lofted Surface deck” is selected as 
the parent; <OK>.

5 This time, the Resolving Names dialog reports 3 name conflicts. In the prefix 
field, type  Cabin  then click <OK>.  MultiSurf will add the prefix 'Cabin.' to the 
names of all the component objects being loaded. ‘Cabin’ will also be the name of 
the component in the Entity Manager.

 Fig. 4

Oops! that doesn’t look like the cabin in 2CABINS.MS2 (Fig. 4). What’s going on?! 
Quite simply, we’ve just done a demonstration that “any ol’ cabin” doesn’t always 
do what you want. Why not? Because not only do component support objects (here 
the deck) have to be appropriate kinds of objects (in this case a surface); but they 
must also have the appropriate orientation. Let’s look at this more closely:

6 Activate the 2CABINS window.

7 Select the deck. The orientation marks show v running from bow to stern (and 
a circle at the bow indicating that the u axis is at the bow).  The Edge Snake ‘n0’ 
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to which the cabin attaches runs along the u=1 edge of the surface (the 
centerline). 

8 Now go back to COMPONENTBOAT.MS2.

9 Select the deck. The orientation marks show u running from bow to stern (and 
v at the bow). When we plunk our cabin-attached-to-Edge Snake component on 
this deck, the Edge Snake, runs as specified along the u=1 edge of the deck 
surface, but unfortunately in this model this is the aft edge of the deck, so this 
cabin component doesn’t work.

10 or Edit>Undo to get rid of this cabin component.

Cabin from CRUISE5.MS2
We need a different cabin; one that will work the way we want! We know what to 
check for now.

Saving the new cabin component
1 Open CRUISE5.MS2 from the \MultiSurf \Tutorials folder. The cabin on this 

cruiser is constructed similarly to the one in 2CABINS: all of the cabin depends 
on a single Ring and the Ring lies on an Edge Snake that runs along the center of 
the deck. But let’s look at the orientation of deck surface to which it attaches.

2 Select the deck. u runs from bow to stern (and v is at the bow) and the Edge 
Snake runs along the v=1 edge which is what we need. Good! Let’s make a 
component!

3 Select Ring ‘cr0’ (white).

4 Click (the Select Children icon) numerous times until it is clear that no 
items are being added to the Selection Set. This is the same as Select>Children> 
All Generations that we used before.

Now we need to check the Parents:

5 twice (or Select>Parents>1st Generation twice).  The second selection 
adds the Arc Lofted Surface ‘ddeck’, which we don’t want, so remove the deck 
surface from the Selection Set.

We have all we need for a cabin:

6 File>Component>Save.

7 The Component Save dialog says the component consists of 21 objects, and needs 
one support. Type in the ID message cabin; <OK>.

8 Give it the filename COMPONENTCABIN2.MC2 (you don’t need to type in the 
.MC2 extension), and put it in the \MultiSurf \Tutorials folder. 
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Loading the new cabin into the tutorial model
Now that we’ve captured this cabin, we can insert it into any model that has the 
same orientation for its deck surface. Let’s put it into our tutorial model.

1 Back in COMPONENTBOAT, pre-select the deck.

2 File>Component>Load>COMPONENTCABIN2.MC2.

3 In the Resolving Parents dialog, “Arc Lofted Surface deck” should be the 
support; <OK>.

4 In the Resolving Names dialog, no name conflicts are indicated, so click <OK>
after we add the name ‘Cabin’.  (Why no name conflicts here, when there were 
name conflicts with our other cabin component? The cabin objects in 
CRUISE5.MS2 have different names than those in 2CABINS.MS2. In fact, all the 
CRUISE5 cabin objects have names that begin with “ c “ (for cabin); you can turn 
on nametags to see).

5 In the Property Manager, change layer to 2.

6 Clear the Selection Set.

This cabin has all the same dependency relationships it had in CRUISE5 (and they 
are the same as those in 2CABINS; what’s different is the deck’s orientation). To 
illustrate, let’s move the cabin forward a foot or so before we go ahead.

7 Drag ring ‘Cabin.cr0’ forward to t = 0.34 (Fig. 5)  [This should match our 
distribution model COMPBT2.MS2.]

 Fig. 5

8 Close 2CABINS and CRUISE5 (do not save changes, if any).

Keel
Now let’s add a keel. We’ll use one that is an already-made component distributed 
with MultiSurf . It attaches directly to the hull. One thing you need to know about 
this keel — it comes off a boat whose canoe body is less deep than that of our 
Component boat. To compensate, we can shorten the keel after we load it (we’ll scale 
it by a factor of 0.9 in Z).

Maybe before slapping another component onto the boat, you would like to take a 
look first to make sure we are suggesting the right thing. You can open a component 
file just like other files:

1 or File>Open.
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2 In the Open dialog box, change “Files of type” to All Files (*.*) which enables 
you to open component files (with the extension .MC2).

3 Pick KEEL1.MC2 which we are going to use next (also in \MultiSurf \ Tutorials 
folder).

4 <OK> to the warning message.

Rotating the model will show you that this looks something like a keel.

We started our model with three master curves, but you can actually start building a 
model from a component file, adding other objects or other components to it 
(although a keel might not be the place to start!). To do this, you would File>Save As 
to save the component (plus any additions or edits) as a model file. Or, if you just 
wanted to make a change to the component file, you could edit it, reselect the 
component objects, and then File>Component>Save it again. But we’re already well 
on our way with our model, so we won’t do any of that now; we’ll just put this keel 
on our hull.

5 Close the component file.

6 Preselect the hull.

7 File>Component>Load>KEEL1.MC2.
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8 In the Resolving Parents dialog:

“C-spline Lofted Surface hull” should be the support listed.

<OK>

9 There are no name conflicts in the Resolving Names, but you will need the prefix  
Keel; <OK> (see Fig. 6, in Rudder section).

10 While the component is still in the Selection Set, go to Edit>Transform>Scale.  
Make sure the Only transformable entities in the selection set radio button is 
set, then type .9 in the Transform factor for Z box.  Click <OK> to the Non-
Transformable Entities box.

11 in the Property Manager, change layer = 3; <OK>.

12 Clear the Selection Set.

Rudder
Now for a rudder.

Saving the rudder component
1 Open SAILBOAT.MS2 from the \MultiSurf \Tutorials folder).

2 Zoom in on the rudder.

This rudder actually has two surfaces, the main foil surface and the tip. We want to 
grab them both, plus all of their Parents, back to the hull surface. Here’s another way 
to select Parents for a component — we’ll begin by selecting the two rudder surfaces:

3 Select ‘rudder’ (the side surface) and ‘r_bot’ (the bottom surface).

4 to Select>Parents>1st Generation. This adds 3 objects. We also need their
Parents.

5 adds 8 points and the centerplane. It looks as though we have the whole 
thing. Let’s just check to make sure:

6 Select>Parents>1st Generation. This adds only one support, ‘hull’, but we 
don’t want to include that, so click on 'hull' and to remove it from the 
Seleciton Set.

7 File>Component>Save.

8 The Component Save dialog says the component will consist of 14 objects, and 
needs one support. Type in the ID message rudder, then <OK>.

9 Give it the filename COMPONENTRUDDER and put it in the \MultiSurf
\Tutorials folder. 
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Putting the rudder component on the tutorial model
As with our cabin, now that we’ve captured it, we can insert the rudder into any 
model that has the same orientation for its hull surface.

1 Return to COMPONENTBOAT model.

2 Preselect the hull.

3 File>Component>Load>COMPONENTRUDDER.MC2.

4 In the Resolving Parents dialog, “C-spline Lofted Surface hull” should be the 
support; <OK>.

5 There are no name conflicts in the Resolving Names, but type in the prefix  r 
anyway; <OK> (Fig. 6). 

6 (Edit>Attributes); layer = 4.

7 Clear the Selection Set.

8 File>Save COMPONENTBOAT.MS2 [This should match our distribution model 
COMPBT3.MS2.]

 Fig. 6

9 Close SAILBOAT (do not save changes, if any).

Transom
This is getting to be a pretty complete model; our next step is to close up the transom. 
We’ll use an already-made component that will fit on this model. This component 
attaches to both the deck and hull, so we need to pick both of them.

1 Click ‘deck’, then <Ctrl>+click ‘hull’ to preselect them.

2 File>Component>Load>TRANSOM1.MC2 from the \MultiSurf \Tutorials 
folder .

3 In the Resolving Parents dialog, check the Parents — notice that they are 
reversed: we preselected them in backwards order (oops again!). It’s 
important to get them in the right order, so we have to correct that. We could 
<Cancel> and begin again, preselecting the Parents in the correct order (hull, 
then deck); but we can also fix the support right here, so let’s do that.
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4 With the first required support (hull) highlighted, double-click “C-spline 
Lofted Surface hull” in the Available Parents list box. The object is filled in as 
the first support.

5 Highlight the second required support (deck) in the upper list box, then 
double-click “Arc Lofted Surface deck” in the Available Parents list box. The 
object is filled in as the second support.

6 <OK> to the Resolving Parents dialog.

7 The Resolving Names dialog indicates no name conflicts, so <OK>.

8 to Edit>Attributes; layer = 5.  

9 File>Save [This should match our distribution model COMPBT4.MS2.]

10 Clear Selection Set (Fig. 7).

11 <F5> to turn symmetry images on and take a look at the results so far then <F5> 
to turn them off again.

 Fig. 7

Rub rail
How about a little detail? Maybe a rub rail to protect our lovely little TUT boat? Let’s 
go grab the one in the SweepSurf sample model GUARD1.MS2.

Saving the rub rail component
1 Open GUARD1.MS2 from the \MultiSurf \Tutorials folder. This hull is a 

modified DEMO hull, so its u,v orientation is the same as that of our Component 
boat. The rub rail is a Sweep Surface: its path is the Line Snake ‘cove’ (magenta), 
specified by the bead ‘ring’ (white); its shape is the Arc ‘shape’ (cyan; at the 
forward end of the rail); its guide is the Offset Curve ‘guide’ (blue).

2 Select the 'guard' surface.

3 to Select>Parents>1st Generation. You get 5 objects, 2 of which are B-
spline Graphs not visible in the drawing. (We would have missed these if we had 
selected the objects just by clicking them in the drawing!)  B-spline Graphs are 
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not currently available for editing in MultiSurf , but can be imported and used in 
this way.

4 again to get 4 more objects.

5 adds 2 Magnets to the Selection Set.

6 one last time.  You get the hull this time. We want to attach to a hull, not 
have it in the component, so Remove it from the Selection Set.

7 File>Component>Save.

8 The Component Save dialog says the component will consist of 12 objects, and 
needs one support. Type in the ID message rub rail, then <OK>.

9 Give it the filename COMPONENTRAIL and put it in the \MultiSurf \Tutorials 
folder.

Putting the rub rail on the tutorial model
Now, onto the hull with this rub rail! Back in the COMPONENTBOAT,

1 Preselect the hull.

2 File>Component>Load>COMPONENTRAIL.MC2.

3 In the Resolving Parents dialog, “C-spline Lofted Surface hull” is preselected as a 
support; <OK>. 

4 The Resolving Names dialog reports no name conflicts, but type in the prefix g 
anyway; <OK>.

5 to Edit>Attributes; layer = 6.

This rub rail will need to be modified slightly to work:

Editing the rub rail
1 Switch to <y> view and zoom in around the forward end of the rail.

2 to turn on Curve Nametags and select the Arc 'gshape'.

3 to Zoom to Selection (this will make 'gshape' the new look point) and then 
zoom out a little.

4 Use the center mouse wheel or the left arrow button to rotate the model left until 
you are looking at the profile of the rail.

You can see that it is not a bump as it should be but a scoop shape.  We need to make 
it a bump.  The rail is a Sweep Surface whose shape is defined by the Arc 'gshape'.  
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The shape of 'gshape' is in turn determined by the location of its middle point, 'gp2'.  
'gp2' is an Offset Point.  If we reverse the offset, 'gp2' will jump to the other side of 
the hull, inverting 'gshape' and the rail along with it.

5 Turn off Curve Nametags and to turn on Point Nametags.  (Note that, 
since we gave the component the prefix g, all its objects have the same prefix).

6 Double click 'gp2' to open its Edit Dialog and click on the <Reverse Offset> 
button.

There, that fixed it.

7 Now, return to the <y> view.

Close up you can see another defect we probably want to correct: the front edge of 
the rail is tilted aft (it’s not that way in GUARD1; go look if you’d like). ‘gm3’ (red) is 
too far aft. Why? After all, it’s a Magnet relative to another Magnet — it should have 
the same u,v location on this hull as it did in GUARD1. Well, it does. 

8 (Zoom to Fit) to see the full profile view again.

Compare the bow profile with that of GUARD1. Therein lies the difference for the 
location of ‘gm3’. To fix our rub rail edge, we can just move ‘gm3’ forward a little.

9 Back in COMPONENTBOAT, (or <F8>) to return to the zoomed in view.

10 If you need to,  zoom in closer until you can see the points easily (Fig. 8a).

a

b

c

d

Fig. 8

11 Be sure All Snaps are off and to turn on 
Orthogonal Dragging.

12 Drag ‘gm3’ straight forward, until the forward edge 
of the rail is vertical. This fixes the tilt of the edge 
(Fig. 8b).

Now let’s slim down the rail (put it on a diet?). We’ll 
need to move ‘gm3’ and ‘gp2’:

13 Drag ‘gm3’ again, this time straight downwards 
about 1/3 the distance to ‘gm1’ (or about du = -
0.025) (Fig. 8c).

14 Next, change 'gp2's offset to -0.26 (Fig. 8d).

15 Now when you rotate the hull you see a beautiful 
rail.

11 File>Save COMPONENTBOAT.MS2  [This should match our distribution 
model COMPBT5.MS2.]

12 to see the whole boat. Better and better all the time!

13 Turn off all nametags.
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Looks like that did the trick. As you can see, even though when we made the 
GUARD1 model (to demonstrate the SweepSurf entity) we didn’t plan to make a 
component out of it, we were still able to do so. Yes, we did have to edit it some in 
order to make it work on our new hull, but that’s not bad. If we had been thinking 
“component” when we made the original model, we might have used an alternate 
construction that would have had a single control point for adjusting the rub rail 
width on a new host hull.

14 Close GUARD1 (do not save changes, if any).

Rigging
Well, if we’re going to sail her, a mast and rigging would be useful. Let’s go pirate 
some from a 24’ sloop model.

Saving the rig component
1 Open SLOOP2.MS2 from the  \MultiSurf \Tutorials folder. 

To get you a bit oriented: 

The mast and boom are Sweep Surfaces. ‘mast’ attaches directly to the deck with the 
magnet ‘m0’. (‘m0’ is the bottom end of the Line ‘sail_track’ which serves as the path
(specified by bead ‘e0’) for the 'mast' Sweep Surface.) 

The lower side stays also attach directly to the deck, with the magnets ‘m2’, ‘m3’, and 
‘m4’. Since these Magnets are based on ‘m0’ at the intersection of ‘sail_track’ and the 
deck, they will keep their proper relationship to the mast if the mast is moved.

The fore and back stays attach indirectly to the deck, via rings ‘r2’ and ‘r3’ on the v = 
1 Edge Snake ‘ctr’ which runs down the centerline of the deck. Thus you can drag the 
bottom ends of the stays forward and aft and they will remain on the centerline of 
the deck. First, let’s check the orientation of the deck:

2 Select the deck. u goes from bow to stern, and that’s what we need (whew! 
after all that introduction, it had better be!). 

Let’s select the objects for our component:

1 With the deck still selected, choose Select>Children>All Generations to add 33 
objects to the Selection Set.

2 We don’t want the deck, so remove it from the Selection Set.

We had better check in the other direction as well — Parents:

3 Select>Parents>1st Generation. Oh! Good thing we checked! These 2 B-spline 
Graphs control the guide curve  and taper of the mast Sweep Surface. We get the 
deck as well.  That's OK, just remove it again.

4 Select>Parents>1st Generation one more time. Just the deck comes up, so we 
are all set.  Remove the deck one last time from the Selection Set

Now we can save the component:



Working with Components Rigging

March 24, 2011 AeroHydro, Inc Marine Tutorials User's Guide   •  176

5 File>Component>Save.

6 The Component Save dialog says the component will consist of 35 objects, and 
needs one support. Type in the ID message mast, boom, and rigging from 24’ 
sloop, then <OK>.

7 Give it the filename COMPONENTRIG and put it in the \MultiSurf \Tutorials 
folder.

Rigging the tutorial boat
1 Return to the COMPONENTBOAT window.

2 Preselect the deck.

3 File>Component>Load>COMPONENTRIG.MC2.

4 In the Resolving Parents dialog, “Arc Lofted Surface deck” should be the 
support; <OK>.

5 In the Resolving Names dialog, no name conflicts are indicated, so click <OK>.

6 (Zoom to Fit).

Now, there’s one wee problem here: the mast and boom are too short for our 30-ft 
boat. We can fix that by scaling the component while it is still in the Selectiojn Set.

7 Edit>Transform>Scale and set all 3 scale factors to 1.25 (that’s 
30/24).

<OK> and <OK> to the Non-Transferable Entities box.

8 (Zoom to Fit) again to see the whole picture.

That’s much better. We’ll keep it.

9 (Edit>Attributes) and put the component on layer 7.

10 Clear the Selection Set.

 Fig.9
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Notice that the mast comes down onto the deck through the cabin (Fig. 9). Let’s step 
it on the cabin top instead:

11 (Zoom to Area) and zoom in on the cabin.

12 Select the Magnet ‘m0’ (red; at the base of the mast).

13 >Projected Magnet to project a magnet onto the cabin top.

Point = 'm0' (pre-selected)
Magnet/Surface = 'ctop'
Mirror/Surface = 'ctop'
<OK>

14 Place the arrow at the back of the mast and when the cursor changes to , 
double click to edit the line 'sail_track'.

15 Remove 'm0' from the Selection Set and add the new magnet .  Be sure to 
move the new magnet so that it is listed first in the Selection Set.  <OK>.

 Fig. 10b

16 File>Save COMPONENTBOAT [This should match our model COMPBT6.MS2.]

17 Zoom to Fit again.

18 <F5> to show the symmetry images.

19 Close SLOOP2 (do not save changes, if any).

Paint job
Guess we’re ready to throw her in the water, but we ought to paint the bottom first:

1 <F5> to remove symmetry images and preselect the hull.

2 File>Component>Load>PAINT1.MC2 (in \MultiSurf \Tutorials folder).

3 In the Resolving Parents dialog, “C-spline Lofted Surface hull” is preselected as a 
support; <OK>. 
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4 The Resolving Names dialog reports 4 name conflicts, so type in the prefix p;
<OK>.

5 (Edit>Attributes) and put the paint component on layer 8.

6 Click the button (or press <p>) to switch to perspective view (if you are not 

already there).  To get rid of some of the clutter, press to hide the points and 
go to Tools>Options (O) and in the Display tab, uncheck "Display mesh lines", 
<OK>.  That's a little better.

In order for this to look really good, we will have to create one more SubSurface for 
the topsides and then hide 'hull'.

7 Select 'hull' and >Edge Snake:

Surface edge = "u=0";
<OK>

8 Select SubSurface 'pboottop' and to Show Parents.

9 Put the new Edge Snake and the Intersection Snake 'pn1' (the top of the boot top) 
in the Selection Set.

10 >SubSurface (Insert>Surface>SubSurface):

<OK>.

11 Select 'hull' and hide it. [This should match our distribution model 
COMPBT7.MS2.]

And guess what! If you don’t like the color, all you need to do is:

12 Select the painted bottom surface “pbtm_paint”.

13 (Edit Attributes) and change color to whatever you want. Presto! 
(Wouldn’t it be nice if it were that simple to repaint a real sailboat?!)

Painting another boat
Before we quit here, since we have the paint out, let’s paint the hull of our 
lobsterboat as well (so you can see that you really can use a component in more than 
one model).

1 Open LOBSTER8.MS2 from the \MultiSurf \Tutorials\ folder.

2 Preselect ‘hull’.

3 File>Component>Load>PAINT1.MC2.

4 <OK> to both Resolving Parents and Resolving Names dialogs.

5 Close both COMPONENTBOAT and LOBSTER8 (do not save changes).
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Working with Components wrap-up
In this lesson, starting with only 3 master curves, you have constructed a complete 
sailboat model almost entirely from components.  MultiSurf components provide 
the ability to paste groups of geometrically related objects into a model without 
having to construct the component object-by-object. MultiSurf provides you with 
some already-made components, but it is just as easy to select a portion of an existing 
model (source model), and save it as a component to be used in other models (host 
models).

When importing a component there are several factors to take into account:

• The host model must have the right kind of Parents for the component; these 
must be akin to those in the source model (e.g. if a parent in the source was a 
surface, that parent in the host must be a surface; if a parent in the source was a 
curve, that parent in the host must be an entity that can serve as a curve, that is a 
curve, snake, or point object).

• The orientation must be matched between source and host (t for curves and 
snakes; u,v and normal orientation for surfaces).

• Name conflicts between the component entities and the entities in the host 
model can be avoided by adding a prefix to the component entity names in the 
Names Resolution dialog.

• The size of a component can be changed immediately after the loading 
operation, by using Edit>Transform>Scale.

Once in place, entities added to a model by loading a component can be edited just 
like any other MultiSurf entities.

Now it’s your turn! You may be surprised by all the components you have lurking in 
your MultiSurf models, just waiting to be captured and used in new places. Happy 
componenting.
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Glossary of Terms

ambiguous selection 
When you click on a screen location to select an entity, and there are two or more 
entities within the cursor’s “target” box that pass through the current filters, the 
selection is termed ambiguous. The Which Entity? dialog opens listing the eligible 
entities at that location, so you can indicate which one you want to select.

attribute 
An entity attribute is any of the data items used to define the entity; e.g. name, color, 
visibility, divisions, type, relabel, orientation, supporting object(s), etc.

axial orthographic view 
An orthographic view in which you are viewing along one of the world coordinate 
axes. The shortcuts for these views are: Front, Back, Left, Right, Top, Bottom 
(Mechanical View Orientation) and Bow, Stern, Port, Starboard, Deck, Keel (Marine 
View Orientation). When the grid is turned on, these views have both horizontal and 
vertical gridlines.

bead 
A point constrained to lie on a curve.

body plan 
(Nav. Arch.) One of the conventional naval architectural views of a ship hull: the two 
end half-views (orthographic) shown side by side, displaying the transverse sections 
of the ship.

boot stripe 
(Nav. Arch.) A decorative and/or protective stripe near the resting waterplane of a 
boat, usually finished in a contrasting color to the hull surfaces above and below it.

bow 
(Nav. Arch.) The front end of a boat.

B-spline 
A continuous curve defined by a series of control points. The curve is formed in 
relation to the 3D polyline (i.e., the broken line) joining the control points in sequence. 
A B-spline always starts at the first control point and ends at the last control point, 
and it is always tangent to the polyline at these end points, but in general it does 
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NOT pass through the other control points (as opposed to a C-spline, which passes 
through all its control points).

buttocks, buttock lines 
(Nav. Arch.) A set of sections of a ship hull cut by vertical planes that are parallel to 
the centerplane; typically made with Contours parallel to the Y-plane.

camber 
A measure of how much a curve deviates from its chord. Often used in different 
disciplines with specific meaning, e.g:

Maximum Camber - The greatest deviation of the curve from its chord.

Camber Ratio - The Maximum Camber divided by the chord length.

Deck Camber - Naval architecture term for Camber Ratio as measured for deck 
stations. It is frequently assumed that the shape of deck stations are arcs.

Foil Camber - The deviation of the Median curve from the chord, where the Median 
curve is the curve describing the points of mid thickness of the foil.

Camber Function - The camber as a function of chord length, usually for describing 
foils.

camera 
You can think of the screen view of a model as being recorded by a camera, which is 
“where your eye is” in the 3D model space. 

child entity 
Any entity that is defined in terms of another “parent” or “support” entity. If  you 
change any entity, the program automatically updates all of its children. Same as 
“dependent” entity.

chine 
A “hard edge” between two surfaces; a join between two surfaces involving a sharp 
bend, hard corner, or break in slope. (Nav. Arch.) The join between two longitudinal 
hull surface strips, especially topside and bottom surfaces in a hard-chine boat hull; 
also, the structural member (if any) that runs along this join.

chord line 
The straight line connecting the end points of a curve.

contours 
Contours are one or more parallel sections in a user specified orientation.  Each 
section cuts all the surfaces desired for that contour creating 3D polylines that trace 
the surface(s) at that location.

control points 
The point entities used to define the shape of a curve or snake entity.
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control curves 
The curve entities used to define the shape of a surface.

coordinate singularity 
A location (u, v) on a parametric surface where the mesh of u,v coordinate lines fails 
to provide a unique normal direction, because of some form of collapse of the mesh.

• the rate of change of the surface point with respect to either u or v is 
zero, or

• the rates of change of the surface point with respect to u and v are 
parallel.  

A pole is a common form of coordinate singularity. A place where the u- and v-
directions are either identical or opposite is another kind of coordinate singularity.

Certain calculations break down at a coordinate singularity. The differential element 
of area associated with differential changes of u and v vanishes.

cove stripe 
(Nav. Arch.) A decorative stripe that runs along the hull of a boat, not far below the 
sheerline, from near the bow to near the stern.

C-spline 
A continuous curve defined by a series of control points. The C-spline curve passes 
through its control points in sequence (as opposed to a B-spline, which generally does 
NOT pass through its interior control points).

curve 
A one-dimensional object, "straight" or not "straight".  In MultiSurf, all curves 
(including Curves and Snakes) have points (including, as appropriate, Points, Beads, 
Rings and Magnets) as parents.

degenerate curve (or snake) 
Normally a curve consists of a continuous 1-dimensional set of points. Under special 
circumstances, a curve can collapse into only a single point; for example, a line from 
point A to point A. Such a collapsed curve is called "degenerate".

degenerate edge 
Normally each edge of a surface consists of a 1-dimensional continuous set of points. 
Under special circumstances, a surface edge can collapse to a single point; for 
example, a ruled surface between a curve and a point. Such a collapsed edge is called 
"degenerate".

degenerate surface 
Normally a surface consists of a continuous 2-dimensional set of points. Under 
special circumstances, a surface can collapse into only a 1-dimensional set of points 
(for example, a B-spline Lofted Surface between two point entities), or just a single 
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point (for example, a Tangent Boundary Surface made from four identically-located 
control points). Such a collapsed surface is called "degenerate".

dependent entity 
Any entity that is defined in terms of another “support” or “parent” entity. If  you 
change any entity, the program automatically updates all of its dependents. Same as 
“child” entity.

developable surface 
Any surface which can be rolled out flat (or conversely, can be formed from flat sheet 
material) by bending alone, without in-plane stretching of any element. A 
developable surface has zero Gaussian curvature at all its points. Cones and 
cylinders are well-known examples.

digraph, directed graph 
A diagram that represents the entities in a model (the nodes) and the dependencies 
between them (directed edges).

duck 
(Drafting)  A special weight used for positioning and holding a flexible curve or 
spline.

durable relationships 
Durable relationships in a MultiSurf model are those which are built into the model 
through entity dependencies. For instance, if two surfaces depend on a common edge 
curve, the join between them is a durable join — you can change the shape of either 
of the surfaces, but they will continue to join along the shared control curve.

DXF file 
An ASCII disk file which serves as a data exchange format between CAD programs. 
The DXF file standard is defined by Autodesk, but is used by essentially all CAD 
programs.

entity 
A kind of geometric entity that a CAD system recognizes (for example, MultiSurf’  
Point, B-spline Curve, or Tangent Boundary Surface), or a specific entity made by 
specifying properties and/or parents for a kind of entity.

entity description 
A reference topic in the manual or help system that lists the characteristic properties 
and/or parents required to create a particular entity, describes the role of  those data 
items, and presents one or more examples. 

Entity List 
The Entity List serves as a container for a list of entities.  This would be useful if, for 
instance, you wanted to perform repeated operations on a group of entities and 
wanted to be able to select this group repeatedly.
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entity name 
An entity name identifies a specific entity; e.g. ‘top’ might be the name of a Point  
located at X=0, Y=0, Z=10. Every MultiSurf entity has a name; entity names within a 
model must be unique.

exponential notation 
Exponential notation, also called scientific notation, is a compact way to write very 
large and very small numbers. A number in exponential notation is written as one 
number, followed by an “e” or “E”, followed by a second number. To read the 
number, you take the first number and multiply it by 10 raised to the power of the 
second number (positive or negative). Examples:

3.124E+009 = 3.124 x 109 = 3.124 x 1,000,000,000 = 3,124,000,000

2.477E-005 = 2.447 x 10-5 = 2.447 x 0.00001 = 0.00002477

fair 
adj.  A fair curve or surface is one that is smoothly curved. It may have necessary 
inflections (e.g. a wine-glass cross-section), but it has no humps or hollows or abrupt 
changes in curvature.

verb  To fair a curve or surface means to make it smoothly curved, removing any 
humps, hollows, or abrupt changes in curvature.

filter 
A tool that allows only entities matching the filter to be available for selection (in 
graphics and Available Entities pane views). E.g. the Points Filter allows points to be 
available; the Current Layer Filter allows entities on the current layer to be available. 
Filters are additive.

Applying or changing filters does not affect entities already selected.

frame (entity) 
A local orthogonal x,y,z coordinate system. A frame can be displaced and/or rotated 
with respect to the global coordinate system.

G0 continuity 
Two curves or surfaces joining without tangency.

G1 continuity 
Two curves or surfaces joining with tangency.

G2 continuity 
Two curves or surfaces joining with tangency and continuous curvature across the 
junction.

generation (1st, 2nd, ... of parents, children) 
When we talk about parents or children of an entity, we usually mean the “direct” or 
“first generation” of them. These are the parent entities you select in the 
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Insert>Entitiy dialogs and the parent and child entities listed in the Parent/Child 
dialogs. But beginning with any one entity, parent (and child) relationships may 
continue on indefinitely, e.g: first generation parents, their parents (second 
generation), their parents (third generation), etc.

host entity 
If entity A is embedded in entity B (another entity of the same or higher 
dimensionality), then entity B is the host of entity A. A bead has a host curve; a 
magnet has a host surface; a ring has both a host snake and a host surface. Converse 
of "resident".

IGES file 
An ASCII disk file which serves as a data exchange format between CAD programs. 
The IGES file is an international standard which is supported by a large number of 
CAD programs. You can import IGES geometry with File>Import>IGES. Most of the 
surface and curve types and all supporting points are fully editable in MultiSurf. 
Although there is no Edit dialog for some entities that can be translated and 
imported into MultiSurf, these entities are relational entities with parents and you 
can change these entities in a more indirect manner.

inflection 
A change in the direction of curvature; e.g. the point at which a curve changes from 
being concave to being convex.

internally-defined entity 
An entity which is defined inside MultiSurf and which can be used as a support 
entity without a user needing to create it. Examples: ‘*’ (point at the origin), ‘*1’
(bead/ring at t=1 end of curve/snake), ‘*X=0’ (plane at X=0). Internally-defined 
entities don’t display in the drawing, so you must select them in the Available 
Entities pane. Same as “predefined” entity.

interpolation 
1 Determination of (usually approximate) intermediate values between the 
entries in a table.

2 A curve that passes through a series of points is said to "interpolate" the 
points (for example, C-spline Curve). Likewise, a surface that passes through a set of 
curves or points is said to "interpolate" them (for example, C-spline Lofted Surface).

keel 
(Nav. Arch.) An appendage on a sailboat hull which usually serves both ballasting 
and hydrodynamic functions. Typically it is a fin, approximately centrally positioned 
on the bottom of the hull, but it can be much more complex and specialized.

knot 
Mathematicians generalize the definition of spline function to mean any piecewise 
polynomial function which satisfies certain conditions of continuity at the "knots", 
the points where the pieces join together.
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latitude 
One of the viewing angles used to control the camera position; angle above or below 
a horizontal plane.

lofted surface 
A lofted surface is shaped by two or more control curves in much the same way as a 
curve is shaped by two or more control points. The process (which MultiSurf carries 
out automatically and invisibly) is:

1 Decide the orientation of the control curves with reference to the first 
control curve that has positive length.

2 On each of the control curves, locate points at the same parameter value t 
(or 1 - t, if the curve is used with reversed orientation).

3 Use the resulting series of points as the control points for a lofting curve.

lofting curves 
In a lofted surface, the lofting curves are the curves “sprung” across the master 
curves to form the lofted surface; the u=constant parametric lines. The control points 
for each lofting curve are points at equal t-values (or 1 - t) on each of the control 
curves.

longitude 
One of the viewing angles used to control the camera position and orientation; angle 
of rotation around the vertical axis.

longitudinals 
(Nav. Arch.) The family of  parametric lines that run fore-and-aft on a boat hull are 
sometimes called longitudinals. For example, these would be the u=constant 
parametric lines (the lofting curves) on a typical C-spline Lofted Surface hull with 
transverse master curves, like DEMO.MS2.

look point 
The location at which the camera that records the view is pointed; the center of the 
orbit sphere when you rotate the camera. The default look point when you load a 
model is the center of the bounding box the program uses to frame the image on the 
screen (basically the center of the model). You can change the look point by panning.

magnet 
A point constrained to lie on a surface.

master curves 
The series of curves used to define the shape of a lofted surface.
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mirror 
The plane, line, or point used for reflection of a Mirrored Point, Mirrored Curve, 
Mirrored Surface; or for projection of a Projected Point or Projected Curve; or for 
specifying the infinite family of potential cutting surfaces for an Intersection Snake.

MS2 file 
An ASCII disk file which defines a model created in MultiSurf.

normal, normal to 
Perpendicular to. For example: a normal plane perpendicular to a curve; the normal 
direction perpendicular to a surface.

NURBS 
NURBS is an acronym for “Non-Uniform Rational B-Spline.” This is a formulation 
for parametric curves and surfaces which permits a uniform representation of  B-
spline, Bezier, and conic section curves and surfaces.

offset 
A displacement perpendicular to a surface.

offsets 
(Nav. Arch.) A conventional way of presenting a hull shape numerically, by giving 
transverse and vertical coordinates at a series of stations.

orbit sphere 
When you rotate the camera, it works as though it were mounted on the surface of a 
sphere, pointing inward toward the center which is the look point. This imaginary 
sphere is called the orbit sphere of the camera.

orientation (of curve or surface) 
The direction in which the parameters t (curve/snake) or u,v (surface) increase. 
Entities such as Trimmed Surfaces require the orientation of one or more basis 
curves/snakes to be in a specific direction. View>Entity Orientation displays this 
information for the selected entity.

orthographic view 
An orthographic view maps a 3D scene into a 2D screen image using parallel 
projection lines. This is an artificial view which is conventional for most engineering 
drawings. 

parameter 
A dimensionless real number which labels one point along a curve; or one of a pair of 
real numbers which label one point on a surface. In MultiSurf, curve parameters are 
called t and surface parameters are called u and v; all nominally run from 0 to 1, but 
have meaning outside this range.
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parametric lines 
The curves on a surface that result from holding one of the surface parameters (u or 
v) constant and varying the other.

parent entity 
An entity that another entity directly depends on for its shape or position. E.g. the 
curve on which a Relative Curve is based; one of the control curves of a lofted 
surface; the surface from which a SubSurface is built. Same as “support” entity.

perspective view 
A perspective view maps a 3D scene into a 2D screen image using  projection lines 
which converge on an eye or camera point. This is a natural view which is similar to 
a visual image or a photograph.

plan view 
A vertical orthographic projection of a scene (from above or below). (Nav. Arch.) A 
vertical orthographic view of a hull, displaying the waterlines.

plane 
An unbounded flat surface.  In MultiSurf there are default planes (*X=0, *Y=0 and 
*Z=0) that consist of the points that define X=0, Y=0 and Z=0 respectively and planes 
with any orientation that you can create in various ways.

planform
The shape and layout of an airplane's wing or a ship's keel.

point 
A non-dimensional location in space.  In MultiSurf, points are 2 parent entities, each 
defined in relation to a Point and a Frame.

pole 
A degenerate edge of a surface. At a pole, one set of parameter lines (u = constant or 
v = constant) converges to a point. For example, the apex of a cone; or either pole of a 
sphere made by revolving a semicircle about the line joining its endpoints. A pole is a 
common form of coordinate singularity.

polyline 
A broken line consisting of 2 or more straight-line segments joining a series of points. 
Polylines can be 2D (the points have 2 coordinates, usually X and Y) or 3D (the points 
have 3 coordinates).

predefined entity 
An entity which is defined internally in MultiSurf and which can be used as a 
support entity without a user needing to create it. Examples: ‘*’ (point at the origin), 
‘*1’ (bead/ring at t=1 end of curve/snake), ‘*X=0’ (plane at X=0). Predefined entities 
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don’t display in the drawing, so you must select them in the Available Entities pane. 
Same as “internally-defined” entity.

profile, profile line 
(Nav. Arch.) The outline of a hull in side view, particularly the edge of the hull 
surface at the centerplane.

profile view 
A horizontal orthographic view of a scene (from either side). (Nav. Arch.) An 
orthographic view perpendicular to the hull centerplane, displaying the profile and 
buttock lines.

property (of an entity) 
An entity property is any of the non-parent data items used to define the entity; e.g. 
name, color, visibility, divisions, type, degree, etc.

Relabel (entity) 
A Relabel entity controls the relabeling (re-parameterization) of a curve, snake or 
some surfaces. It is not a visible entity in itself, but its effects on labeling can be made 
visible by showing tickmarks for the affected curve or snake.  Its effect on surfaces is 
harder to see, but magnets will change their absolute location on a surface as the 
surface's u-v parameterization changes.

Relational Geometry 
Also referred to as RG. The conceptual framework of MultiSurf: a scheme for 
defining geometric entities and the relationships between them. Capturing 
relationships as part of a geometric model allows automatic propagation of changes 
to all affected entities, and supports the key advantages of Relational Geometry: 
accuracy, design flexibility, parametric design, ability to freely refine and optimize.

resident 
If entity A is embedded in entity B (another entity of the same or higher 
dimensionality), then entity A is a resident of entity B. A bead resides on a curve; a 
magnet resides on a surface; a ring resides on both a snake and a surface. Converse of 
“host”.

ring 
A point constrained to lie on a snake. A ring also lies on the surface the snake is on, 
so it can serve as a magnet on that surface.

RMS (root-mean-squared) 
A measure of the deviation between two sets of data.

scientific notation 
See “exponential notation”.
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selection set
The selection set is comprised of the one or more entities currently selected. Its basic 
use is: you make a selection set, then you tell the program what you want to do to it 
(edit, move, hide, use as parents for an entity, ...).

sheerline 
(Nav. Arch.) The upper edge of  a hull surface; usually the most visually prominent 
line on a boat.

SLDCRV file 
An ASCII text file containing X, Y, Z values in three columns. Each line represents 
one 3D point, and must contain three decimal values separated by spaces or tabs.  
Can be opened in MultiSurf with File>Import>SLDCRV.

snake 
A curve constrained to lie on a surface.

spline, drafting spline 
(Drafting)  A thin, flexible curve held in position by weights (“ducks”), used for 
drafting free-form curves.

stations 
(Nav. Arch.) A set of longitudinal locations on a ship, usually uniformly spaced; also, 
the transverse sections at these locations.

stem 
(Nav. Arch.) The forward edge of a boat hull. (Also, a structural member along this 
edge.)

stern 
The back end of a boat.

support (or supporting) entity 
An entity that another entity directly depends on for its shape or position. E.g. the 
curve on which a Relative Curve is based; one of the control curves of a lofted 
surface; the surface from which a SubSurface is built. Same as “parent” entity.

surface 
A 2-dimensional object, i.e. an object that can be defined by 2 parameters.  In 
MultiSurf, all surfaces have curves (Curves or Snakes) as parents.

t (parameter) 
t is the parameter used to reference/label curves and snakes. It runs from 0 at the 
starting end to 1 at the other end of the curve or snake. You can think of each point 
that forms the curve as being labeled with a unique value of t.
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thwart 
(Nav. Arch.)  A seat extending from side to side of a small boat.

tilt 
One of the viewing angles used to control the camera orientation; rotation of the 
camera about the line from the camera to the look point.

transom 
The distinct surface (if any) that forms the back end of a boat.

u and v (parameters) 
u and v are the parameters used to reference/map surfaces. From the 0,0 corner of 
the surface, u runs from 0 to 1 in one direction along the surface; v runs from 0 to 1 in 
the other direction. You can think of each point that forms the surface as being 
labeled with a pair of values of u,v.

waterlines 
(Nav. Arch.) A set of  sections through a hull, cut by a family of horizontal planes; 
typically made by one or more Contours parallel to the Z-plane.

WireFrame (entity) 
A WireFrame entity is a .3DA or .PAT file which can be included in a model 
primarily for display or comparison purposes. The result of including this file is a 
wireframe entity which cannot be used in the construction of other MultiSurf entities. 
For example, a curve represented in a WireFrame entity cannot support a bead, and 
it cannot be used as an edge of a surface.

wireframe image 
An image of a model in which surfaces are represented by meshes, curves and 
contours by polylines, and points by little dots. A wireframe is essentially 
transparent — you can see between the wires, and when part of a surface is behind 
another surface, you can still see it.

zero-velocity point 
You can think of the parameter t on a curve as time and the curve as being the path 
of a moving point as t goes from 0 to 1. The parametric velocity of the point is the 
rate of change of its position with respect to t. 

A zero-velocity point (t-position) on a parametric curve or snake is a place where the 
parametric velocity vanishes. At a zero-velocity point, a small change in the 
parameter t causes no change in the 3D location of the moving point. This can be 
caused by a variety of situations, including: doubled control points on a degree-2 or 
lower B-spline Curve, a point serving as a curve, an ellipse with a zero major or 
minor axis. Some calculations will fail at a zero-velocity point — for example, the 
tangent direction is not defined.
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<Shift+X> 16
<Shift+Y> 16
<Shift+Z> 16
<X> 16
<Y> 16
<Z> 16

3

3 consecutive points on a line 
make a straight section in a B-
spline Curve 58

3DA files 21

A

ambiguous selection 40
appendages 120
Arc 76
Arc Lofted Surface 70
arrow keys 12
attitude

specifying for hydrostatics 130
Auto Orientation 44
Available Entities pane 9

B

basic terminology 3
Bead 44

creating one in Quick Point 
Mode 96

on extension of its curve 99
using to make a B-spline loop 

that joins with continuous 
slope 97

Bead,
dragging 80

beads
dragging 45
moving beyond ends of basis 

curve 80
quick beads 96

beginning a new model 31
bottom

durably flat across the 
centerplane 39

bows
rounded 112

B-spline Curve 86, 95
adding control points 97
closed 97
displaying its polyline 95
G1 join 99
G2 join 99
making a loop that joins with 

continuous slope 96
relationship to its control 

points 95
relationship to its polyline 96
tangent to a line 98
using Mirrored Points to make 

tangent joins 101
with straight portion 87, 116

B-spline Curve always starts at 
first control point 57

B-spline Curve,
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Degree1,
how to make meet points 86

B-spline Lofted Surface 90
changing which curves support 

the surface 107
creating 105
making 2 B-spline Lofted 

Surfaces tangent to each 
other 103

B-spline Snake 88
bulkheads,

movable 123

C

cabins
component (with correct 

orientation) 167
component (with wrong 

orientation) 165
durable joins 124
movable 124
with flying bridge 126

camera
definition 11
moving 12

center of gravity (hydrostatics)
Z-coordinate of 130

Change name in Surface Manager 
70

child entities 22
Clear Selection Set 40
components

cabin (with correct orientation)
167

cabin (with wrong orientation)
165

deck (arc-lofted) 163
hull skin (C-lofted) 162
issues 159
keel (using component scaling 

factors) 168
orientation 166, 167
paint job (on 2 different hulls)

177
prefix 166
resolving names 166, 168
rigging (saving, loading, 

editing) 175
rub rail (saving, loading, 

editing) 172

rudder (saving and loading)
170

saving 165, 170, 172
scale factors 176
selecting objects for 165, 170, 

172
transom (supports wrong and 

right order) 171
tutorial 159
using 159, 162

compound-curved surfaces 119
Contours entity must be made 

from shiftable entity if you 
want it to shift 55

Contours filter 63
control curves

changing which curves support 
a surface 107

making a set that will create a 
surface ending normal to a 
plane 102

specifying support curves for a 
surface 103

control of view 11
control points

adding 97
B-spline tangency 94
selecting as parents for a curve 

94
Copy Last (Insert Menu) 95
cove stripe 67
C-spline curve

with straight portion 116
C-spline Curve 85
C-spline Curve,

degree 1,
does not meet points in 

graphic view 85
C-spline Lofted Surface 89, 119
C-spline Lofted Surface always 

attached to first curve) 57
Ctrl click to add entity to Selection 

Set 37
Ctrl+arrow keys 12
Ctrl+shift+click 97
curvature profile 86
curvature profile (of curve) 59
curvatures,

surface
Gaussian 117, 118

curves
Arc 76
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B-spline Curve 86
C-spline Curve 85
Projected Curve 91, 102
SubCurve 80

Curves filter 41
cutter rig 127
cylindrical transoms 61, 139

D

decks
cambered 122
component (arc-lofted) 163
C-spline Lofted 122
C-spline Lofted Surface 68
developable 122
ruled surface 122
without camber 122

default plane 39
defaults

location for point objects 45
symmetry display 21

degrees per keystroke (rotation) 
13

dependency 116
developability,

checking for 117
Distance (Tools Menu) 128
distribution

of curvature along curve 86
of surface curvature 117

divisions
for actual parts 133
for N/C cutting 133
Offset Surface 131
type-1 B-spline Curve 86
type-1 C-spline Curve 85

Double click entity for Edit dialog 
95

double click on entity Edit dialog 
33

drag a point 23
drag select 81
drag selection 42
dragging

beads 45
durable joins

bulkhead example 123
cabin example 124
rowboat example 39, 43

durable properties of model 41, 49
durably straight stem 58

DXF files 21

E

Edge Snake 43
Edit>Transform>Scale 52
Edit>Transform>Scale) 48
Edit>Transform>Shift 55
Edit>Undo 23
editing

adding an entity twice to the 
selection set 97

adding control points 97
changing which curves support 

a surface 107
moving bulkhead 123
moving cabin 124

entities
can’t select 5

entity
child 22

entity names with spaces 40
entity orientation

for Relative Curve 104
of curves 104

error messages
what to do 5

exiting SurfaceWorks 26, 49
expand to selected entity in 

Surface Manager 22
Export 2D (File Menu) 19
Export 3D (File Menu)

RUL 119
extension

of curve 80

F

F4 95
figures in the tutorials 5
File>Close 23
File>Exit 26
File>Export 3D>3DA wireframe 

66
File>Open 8
File>Save 35
File>Save As 32
files

3DA 21
DXF 21
POV 21
RUL 119

filters
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examples of using 41
flying bridge 126
Frame 61
Free tumble mode 11

G

G1 join
B-spline Curve and line 99

G2 join
B-spline Curve and line 99

Gaussian curvature 117, 118
graphics views

multiple 23
Grid 90
Grid (View Menu)

axial orthographic views only 
90

H

Heel (hydrostatics) 130
Help 16
Hide Selection Set 39
hull skin (C-lofted) component

162
hulls

C-spline Lofted Surface with B-
spline Curve master curves 
110

planing 141
powerboat 115
preference for type-3 B-spline 

Curve master curves 143
radius-chine 119
round-chine 119
rowboat 31
sailboat from components 160
Tangent Boundary Surface 115

Hydrostatics (Tools Menu) 130

I

ID (identifying) message 31
Insert Menu

Copy Last (Insert Menu) 95
Insert>Contours 129
Insert>Copy Last 47
Insert>Plane 136
Insert>Quick Point Mode 46
Insert>Wireframe 21
Invert filters 42

K

keel with a durably straight 
portion 116

keels
bulb 120
component 168
sailing yacht 120
with straight portion 116

keyboard
doesn’t respond 5

L

latitude
adjusting 12
definition 11

Line 58, 95
Line Snake 47
lofted surface

B-spline,
ending normal to plane 102

making 2 B-spline Lofted 
Surfaces tangent to each 
other 103

longitude
adjusting 12
definition 11

look point
adjusting 12

M

Magnet,
dragging 88

magnets
definition 45

master curves
preference for type-3 B-spline 

Curves 143
menu,

right click on entity 22
message

identifying message 31
Mirrored Curve

creating 101
using to make G2 joins 101

Mirrored Point
creating 101
using to make tangent joins 101

Mirrored Surface
creating 103
tangency with B-splines 103
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model
beginning a new one 31
durable properties of 49

model disappears from window 5
mouse pan 14
mouse rotate 13
mouse zoom in/out 14
mouse zoom to area 14
moving

a bulkhead 123
a cabin 124

multiple graphics views 23

N

Nametags
Point 23

New (File Menu) 31
New Model Window (Window 

Menu) 23

O

oarlock 44
Offset Surface 131, 132
Offsets (View Menu) 128
online tutorials

following the tutorial sequence 
1

orientation
marks (surface) 45
of surface 45

Orthogonal Dragging 90
orthographic view 15

P

paint job component 177
panning

with mouse 14
parameter

t 44
u 45
v 45

Parent/Child box 22
perspective view 15
planar

sheerline 134
transom 120

planes
base 54

planing powerboat 141
Point 69, 81
points drag in plane of screen 36

Points explained 36
Points filter 41
PolyCurve 81
polyline display

B-spline Curves 95
POV files 21
powerboats 115, 122, 126

planing 141
pre-selected entity 37
Preserve Absolute Location 36
Preserve Offset Values 36
preserving relationships in a 

model 41
Previous View 18
Projected Curve 39, 91, 102

creating 102
using to make surface end 

normal to a plane 103
Projected Point

creating 100
using to make B-spline Curve 

end normal to a plane 100

Q

Quick Bead 59
Quick Beads and Rings snap to 

curve 46
Quick Magnet 45
Quick Ring 46
quitting SurfaceWorks 26, 49

R

radius
adjusting 12

radius (of camera)
definition 11

realignment of stations 65
Relational Geometry 49
relationships captured in a model 

49
remove entity from Selection Set 

81
reshaping

stem 56
stern 61

reverse t distribution with 
SubCurve 80

rigging 127
component 175

right click in graphics white space 
menu 14
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right click in Surface Manager 
white space 22

right click on entity menu 22
right click on entity>Hide 39
right click on entity>Show 41
rotating

with mouse 13
rowboat 31
rub rail component 172
rudder component 170
RUL files 119
Ruled Surface 32, 37, 122

S

sailboats 127, 160
Save Offsets (File Menu) 130
scaling a model 48
screen doesn’t match our 

instructions 2
Select>All 79
Select>Both 41
Select>Children 22
Select>Hidden 41
Select>Parents 22
Select>Reset All Filters 42
Select>Select Mode 33
selecting

can’t select 5
to put entity in selection set 

more than once 97
selecting, choosing, picking, going 

to 4
Selection Set pane 9
Selection Set,

remove entity from 81
sheerline

durably planar alternatives 138
planar example 134
planar,

our recommended method 
138

shift+arrow keys 13
Ship Lines (View Menu) 20
show only Boundary lines on a 

surface 68
Show-Hide>Hide Points 82, 89
Show-Hide>Hide Unselected 144
Show-Hide>Show Children 123
Show-Hide>Show Parents 63
Show-Hide>Show Points 89
Show-Hide>Show Selection Set 41

Sink (hydrostatics) 130
skin deduction 131
Snake defined 42
snakes

B-spline Snake 88
Edge Snake 43

snaps 87
spars 127
stations

realignment 65
stem

durably straight 58
reshaping 56

stern
reshaping 61
rounded 114

stripe
cove 67

SubCurve 80
SubCurve,

change curve parameterization 
80

superstructures,
durable joins 124

Surface Curvatures (Tools Menu)
Gaussian 117

Surface Manager 9
surfaces

B-spline Lofted Surface 90
compound-curved 119
C-spline Lofted Surface 89, 119
developable 117
mixing developable and 

compound-curved 119
Offset Surface 131
orientation 45
Ruled Surface 32, 37, 117, 122
Tangent Boundary Surface 116

Surfaces filter 63
surfaces should be made between 

curves of similar t distribution 
83

SurfaceWorks
exiting 26, 49

Symmetry Images 21

T

t (parameter) 44
tangency

between surfaces 102
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between two arbitrary B-spline 
Lofted Surfaces 103

B-spline Curve tangent to Line 
98

B-spline loops 96
endpoint tangency property of 

B-spline Curves 95
tangengy principle of B-spline 

Curves 95
using Mirrored Curve 100
using Mirrored Points 101

Tangent Boundary Surface 116
tickmarks 44
Tickmarks 83
Tile Vertical 23
tilt

definition 12
Tools>Adopt Children 47, 84
Tools>Mass Properties 119
Tools>Measure>Clearance 136
Tools>Options 31
Tools>Options, Dragging, 

Dragging, Orthogonal 
Dragging 57, 90

Tools>Options, Dragging, Snap 87
Tools>Options, Dragging, Snaps

56
Tools>Options, Dragging, Snaps, 

Clear All 57
Tools>Options, Dragging, Snaps, 

Set All 61
Tools>Options, Entity, Quick 

Spline Defaults 81
Tools>Options, General, Auto 

Orientation 79
Tools>Options, Model, Home 

view 13
Tools>Options, Performance, 

Model, Divisions multiplier
133

tooltip for entity 18
transoms

component 171
cylindrical 61, 139
planar 120
ruled surface 42

Trim (hydrostatics) 130
troubleshooting 5

can’t select 5
how to fix things when you get 

an error message 5

if your screen doesn’t match 
our instructions 2

keyboard doesn’t respond 5
model disappears from 

window 5
tutorials

figures 5
if your screen doesn’t match 

our instructions 2
taking a break 2
troubleshooting 5
using the online tutorials 1

typeface and symbol conventions 
4

U

u (parameter) 45
UV Snake 46

V

v (parameter) 45
View>Display>Curvature Profile 

59, 86
View>Display>Shaded 11
View>Display>Wireframe 10
View>Entity Orientation 44, 78
View>Grid 35, 37, 90
View>Marine Orientation View 

16
View>Mechanical Orientation 

View 11
View>Modify>Previous 18
View>Modify>Zoom to Area 17
View>Modify>Zoom to Selection 

18
View>Nametags,

Point 23
View>Nametags, Curve 79
View>Nametags, Surface 141
views

multiple graphics views of 
model 23

orthographic 15
perspective 15
specifying symmetry in model 

31

W

watertight seams 39, 43
wheel pan 13
wheel rotate 13
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wheel zoom 13
Which Entity? box 82
Window>Tile Horizontal 129

X

XYZ Ring 47

Z

Z axis verticl mode 11
Zcg 130
zoom in/out

with mouse 14
zoom to area

with mouse 14
Zoom to Area 17
Zoom to Area+click centers the 

model at the click point 65
Zoom to Selection 18
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