Contents

What’s New in MultiSurf 8.0

Longer Entity Names – Now 32 Characters Available.................................1
New Naming Convention Option.................................................................1
New Commands..........................................................................................2
Updated Example Files..................................................................................3
Component ....................................................................................................3
  General component issues.........................................................................4
  Load ..............................................................................................................4
  Resolving Parents dialog..........................................................................4
  Resolving Names dialog............................................................................5
  *NEW* The Component in the Entity Manager .......................................8
  *NEW* Changing the Component Order...............................................9
  *NEW* Editing Individual Components in the Entity Manager...............9
  *NEW* Make Internal .............................................................................10
  *NEW* Current .......................................................................................10
  Save.........................................................................................................10
  Selecting the component entities............................................................11
  Saving the component file........................................................................11
New Model Options Dialog.........................................................................13
Mouse Wheel Zoom Preference...................................................................14
Latest Crypkey .............................................................................................14

Index ...........................................................................................................16
What’s New in MultiSurf 8.0

The new functionality added in the release of MultiSurf 8.0 is summarized as follows:

- Longer Entity Names
- New Naming Convention Option
- New Command Window Commands
- Updated Example Files
- Component Enhancements
- Model Options Shown at File/New
- Mouse Wheel Zoom Preference
- New Crypkey version (7.6)

Longer Entity Names – Now 32 Characters Available

New Naming Convention Option

In the Entity Tab of the Tools/Options dialog there is a new check box. Here you are able to choose one of two naming conventions. The default option is a new scheme which DOES NOT use the names of previously named entities, of the same class, to use as a basis for newly created entities. Should you choose to keep the same naming convention always used by MultiSurf/, check the box to keep the traditional naming techniques.
New Commands

- **LoadComponent**: `filename.ext` name [prefix]
  with parent entities selected (order is significant).
  Default file extension is .MC2.
  If prefix is 1, use name as prefix to entity names; if prefix is 0, no prefix is used; default is 1.

- **SequenceDigits**: `digits`
  Sets (or displays) model-level attribute controlling the number of digits to use in program-generated sequences of entity names, like pt001, pt002, pt003...
Updated Example Files

The sample files for all entity types have been updated to reflect the current best practices. Nearly every model contains embedded text (using the new Text Label entity type) to help explain the major point the model illustrates. These new files are located at the default location of:

C:\ Program Files\ AeroHydro\ MultiSurf\ Examples. Please have a look!

Component

MultiSurf components provide the ability to paste groups of geometrically related entities (a “component”) into a model (the “host” model), without having to construct the component entity-by-entity. Component files have the extension .MC2.

Generally, you make a component by saving a selected portion of an existing MultiSurf model (the “source” model). When MultiSurf saves a component file, it includes all the component’s parents from the source model as hidden entities in the
component file. That way, you can open a component using File>Open (set "Files of type:" to "All Files (*.*)"). You would do this to:

- **View the component** in its native setting. Show-Hide>Show All or ⊡ to see its parents.
- **Edit the component**. Edit the entities in the component just as you would edit the entities in a model. To save the edited component, select all the entities you want to be in the component (just as you would if you were saving the component out of a model file), then File>Component>Save. For the editing/reselecting/resaving process, you may find it helpful to show the component’s parents (1st generation or more).
- **Save component as a model file**.
  
  Show-Hide>Show All or ⊡ to see its parents. File>Save As to save the component as a model file (.MS2).

### General component issues

**Parents**: A component essentially is a chunk taken out of a MultiSurf model. As such, its dependencies usually are incomplete (like a fish out of water) — it needs parent(s). The host model parent(s) must be akin to those in the source model. E.g. if the component is a C-spline Lofted Surface that had 3 master curve parents in its source model, the parents for the component in the host model must be 3 entities that qualify as curves (curves, snakes, points).

**Orientation**: Beyond kinship between source and host parents, there is the matter of matching orientation (t for curves and snakes; u,v and normal orientation for surfaces) between source and host. If a component’s attachment to a host surface is with magnets, the host surface must have u,v running in the same direction as the source surface.

### Load

Imports the contents of a MultiSurf component file (.MC2). For a component to work correctly, its parents and orientation must be compatible with the host model (see **General component issues** above and the examples in Tutorial "Working with Components"). You may preselect the required parents or select them in the Resolving Parents dialog. If you preselect parents, select them in the correct order (of course, if you miss, you can always reselect them in the dialog box). For examples of loading components, see Tutorial "Working with Components".

### Resolving Parents dialog

**Required parents**. The number of parents required is shown after the heading. In the list box, the required parents are listed in order. Each entry states the kind of entity required (point, curve, surface, etc.). The name which follows is the name that parent had in the source model from which the component was saved. This name is included for reference only; the parent in the host model can have a completely different name. But note that if parents are not pre-selected and an appropriate parent of the same name exists, MultiSurf does the selection itself.
Selected parents. The number of parents selected is shown after the heading. When all the necessary parents have been selected, this number will be the same as the number of required parents. Each entry displays either *EMPTY* (no parent selected) or the entity type and the entity name of the parent chosen from the host model.

To specify a parent, highlight the parent in the "Selected Parent" list, then pick the parent using the "Available parents" list box. Either double click the parent or select the parent and click on <Select ^ >.

Available parents. This box lists the entities available as parents for the selected "Required parent" entity. To choose a parent, double-click it in the list, or highlight it and then click the <Select ^ > button.

<OK> moves you on to the Resolving Names dialog.

32-character entity names: If the component you are loading contains one or more entities with 32-character names AND there are name conflicts, you will be notified that name conflict resolution cannot proceed. To fix the problem, you will need to: <OK> the message box, open either the component or the component’s source model, edit the names of one or more entities, and save the component again.

<Cancel> cancels the component loading process and returns you to the drawing.

Resolving Names dialog

Prefix. *NEW* All component entities can have a prefix whether there is a name conflict or not. A prefix could give the user a big advantage in a large model to determine the structure and inter-connection of entities in a model. As shown in the first Resolving Names dialog below, the prefix field is blank. The field following reports the number of name conflicts which exist between the component entities and the host model entities. In this case there are no conflicts and a prefix would not be required. The radio button “Do not add prefix” is selected indicating the user preference. To the left of the conflicts field is the notation of the maximum number of characters remaining available for the prefix.
**NEW** Component Name  All components must have a name. They are now listed in the Entity Manager for enhanced editing. In the Resolving Names dialog below the required name has been added. All entities will be added to the model without a prefix and in the Entity Manager this component can be located under the Components heading as “Hull”. Should the user desire a prefix, the “Use component name as prefix” radio button would be checked. The component would be named “Hull” and all entities names, in the added component, would be similar to: “Hull.entity_name”. MultiSurf now uses a period to separate component prefixes from entity names.

**Resolving Name Conflicts**  In the first Resolving Names dialog example below we are loading a constant camber deck on to the hull previously loaded. There are two name conflicts and we no longer have the option of not using a prefix. The prefix is required to resolve the conflict. There cannot be two entities in the model with the same name. It is also noted that the prefix doubles as the component name.
The <OK> button will not be active until name conflicts have been resolved. To resolve name conflicts, type a prefix into the Prefix field. This prefix will be added to all component entity names. Here is an example:

<OK> loads the component; the component’s entities are all selected. This makes it easy to move all the component entities to a new layer, or to Delete the component if you don’t like the result. You can also use Undo to remove the component if the Load result is tangled or confusing.

<Cancel> cancels the component loading process and returns you to the drawing.

(Note for those of you who look at or edit model files as text: the identifying message, entities, and remarks of the component appear at the end of the host model file.)
*NEW* The Component in the Entity Manager

New Component Heading
The model we have been using as an example was created by loading multiple components which can now easily be seen by looking under the new Component Heading in the Entity Manager.

Each component is listed by name and arranged in a tree format similar to the model as a whole. These can be used as a model tree within a tree to separate components and simplify the
**NEW** Changing the Component Order

There are many enhancements added to the Entity Manager regarding the editing of components. It has been our intention to keep them apart from the model and easily influence the component as a whole with the use of the context sensitive (right click) menu.

Right click on the Component heading and two choices are provided:

**Load** – Load a component

**NEW** Change order – Choose this and you will get the following dialog:

Select various components and use the arrow buttons to move the components to the desired order.

**NEW** Editing Individual Components in the Entity Manager

Right click on a component name in the Entity Manager and you will be presented with the following choices:

**Select** Selects all the entities in a component. Useful for query purposes, changing layers, and Multiple Edit.

**Delete** Deletes all component entities and removes it from the Entity Manager.

**Show** Changes the visibility state of all component entities to “visible”.

**Hide** Changes the visibility state of all component entities to “not visible”.

understanding of complex models.
*NEW* Make Internal

At some point it may be desired to fold the contents of a component into the main body of the model. This could be advantageous when removing prefixes is needed or if a minor construction component was added for efficiency, but it does not need to be separated from the model with its own heading. We call this action Make Internal. During this action, any prefix is stripped and the component heading is removed. The action of stripping the prefix could result in name conflicts, which can be resolved in the following dialog:

![Make Internal dialog](image)

*NEW* Current

A Current Component is similar to a Current Layer. All subsequent insertions of entities will be added to the Current Component.

Save

Saves a selected set of (nominally) related entities into a component file (.MC2). This component can then be loaded into another host model (as long as the host contains suitable parent entities for the component), or it can be opened to begin a new model or simply to view it in its native setting (Show-Hide>Show All or ![Show All button](image) to see its parents).

For examples of saving components, see Tutorial "Working with Components".

**Note about component entity names**: When you are saving a component, you will probably want to avoid entity names that are 32 characters long (the maximum entity name length). Because... when you load a component into a host model, if there are any component entity names which are the same as host model entity names, you will be required to specify a "prefix" that will be added to all the component entity names. If any component entity names already are 32 characters long, adding a prefix...
What's New in MultiSurf 8.0 Component

will be impossible and you will have to go back and save your component anew, with different names.

Selecting the component entities

Whether you are saving a component from a model file (.MS2) or from a component file (.MC2) you opened and have edited, before choosing **Component>Save**, you need to select the entities that will comprise the component. In doing this, you will probably find **(Select>Parents>First Generation)** and **(Select>Children> First Generation)** useful. There are several ways you might do this:

Suppose, for example, that you want to make a component from a keel that is attached to a hull surface with magnets:

- **You could select the keel surface(s), then do a series of** **(Select>Parents>First Generation)** until the parent that would be added was the hull — you’d cancel from that one (because you don’t want the hull in the component), then choose **Component>Save**.

- **Or you could select the keel surfaces, then choose Select>Parents>All Generations** — this would select more entities than you want, but you could then use **<Ctrl>+click** to get rid of the unwanted ones from the graphic view (yes, in a complex model, this could get messy).

- **Or ... you could select the magnet(s) that attach the keel to the hull, then choose Select>Children>All Generations.**

- **If you use a relabel entity, be sure to check dependencies in both directions** (parents and children), because these entities often are little side branches in the dependency tree (and as well, they aren’t visible).

- **Or, of course, you could select the entities one-by-one in the drawing — but that could be very tedious, and you’d run the risk of missing hidden entities and non-visible entities such as Relabels this way (oops!).**

You can use the Selection Set pane to see (and change if need be) a list of the entities you’ve selected to include in the component.

Saving the component file

With the component entities selected, it’s time to select **File>Component>Save**.

**Parent(s).** This list displays the kinds of parents the component will require when it is loaded into another model. The entity name is the name of the parent in the current or “source” model (that is, the model from which you are saving the component). It is listed as a way of helping you keep track of connections. The parents in any future host model are not required to (although they may) have the same parent names as in the source model.
**NEW** Change Order Button  This is used in the case the list of Parents are in an inconvenient order for re-insertion into a model. Please look at the images below to see the list of Parents required for insertion. For this component the ‘bead’ parent will be the only one changed and the two variables will be taken from already existing entities. The bead should be at the top of the list. For pre-selection of parents the best solution is to select a bead, and on Component/Load the new bead will be the only entity which needs to be selected. The two variables will automatically be added to the Resolving Parents list.

Identifying message. Type in an identifying message for the component. This message will be put in the heading of the component file and inserted into any host models when the component is loaded into them.

<OK> takes you on to the Save Component dialog where you can specify a filename (and path) for the component. You will be warned if any component entity names are 32 characters long.

<Cancel> returns you to the drawing with the Selection Set intact.
New Model Options Dialog
Mouse Wheel Zoom Preference

The setting, to reverse the mouse wheel zoom direction, can be found on the General tab of the Options dialog.

Latest Crypkey

The copyright protection software, Crypkey, has been updated to the latest version.
Index

<table>
<thead>
<tr>
<th>Component (File Menu) 3</th>
<th>Load 4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Save 10</td>
</tr>
<tr>
<td>components</td>
<td></td>
</tr>
<tr>
<td>32-character object names 5, 10</td>
<td></td>
</tr>
<tr>
<td>beginning a new model 4</td>
<td></td>
</tr>
<tr>
<td>editing 4</td>
<td></td>
</tr>
<tr>
<td>filename extension 3</td>
<td></td>
</tr>
<tr>
<td>issues 4</td>
<td></td>
</tr>
<tr>
<td>loading 4</td>
<td></td>
</tr>
<tr>
<td>opening 4</td>
<td></td>
</tr>
<tr>
<td>orientation 4</td>
<td></td>
</tr>
<tr>
<td>parents 3, 4</td>
<td></td>
</tr>
<tr>
<td>prefix 5</td>
<td></td>
</tr>
<tr>
<td>resolving names 5</td>
<td></td>
</tr>
<tr>
<td>resolving supports 4</td>
<td></td>
</tr>
<tr>
<td>saving 10</td>
<td></td>
</tr>
<tr>
<td>selecting entities for 10</td>
<td></td>
</tr>
<tr>
<td>viewing 4</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>F File Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component 3</td>
</tr>
<tr>
<td>files</td>
</tr>
<tr>
<td>component 3</td>
</tr>
<tr>
<td>MC2 3</td>
</tr>
</tbody>
</table>

| M MC2 files 3        |

| P prefix (in Load>Component) 5 |

<table>
<thead>
<tr>
<th>R Resolving Names dialog 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resolving Supports dialog 4</td>
</tr>
</tbody>
</table>

| S selecting               |